We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

OC 3.0.4.2: Incorrect default values?

Hi all,
On my installation of OpenClinica (version 3.0.4.2), this CRF is populated
with default values of "last option checked in radio button group", both on
"View default" and during actual data entry. Would someone please check to
see if the same thing happens on your installation?
Best regards,
Janus
(See attached file: ITSQ_v1.0.zip)
Attachments:
ITSQ_v1.0.zip 19.0 KB

Comments

  • GerbenRienkGerbenRienk Posts: 810 ✭✭✭
    Hello Janus,
    I tested your CRF and the result is the same. And that is as expected,
    because your options are seven zero-length-strings. And you do not specify
    a default, so your default is also zero-length, so they are all the same
    as the default, but only one can get "selected", so it's the last one in
    line.
    And that's a nice trick you did in the header! Please put it in the wiki.
    Regards,
    Gerben Rienk
    > >
    > > Hi all,
    > >
    > > On my installation of OpenClinica (version 3.0.4.2), this CRF is populated
    > > with default values of "last option checked in radio button group", both
    > > on
    > > "View default" and during actual data entry. Would someone please check to
    > > see if the same thing happens on your installation?
    > >
    > > Best regards,
    > > Janus
    > >
    > > (See attached file:
    > > ITSQ_v1.0.zip)
  • kristiakesourcekristiakesource Posts: 133
    Hello Janus,
    I tried your CRF in 3.1 and use CHECKBOX instead of RADIOBUTTON. The
    nothing get selected by default. On the other hand you can select several.
    And I agree with Gerben, your very smart trick in the HEADER was a strike of
    genius, where did you pick it up. I have looked many times but never found
    it in the documentation.
    Regards
    Krister
    -----Original Message-----
    On Behalf Of Gerben Rienk Visser
    Sent: 28 June 2011 16:26
    To: [email protected]
    Subject: Re: [Users] OC 3.0.4.2: Incorrect default values?
    Hello Janus,
    I tested your CRF and the result is the same. And that is as expected,
    because your options are seven zero-length-strings. And you do not specify a
    default, so your default is also zero-length, so they are all the same as
    the default, but only one can get "selected", so it's the last one in line.
    And that's a nice trick you did in the header! Please put it in the wiki.
    Regards,
    Gerben Rienk
    > >
    > > Hi all,
    > >
    > > On my installation of OpenClinica (version 3.0.4.2), this CRF is
    > > populated with default values of "last option checked in radio button
    > > group", both on "View default" and during actual data entry. Would
    > > someone please check to see if the same thing happens on your
    > > installation?
    > >
    > > Best regards,
    > > Janus
    > >
    > > (See attached file:
    > > ITSQ_v1.0.zip)
  • JanusJanus Posts: 260
    Hi Krister and Gerben,
    Thanks for checking the CRF. Gerben, your explanation of why the last items
    is selected makes perfect sense, although I will interpret it as a "side
    effect"-bug :) I'll post at the Mantis page.
    And thank you for your kind comments regarding the layout of the header :)
    I use this layout for all my CRFs as I find the default layout rather dull
    and I needed a clear differentiation between the header and subheaders.
    I'll post it at the wiki, thanks for reminding me (Gerben and I have
    already talked about this some months ago, but I forgot).
    Best regards,
    Janus

    "Krister
    Kristianson"

    Sent by: cc
    [email protected]
    nclinica.org Subject
    Re: [Users] OC 3.0.4.2: Incorrect
    default values?
    28-06-2011 21:28


    Please respond to
    [email protected]
    .org


    Hello Janus,
    I tried your CRF in 3.1 and use CHECKBOX instead of RADIOBUTTON. The
    nothing get selected by default. On the other hand you can select several.
    And I agree with Gerben, your very smart trick in the HEADER was a strike
    of
    genius, where did you pick it up. I have looked many times but never found
    it in the documentation.
    Regards
    Krister
    -----Original Message-----
    On Behalf Of Gerben Rienk Visser
    Sent: 28 June 2011 16:26
    To: [email protected]
    Subject: Re: [Users] OC 3.0.4.2: Incorrect default values?
    Hello Janus,
    I tested your CRF and the result is the same. And that is as expected,
    because your options are seven zero-length-strings. And you do not specify
    a
    default, so your default is also zero-length, so they are all the same as
    the default, but only one can get "selected", so it's the last one in line.
    And that's a nice trick you did in the header! Please put it in the wiki.
    Regards,
    Gerben Rienk
    > >
    > > Hi all,
    > >
    > > On my installation of OpenClinica (version 3.0.4.2), this CRF is
    > > populated with default values of "last option checked in radio button
    > > group", both on "View default" and during actual data entry. Would
    > > someone please check to see if the same thing happens on your
    > > installation?
    > >
    > > Best regards,
    > > Janus
    > >
    > > (See attached file:
    > > ITSQ_v1.0.zip)
  • JanusJanus Posts: 260
    http://en.wikibooks.org/wiki/OpenClinica_User_Manual
    Link under the CRF section
    :)
    Best regards,
    Janus

    "Krister
    Kristianson"

    Sent by: cc
    [email protected]
    nclinica.org Subject
    Re: [Users] OC 3.0.4.2: Incorrect
    default values?
    28-06-2011 21:28


    Please respond to
    [email protected]
    .org


    Hello Janus,
    I tried your CRF in 3.1 and use CHECKBOX instead of RADIOBUTTON. The
    nothing get selected by default. On the other hand you can select several.
    And I agree with Gerben, your very smart trick in the HEADER was a strike
    of
    genius, where did you pick it up. I have looked many times but never found
    it in the documentation.
    Regards
    Krister
    -----Original Message-----
    On Behalf Of Gerben Rienk Visser
    Sent: 28 June 2011 16:26
    To: [email protected]
    Subject: Re: [Users] OC 3.0.4.2: Incorrect default values?
    Hello Janus,
    I tested your CRF and the result is the same. And that is as expected,
    because your options are seven zero-length-strings. And you do not specify
    a
    default, so your default is also zero-length, so they are all the same as
    the default, but only one can get "selected", so it's the last one in line.
    And that's a nice trick you did in the header! Please put it in the wiki.
    Regards,
    Gerben Rienk
    > >
    > > Hi all,
    > >
    > > On my installation of OpenClinica (version 3.0.4.2), this CRF is
    > > populated with default values of "last option checked in radio button
    > > group", both on "View default" and during actual data entry. Would
    > > someone please check to see if the same thing happens on your
    > > installation?
    > >
    > > Best regards,
    > > Janus
    > >
    > > (See attached file:
    > > ITSQ_v1.0.zip)
This discussion has been closed.