We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

[Developers] Problem when rule runs Oops!, a problem has occured

kristiakkristiak Posts: 1,334 ✭✭✭
Hi Gerben,

The entire issue is resolved. It was due to a mail configuration problem and thanks to Shaun I was directed to a very useful web site that helped me identifying the issue. http://www.webpan.com/Customers/Email/SMTP_Authentication_Telnet_Test.htm

Have a continued nice week-end

Regards

Krister
ica.org] On Behalf Of Krister Kristianson
Sent: 28 January 2012 15:45
To: Gerben Rienk; [email protected]; [email protected]
Subject: [Developers] Problem when rule runs Oops!, a problem has occured

Hi Gerben,

Sorry to bother you on the week-end but I have discovered a peculiar problem. I have you seen this before. Its again the AE page that is causing my headache. The page works perfectly OK as long as I have not activated the rule that you looked at earlier today.

The rule is set to fire and send me an e-mail message when the AE is classified as serious. When I run it manually everything is fine but from the CRF the following happens:


First I see: There are issue(s) with your submission. The data has NOT been saved. See below for details. I guess this is expected. I then issue a discrepancy note and SAVE the form again:

Then the ugly “Oops! An error has occurred” shows up. When I hit “Or click here to go back to where you came from.”, I’m put back into the subject matrix with the following error message:

“You are trying to begin data entry for a CRF within a Study Event, but the subject does not exist within the study.”
No e-mail messages are issued!!
Could this possibly be caused by problems connecting to mail email system?

I attach the AE form and the 2 rules that I ran.

Regards

Krister
This discussion has been closed.