We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

OpenClinica Slowness

Hello OC users,

Has anyone run in the problem of OpenClinica becoming very slow when many users are using the system, and if yes, what was your solution, from a technical perspective, other than reducing CRF size, limiting number of rules and so on?

Our OC specs are below:

VMware ESX 4.1 machine
OS: Windows 2003 SP2 32 bit
Processor: Intel Xeon x5680 3.33 GHz running 4 cores
Ram: 4 GB DDR3
HDD: Equalogic SAN with SAS Harddrives on RAID 10
Network: 10Gb to SAN 1 Gb to LAN

Thank you,

Mihai Virtosu
University of Utah
«1

Comments

  • GerbenRienkGerbenRienk Posts: 803 ✭✭✭
    Hello Mihai,
    That's quite some hardware ;-)
    You did not mention the settings for tomcat and for postgres.
    If you did not tweak postgres, try
    effective_cahce_size=2GB
    Kind regards,
    Gerben Rienk
    > > Hello OC users,
    > >
    > > Has anyone run in the problem of OpenClinica becoming very slow when many
    > > users are using the system, and if yes, what was your solution, from a
    > > technical perspective, other than reducing CRF size, limiting number of
    > > rules and so on?
    > >
    > > Our OC specs are below:
    > >
    > > VMware ESX 4.1 machine
    > > OS: Windows 2003 SP2 32 bit
    > > Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    > > Ram: 4 GB DDR3
    > > HDD: Equalogic SAN with SAS Harddrives on RAID 10
    > > Network: 10Gb to SAN 1 Gb to LAN
    > >
    > > Thank you,
    > >
    > > Mihai Virtosu
    > > University of Utah
    > >
    > >
  • Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    > >Hello Mihai,
    > >
    > >That's quite some hardware ;-)
    > >You did not mention the settings for tomcat and for postgres.
    > >If you did not tweak postgres, try
    > >effective_cahce_size=2GB
    > >Kind regards,
    > >
    > >Gerben Rienk
    > >
    >> >> Hello OC users,
    >> >>
    >> >> Has anyone run in the problem of OpenClinica becoming very slow when
    >> >>many
    >> >> users are using the system, and if yes, what was your solution, from a
    >> >> technical perspective, other than reducing CRF size, limiting number of
    >> >> rules and so on?
    >> >>
    >> >> Our OC specs are below:
    >> >>
    >> >> VMware ESX 4.1 machine
    >> >> OS: Windows 2003 SP2 32 bit
    >> >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> >> Ram: 4 GB DDR3
    >> >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> >> Network: 10Gb to SAN 1 Gb to LAN
    >> >>
    >> >> Thank you,
    >> >>
    >> >> Mihai Virtosu
    >> >> University of Utah
    >> >>
    >> >>
  • Please remove me from this distribution list.
    Thank you.
    ----- Reply message -----
    From: "Richard Brookes"
    To: "[email protected]"
    Subject: [Users] OpenClinica Slowness
    Date: Thu, Feb 21, 2013 1:27 pm
    Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    >Hello Mihai,
    >
    >That's quite some hardware ;-)
    >You did not mention the settings for tomcat and for postgres.
    >If you did not tweak postgres, try
    >effective_cahce_size=2GB
    >Kind regards,
    >
    >Gerben Rienk
    >
    >> Hello OC users,
    >>
    >> Has anyone run in the problem of OpenClinica becoming very slow when
    >>many
    >> users are using the system, and if yes, what was your solution, from a
    >> technical perspective, other than reducing CRF size, limiting number of
    >> rules and so on?
    >>
    >> Our OC specs are below:
    >>
    >> VMware ESX 4.1 machine
    >> OS: Windows 2003 SP2 32 bit
    >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> Ram: 4 GB DDR3
    >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> Network: 10Gb to SAN 1 Gb to LAN
    >>
    >> Thank you,
    >>
    >> Mihai Virtosu
    >> University of Utah
    >>
    >>
  • SyntaxSyntax Posts: 34
    Hi Mihai,

    Monitoring your server with all key performance counters (e.g. processor, memory, disk) will let you know what’s going on inside during high user activities.

    Also scheduled PostgreSQL’s database VACCUUM will help increase database performance, optimize Tomcat (java) setting also help.

    Btw, what version of OC you are referring to?

    Note: If any of your user is working on dataset, it consumes a lot of server’s resources, other users will be able to notify OC slower response during dataset processing period.

    Cheers,
    Montri
    Sent: Friday, February 22, 2013 12:33 AM
    To: [email protected]
    Subject: [Users] OpenClinica Slowness

    Hello OC users,

    Has anyone run in the problem of OpenClinica becoming very slow when many users are using the system, and if yes, what was your solution, from a technical perspective, other than reducing CRF size, limiting number of rules and so on?

    Our OC specs are below:

    VMware ESX 4.1 machine
    OS: Windows 2003 SP2 32 bit
    Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    Ram: 4 GB DDR3
    HDD: Equalogic SAN with SAS Harddrives on RAID 10
    Network: 10Gb to SAN 1 Gb to LAN

    Thank you,

    Mihai Virtosu
    University of Utah
  • mx8866mx8866 Posts: 109
    Hi Gerben,
    Where should I add this line for postgres configuration?
    > >If you did not tweak postgres, try
    > >effective_cahce_size=2GB
    Thanks
    May
    -----Original Message-----
    Sent: Thursday, February 21, 2013 3:24 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness
    Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    > >Hello Mihai,
    > >
    > >That's quite some hardware ;-)
    > >You did not mention the settings for tomcat and for postgres.
    > >If you did not tweak postgres, try
    > >effective_cahce_size=2GB
    > >Kind regards,
    > >
    > >Gerben Rienk
    > >
    >> >> Hello OC users,
    >> >>
    >> >> Has anyone run in the problem of OpenClinica becoming very slow when
    >> >>many users are using the system, and if yes, what was your solution,
    > >>from a technical perspective, other than reducing CRF size, limiting
    >> >>number of rules and so on?
    >> >>
    >> >> Our OC specs are below:
    >> >>
    >> >> VMware ESX 4.1 machine
    >> >> OS: Windows 2003 SP2 32 bit
    >> >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> >> Ram: 4 GB DDR3
    >> >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> >> Network: 10Gb to SAN 1 Gb to LAN
    >> >>
    >> >> Thank you,
    >> >>
    >> >> Mihai Virtosu
    >> >> University of Utah
    >> >>
    >> >>
  • mvirtosumvirtosu Posts: 276 ✭✭
    Montri,

    Thank you for your response. We are currently using version 3.0.4.2.

    I believe we are already vacuuming the database every night.

    And thanks for the pointer on the dataset extraction. Does anyone know if there is a table/log with all datasets extractions and their date and time?

    Thanks again,

    Mihai
    Sent: Thursday, February 21, 2013 6:54 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness

    Hi Mihai,

    Monitoring your server with all key performance counters (e.g. processor, memory, disk) will let you know what’s going on inside during high user activities.

    Also scheduled PostgreSQL’s database VACCUUM will help increase database performance, optimize Tomcat (java) setting also help.

    Btw, what version of OC you are referring to?

    Note: If any of your user is working on dataset, it consumes a lot of server’s resources, other users will be able to notify OC slower response during dataset processing period.

    Cheers,
    Montri
    Sent: Friday, February 22, 2013 12:33 AM
    To: [email protected]
    Subject: [Users] OpenClinica Slowness

    Hello OC users,

    Has anyone run in the problem of OpenClinica becoming very slow when many users are using the system, and if yes, what was your solution, from a technical perspective, other than reducing CRF size, limiting number of rules and so on?

    Our OC specs are below:

    VMware ESX 4.1 machine
    OS: Windows 2003 SP2 32 bit
    Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    Ram: 4 GB DDR3
    HDD: Equalogic SAN with SAS Harddrives on RAID 10
    Network: 10Gb to SAN 1 Gb to LAN

    Thank you,

    Mihai Virtosu
    University of Utah
  • mvirtosumvirtosu Posts: 276 ✭✭
    Richard,
    We are still using 3.0.4.2 and hence do not have a choice of log level.
    Thanks,
    Mihai
    -----Original Message-----
    Sent: Thursday, February 21, 2013 2:24 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness
    Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    > >Hello Mihai,
    > >
    > >That's quite some hardware ;-)
    > >You did not mention the settings for tomcat and for postgres.
    > >If you did not tweak postgres, try
    > >effective_cahce_size=2GB
    > >Kind regards,
    > >
    > >Gerben Rienk
    > >
    >> >> Hello OC users,
    >> >>
    >> >> Has anyone run in the problem of OpenClinica becoming very slow when
    >> >>many users are using the system, and if yes, what was your solution,
    > >>from a technical perspective, other than reducing CRF size, limiting
    >> >>number of rules and so on?
    >> >>
    >> >> Our OC specs are below:
    >> >>
    >> >> VMware ESX 4.1 machine
    >> >> OS: Windows 2003 SP2 32 bit
    >> >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> >> Ram: 4 GB DDR3
    >> >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> >> Network: 10Gb to SAN 1 Gb to LAN
    >> >>
    >> >> Thank you,
    >> >>
    >> >> Mihai Virtosu
    >> >> University of Utah
    >> >>
    >> >>
  • jamuna269jamuna269 Posts: 109
    Hi Mihai,
    There is a table called archived_file_dataset and it should have the information about which file was extracted when.
    Thanks
    Jamuna
    On Fri, Feb 22, 2013 at 11:56 AM, Mihai Virtosu wrote:
    Richard,
    We are still using 3.0.4.2 and hence do not have a choice of log level.
    Thanks,
    Mihai
    -----Original Message-----
    Sent: Thursday, February 21, 2013 2:24 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness
    Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    >Hello Mihai,
    >
    >That's quite some hardware ;-)
    >You did not mention the settings for tomcat and for postgres.
    >If you did not tweak postgres, try
    >effective_cahce_size=2GB
    >Kind regards,
    >
    >Gerben Rienk
    >
    >> Hello OC users,
    >>
    >> Has anyone run in the problem of OpenClinica becoming very slow when
    >>many users are using the system, and if yes, what was your solution,
    >>from a technical perspective, other than reducing CRF size, limiting
    >>number of rules and so on?
    >>
    >> Our OC specs are below:
    >>
    >> VMware ESX 4.1 machine
    >> OS: Windows 2003 SP2 32 bit
    >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> Ram: 4 GB DDR3
    >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> Network: 10Gb to SAN 1 Gb to LAN
    >>
    >> Thank you,
    >>
    >> Mihai Virtosu
    >> University of Utah
    >>
    >>
  • GerbenRienkGerbenRienk Posts: 803 ✭✭✭
    Hi May,
    I misspelled that: it should be
    effective_cache_size=2GB
    and it's under QUERY TUNING, section Planner Cost Constants
    in your postgresql.conf, located for example in
    /etc/postgresql/8.3/main/postgresql.conf
    The 2GB is 50% of the memory Mihai reported.
    By default this is set very conservatively, in order to let postgres start
    under all conditions.
    Kind regards,
    Gerben Rienk
    -----Oorspronkelijk bericht-----
    Van: [email protected] [mailto:[email protected]]
    Namens Xi, Xuemei
    Verzonden: vrijdag 22 februari 2013 14:19
    Aan: [email protected]
    Onderwerp: Re: [Users] OpenClinica Slowness
    Hi Gerben,
    Where should I add this line for postgres configuration?
    > >If you did not tweak postgres, try
    > >effective_cahce_size=2GB
    Thanks
    May
    -----Original Message-----
    On Behalf Of Richard Brookes
    Sent: Thursday, February 21, 2013 3:24 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness
    Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    > >Hello Mihai,
    > >
    > >That's quite some hardware ;-)
    > >You did not mention the settings for tomcat and for postgres.
    > >If you did not tweak postgres, try
    > >effective_cahce_size=2GB
    > >Kind regards,
    > >
    > >Gerben Rienk
    > >
    >> >> Hello OC users,
    >> >>
    >> >> Has anyone run in the problem of OpenClinica becoming very slow when
    >> >>many users are using the system, and if yes, what was your solution,
    > >>from a technical perspective, other than reducing CRF size, limiting
    >> >>number of rules and so on?
    >> >>
    >> >> Our OC specs are below:
    >> >>
    >> >> VMware ESX 4.1 machine
    >> >> OS: Windows 2003 SP2 32 bit
    >> >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> >> Ram: 4 GB DDR3
    >> >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> >> Network: 10Gb to SAN 1 Gb to LAN
    >> >>
    >> >> Thank you,
    >> >>
    >> >> Mihai Virtosu
    >> >> University of Utah
    >> >>
    >> >>
  • mvirtosumvirtosu Posts: 276 ✭✭
    Thanks Jamuna!

    May I suggest adding a time component to “date_created”?

    Mihai
    Sent: Friday, February 22, 2013 12:05 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness

    Hi Mihai,
    There is a table called archived_file_dataset and it should have the information about which file was extracted when.
    Thanks
    Jamuna

    On Fri, Feb 22, 2013 at 11:56 AM, Mihai Virtosu wrote:
    Richard,
    We are still using 3.0.4.2 and hence do not have a choice of log level.
    Thanks,
    Mihai
    -----Original Message-----
    Sent: Thursday, February 21, 2013 2:24 PM
    To: [email protected]
    Subject: Re: [Users] OpenClinica Slowness
    Hi,
    Could it be caused by the logging level chosen?
    Richard
    On 22/02/13 6:56 AM, "Gerben Rienk" wrote:
    >Hello Mihai,
    >
    >That's quite some hardware ;-)
    >You did not mention the settings for tomcat and for postgres.
    >If you did not tweak postgres, try
    >effective_cahce_size=2GB
    >Kind regards,
    >
    >Gerben Rienk
    >
    >> Hello OC users,
    >>
    >> Has anyone run in the problem of OpenClinica becoming very slow when
    >>many users are using the system, and if yes, what was your solution,
    >>from a technical perspective, other than reducing CRF size, limiting
    >>number of rules and so on?
    >>
    >> Our OC specs are below:
    >>
    >> VMware ESX 4.1 machine
    >> OS: Windows 2003 SP2 32 bit
    >> Processor: Intel Xeon x5680 3.33 GHz running 4 cores
    >> Ram: 4 GB DDR3
    >> HDD: Equalogic SAN with SAS Harddrives on RAID 10
    >> Network: 10Gb to SAN 1 Gb to LAN
    >>
    >> Thank you,
    >>
    >> Mihai Virtosu
    >> University of Utah
    >>
    >>
This discussion has been closed.