We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Export problems!

Hello all,

Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:

The extract data job failed with the message:
For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
More information may be available in the log files.

However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.

Any clue what this could be?

Regards

Krister

Comments

  • kristiakesourcekristiakesource Posts: 133
    Hello all,

    Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:

    The extract data job failed with the message:
    For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
    More information may be available in the log files.

    However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.

    Any clue what this could be?

    Regards

    Krister
  • leandroamparoleandroamparo Posts: 15
    hello,
    i had this problem a while ago with the exports also. the problem a found is that our operating system was running in brazilian portuguese and OC was in american english. so, our date formats are different, in portuguese we use DD/MM/AAAA and american is MM/DD/AAAA, so i thought that might be the problem. so, as we had about 5 patients only, we decided to install everything again, with the OS in english, as well as OC. now the export is working fine.
    hope that could be of some help
    leandro.
    On 14 May 2013 05:31, Krister Kristianson beta-JUDO, Uppsala University wrote:
    Hello all,

    Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:

    The extract data job failed with the message:
    For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
    More information may be available in the log files.

    However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.

    Any clue what this could be?

    Regards

    Krister
  • wolfwolf Posts: 4
    Hello Krister,
    we had the same problem. The reason was the language setting of the operating system (our system was set to German). When we switched the language of the operating system to English, all worked fine. Our assumption is that it is related to the format of numbers (decimal point vs comma).
    Good luck, Wolf
    On 05/14/2013 10:31 AM, Krister Kristianson beta-JUDO, Uppsala University wrote:
    >
    > Hello all,
    >
    >
    >
    > Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:
    >
    >
    >
    > The extract data job failed with the message:
    >
    > For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
    >
    > More information may be available in the log files.
    >
    >
    >
    > However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.
    >
    >
    >
    > Any clue what this could be?
    >
    >
    >
    > Regards
    >
    >
    >
    > Krister
    >
    >
    >
    >
    >
  • kristiakkristiak Posts: 1,334 ✭✭✭
    Hi Leandro,

    Why did I not think of this reason? That explains why it works fine on my laptop were the operating system is English. The server has ben installed by the hosting company, although I told them I wanted a US/English installation maybe they did not do it properly.

    Thanks and regards

    Krister
    Sent: Tuesday, May 14, 2013 4:42 PM
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] Export problems!

    hello,
    i had this problem a while ago with the exports also. the problem a found is that our operating system was running in brazilian portuguese and OC was in american english. so, our date formats are different, in portuguese we use DD/MM/AAAA and american is MM/DD/AAAA, so i thought that might be the problem. so, as we had about 5 patients only, we decided to install everything again, with the OS in english, as well as OC. now the export is working fine.
    hope that could be of some help
    leandro.

    On 14 May 2013 05:31, Krister Kristianson beta-JUDO, Uppsala University wrote:
    Hello all,

    Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:

    The extract data job failed with the message:
    For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
    More information may be available in the log files.

    However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.

    Any clue what this could be?

    Regards

    Krister
  • kristiakkristiak Posts: 1,334 ✭✭✭
    Thanks Wolf,

    I have checked and it seems that you are correct. The Operatingsystem is indeed in Swedish although we had ordered an English system.

    We will change it.

    Thanks and regards

    Krister
    Sent: Tuesday, May 14, 2013 9:03 PM
    To: [email protected]
    Subject: Re: [Developers] Export problems!

    Hello Krister,
    we had the same problem. The reason was the language setting of the operating system (our system was set to German). When we switched the language of the operating system to English, all worked fine. Our assumption is that it is related to the format of numbers (decimal point vs comma).
    Good luck, Wolf
    On 05/14/2013 10:31 AM, Krister Kristianson beta-JUDO, Uppsala University wrote:
    Hello all,

    Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:

    The extract data job failed with the message:
    For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
    More information may be available in the log files.

    However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.

    Any clue what this could be?

    Regards

    Krister
  • leandroamparoleandroamparo Posts: 15
    hi krister,
    i
    did the same thing for a while, worked fine on my laptop too, but not on the server. as i had that kind of problem with another system, i thought that might be the problem, and luckily it was. it's working fine now. hope it does work for you too.
    good luck
    leandro.
    On 16 May 2013 08:39, Krister Kristianson wrote:
    Hi Leandro,

    Why did I not think of this reason? That explains why it works fine on my laptop were the operating system is English. The server has ben installed by the hosting company, although I told them I wanted a US/English installation maybe they did not do it properly.

    Thanks and regards

    Krister
    Sent: Tuesday, May 14, 2013 4:42 PM
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] Export problems!

    hello,
    i had this problem a while ago with the exports also. the problem a found is that our operating system was running in brazilian portuguese and OC was in american english. so, our date formats are different, in portuguese we use DD/MM/AAAA and american is MM/DD/AAAA, so i thought that might be the problem. so, as we had about 5 patients only, we decided to install everything again, with the OS in english, as well as OC. now the export is working fine.
    hope that could be of some help
    leandro.

    On 14 May 2013 05:31, Krister Kristianson beta-JUDO, Uppsala University wrote:
    Hello all,

    Anyone seen something like this? We have a 300 patient database running in OC 3.1.3.1 on a Windows 2008 R2 server and everything works fine with one quirk. When we try to export the data as Excel or any other text output we get the following error message:

    The extract data job failed with the message:
    For input string: "1,6" (This number is different depending on what text mode you select, e.g. for HTML it is “2,2”)
    More information may be available in the log files.

    However the export as ODM works fine. The strange thing is, though, after we have used one of the ODM options, the Excel or any other text option also works as expected (in most cases). Even more puzzling is the fact, if we do a PG dump backup and restore to a Windows 7 laptop, the it works normally in text mode as well as ODM exports.

    Any clue what this could be?

    Regards

    Krister
This discussion has been closed.