We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Maven repository down?

Hello,

I'm trying to setup development environment and have dependencies installation issues right after git clone. It seems maven can't download from https://dev.openclinica.org/artifactory/. Maven claims it can't verify security certificate, but if I try to open repo URL in browser I get 403 Service Temporarily Unavailable error. Is it down for some reason or am I having some other setup problem?

Portion of the maven log:

[INFO] ------------------------------------------------------------------------
[INFO] Building OpenClinica
[INFO]    task-segment: [clean, install]
[INFO] ------------------------------------------------------------------------
Downloading: https://dev.openclinica.com/artifactory/plugins-release/org/apache/maven/wagon/wagon-provider-api/1.0-beta-2/wagon-provider-api-1.0-beta-2.pom
[WARNING] Unable to get resource 'org.apache.maven.wagon:wagon-provider-api:pom:1.0-beta-2' from repository central (https://dev.openclinica.com/artifactory/plugins-release): Error transferring file: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
...
Downloading: https://dev.openclinica.com/artifactory/libs-snapshot/org/apache/maven/shared/file-management/1.2.1/file-management-1.2.1.jar
[WARNING] Unable to get resource 'org.apache.maven.shared:file-management:jar:1.2.1' from repository snapshots (https://dev.openclinica.com/artifactory/libs-snapshot): Error transferring file: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Downloading: http://repository.jboss.org/nexus/content/groups/public//org/apache/maven/shared/file-management/1.2.1/file-management-1.2.1.jar
[INFO] Unable to find resource 'org.apache.maven.shared:file-management:jar:1.2.1' in repository jboss-public-repository-group (http://repository.jboss.org/nexus/content/groups/public/)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.
Tagged:

Comments

  • GuppiGuppi Posts: 14
    Hello adevaykin,

    Trunk branch works fine for me (maven 3.0.5). Try to use 3.0.5 or 3.1.1.
    Also, next link can be useful:

    Guppi
  • max_fraimax_frai Posts: 2

    Hi guys!

    I'm having the same issue on trunk

    [ERROR] Plugin org.codehaus.mojo:buildnumber-maven-plugin:1.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:buildnumber-maven-plugin:jar:1.3: Could not transfer artifact org.codehaus.mojo:buildnumber-maven-plugin:pom:1.3 from/to central (https://dev.openclinica.com/artifactory/plugins-release): peer not authenticated -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1]
    http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException

    Tried both versions of maven 3.0.5 and 3.1.0 - still getting this error.

    I hope that you will be able to advice me some solution.

    Best, Max



  • drakosdrakos Posts: 16
    edited January 2015

    Hello,

    I'm having the exact same problem as max_frai:

    [ERROR] Plugin org.codehaus.mojo:buildnumber-maven-plugin:1.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.codehaus.mojo:buildnumber-maven-plugin:jar:1.3: Could not transfer artifact org.codehaus.mojo:buildnumber-maven-plugin:pom:1.3 from/to central (https://dev.openclinica.com/artifactory/plugins-release): peer not authenticated -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException


    Any help will be greatly appreciated.


    Best,

    Ioannis.

  • drakosdrakos Posts: 16

    Hello again,

    eventually I solved the problem by adding "-Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true" to the mvn command.

    The issue was caused by maven not trusting the ssl certificate.

    I hope this also solves your problems.


    Best,

    Ioannis.

  • max_fraimax_frai Posts: 2

    Good day,

    Thank you Ioannis - your solution works for me to!


    Best, Max

  • adevaykinadevaykin Posts: 7
    Thanks Ioannis, it worked indeed!
  • drakosdrakos Posts: 16

    Hi Max and Adevaykin,

    I'm glad to hear that the solution is working for you too.

    If you are interested in a system wide solution for the certificate issues you can have a look here.


    Regards,
    Ioannis

This discussion has been closed.