Please join your peers on either March 26 (8pm GMT) or March 28 (8am GMT) to watch as user extraordinaire and forum legend @"lindsay.stevens" demonstrates OpenClinica Insight.

See preview and register at

Insight makes it easy to ask questions of ALL of your clinical and operational data and visualize answers via interactive reports and dashboards. The idea is simple, but the results are powerful: ask your questions, choose your visualizations, then return often for updated, interactive results that link you to all of the underlying data.

Error: Cannot get Open Clinica to work , getting listener error

I cannot get Open Clinica 3.4.1 to open using

Tomcat is installed properly but for some reason the OpenClinica folder in webapps folder cannot be accessed by the web browser..

I have attached the catallina.log files, I hope someone is able to help me with this.. Thanks.



  • rmcbarnettrmcbarnett Posts: 2
    Can someone help me please?
  • libowenlibowen Posts: 13
    Same environment (jdk, postgresql, tomcat), openclinica 3.4.1 does not work but openclinica 3.3 works.

    In the log file, "SEVERE: Error listenerStart"
  • GerbenRienkGerbenRienk Posts: 772 ✭✭✭
    Did you check if user tomcat is the owner of the dir tomcat/webapps? If not, issue a 
    chown -R tomcat:tomcat 
    Hope this helps,
    Gerben Rienk
  • libowenlibowen Posts: 13
    The Error listenerStart is caused by postgreSQL authentication. I found out by adding the /WEB-INF/classes/ file

    org.apache.catalina.core.ContainerBase.[Catalina].level = INFO
    org.apache.catalina.core.ContainerBase.[Catalina].handlers = java.util.logging.Consol

    There are two files:

    Change the dbPass field in both files and restart tomcat will solve the problem.
  • yogiyogi Posts: 25

    i got the same error and only with Version 3.5. I´m wondering because if i rename the folder from i.e. webapps/dev-OpenClinica35 to webapps/dev-OpenClinica35.test it works and OpenClinica have an postgreSQL connection. The Logfile from Tomcat says "SEVERE: Error listenerStart". Makes this sence? I also searched for an second properties file but there issn´t one and i used the standard war file from the community edition.

    I look forward that i find the mistake but i very interessed if someone else have same problems.

  • ebsebs Posts: 119 ✭✭
    My understanding of the deployment is that the second file is only created after the initial deployment of the web app is performed.

    "Important change in 3.4: The first time you install OpenClinica you will configure here: c:\oc\tomcat\webapps\OpenClinica\WEB-INF\classes\ Consequent configuration changes SHOULD be made here c:\oc\tomcat\webapps\openclinica.config."

    So you should do the following:
    1. Copy war file to webapps
    2. Start Tomcat
    3. Wait for it to be deployed
    4. Stop Tomcat
    5. Delete war file from webapps
    6. Change the file in C:\oc\tomcat\openclinica.config
    7. Restart Tomcat
    8. Cross fingers for luck - optional step ;-)
  • yogiyogi Posts: 25

    ah ok thank you! I missed this information in my documentation. So now the problem is not solved because i think my infrastructure is not so simple.
    I have two tomcats on an centOS. I want to install openclinica in the following path /usr/share/tomcat6live/webapps/dev-OpenClinica35 so i deploy the war file in
    the webapps folder, ok. Then i setup the file and restart the tomcat instance but i get the same error. And i can´t find any openclinica.config file in the folders.

    I try to copy the file in the folder ./tomcat6live/ and ./tomcat6live/webapps but this also don´t resolve the issue. An error of the userrights is not possible in my
    opinion because all rights are setup correctly.

    is the User tomcat needed for openclinica since 3.4?

    Any Ideas?

  • ebsebs Posts: 119 ✭✭
    " i can´t find any openclinica.config file in the folders."

    You should have the file /usr/share/openclinica.config/ - Note that openclinica.config is a directory/folder name.

    Are there any relevant messages in any of the files in /logs?
  • GerbenRienkGerbenRienk Posts: 772 ✭✭✭
    Hi Holger,
    I was only succesful in starting OC35 with tomcat7.
    Kind regards,
    Gerben Rienk
  • yogiyogi Posts: 25
    Hi Gerben,

    oh thats an intressting fact. Thank you for this tipp. I will check that i can update the tomcat version.
    At the moment i can say that OC3.5 is starting but not with an other webbapp name than openclinica in tomcat6.

    Thanks an best,

Sign In or Register to comment.