We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Problems installing WEB services in OC 3.5 & 2.6



  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    via Email
    The settings are mostly identical between OpenClinica and OpenClinica-ws.

    In fact if you are not manually specifying the webapp names, the {WEBAPP.
    lower} placeholder will take care of the differences for you. At runtime
    this placeholder is replaced with the webapp folder name.

    If you are manually specifying the webapp names, once you have OpenClinica
    working, copy its datainfo into the openclinica-ws.config folder. The only
    things to change are sysUrl, the data dir, and log dir. In these three
    settings you should just change references from OpenClinica to

    I'm not sure how I can make this clearer. Perhaps post your datainfo files
    for us.
  • kristiakkristiak Posts: 1,334 ✭✭✭
    There are two datainfo.properties files or rather 4 when you use WS. Should they all be the identical- I will attach the two from C:\OC\Tomcat\openclinica-config and from C:\oc\Tomcat\OpenClinica-ws-config.
    I would be so kind of you if you would have chance to take a look.
    Is this new location of the config files also relevant for the email configuration. I have not been able to get that to work either.
    Best regards

  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    via Email
    Ill have a look soon, but I can say now that the folder paths are

    They should be lower case, with a period not a hyphen, like this:


  • kristiakkristiak Posts: 1,334 ✭✭✭
    Sorry that was just a typo :) in my message. The real folders are spelt correctly!
  • kristiakkristiak Posts: 1,334 ✭✭✭
    I changed the settings to just "OpenClinica" and now openclinica-ws shows up in the Tomcat manager. But when I type I still get an eror message. Should I not get the welcome page?
  • ebsebs Posts: 137 ✭✭
    You should see a welcome page rather than an error - but note that you can't login to the WebServices section.

    It is worth reviewing the installation notes which are on GitHub - there are specific sections which refer to Web Services - https://github.com/OpenClinica/OpenClinica/wiki/Install-OpenClinica-3.6-on-Windows

    Also do you have any specific error messages in the log files?
  • kristiakkristiak Posts: 1,334 ✭✭✭
    I have followed the specific instructions to the letter, I see in the Tomcat manager the WS is up and running, but but when I try all I get is an eror message.
    I have attached two relevant log files!
  • kristiakkristiak Posts: 1,334 ✭✭✭
    It used to work very well in 3.1 but here it gives me an headache!! :)
  • kristiakkristiak Posts: 1,334 ✭✭✭
    Should configurations for mail services also ONLY be made in the \tomcat\openclinica.config\datainfo.properties
    There are no notes in the latest manual about mail!
  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    I had a look at your datainfo files from earlier.

    In both datainfo.properties:
    - LINE 14: dbType=postgres
    - LINE 15: dbUser=clinica
    - LINE 16: dbPass=ABetterPasswordThanJustClinica
    - LINE 17: db=openclinica
    - LINE 18: dbPort=5432
    - LINE 19: dbHost=localhost

    In openclinica.config/datainfo.properties:
    - LINE 32: filePath=${catalina.home}/openclinica.data/
    - LINE 112: sysURL=http://localhost:8080/OpenClinica
    - LINE 135: log.dir=${catalina.home}/logs/openclinica/
    - LINE 71: your admin email address
    - LINE 85-95: your smtp email settings

    In openclinica-ws.config/datainfo.properties:
    - LINE 32: filePath=${catalina.home}/openclinica-ws.data/
    - LINE 112: sysURL=http://localhost:8080/OpenClinica-ws
    - LINE 135: log.dir=${catalina.home}/logs/openclinica-ws/

    In the above, ${catalina.home} is substituted with the environment variable CATALINA_HOME at run time. You can replace it with the absolute path, e.g. C:/oc/tomcat/logs/openclinica/

    Make sure that the following directories exist:

    Lastly, in the access logs you sent there are remote requests logged there - probably best to change your firewall settings so that only your computer can connect while you are doing this setup stuff. Also your smtp password was included in the datainfo files you sent so you might want to change it.
This discussion has been closed.