Rule Designer - Need Help

Hi Community,

https://forums.openclinica.com/discussion/15108/rule-designer-now-open-source

Following the above post after download Designer1.2.war, When I open link http://xx.xx.x.x:8080/Designer/, I below page is displayed


And from OpenClinica On the Tasks menu-> Build Study > Create Rules >Rule Designer I get
http://localhost:8080/OpenClinica/oauth/user/authorize?client_id=designer&redirect_uri=http://designer13.openclinica.com/access?host=http://localhost:8080&app=OpenClinica&study_oid=S_PID_TEST&provider_user=root&path=pages/studymodule&response_type=code

changes made in
vi /var/lib/tomcat7/webapps/Designer/WEB-INF/classes/META-INF/spring/applicationContext-security.xml



what changes am I missing?

Thanks in advance

Kavita
Tagged:

Comments

  • ebsebs Posts: 107
    edited January 2016
    It looks like the URL being used has changed in the latest version of OC. Try editing the URL in your browser to get the Rules Designer to load. If you are successful then try and identify what config files are being used in the building of the URL and change them.

    I would start by removing the redirect section.

    ***** Just noticed that your screen shot is OCRD 1.2 but the URL is looking for 1.3, I guess you need to get OCRD 1.3 rather than 1.2 See here - https://forums.openclinica.com/discussion/15784/rule-designer-open-to-all-no-registration-needed#latest
    *****

    I haven't looked anything post OC3.5/OCRD1.2 so can't give specifics.

    If you can post any progress/solution then that would help others out in future.

    Good luck.
  • toskriptoskrip Posts: 247 ✭✭
    Hi @KavitaRege ,

    have you solved your issue? The screenshot you shared basically says that you have successfully deployed Designer locally on your server. URL that you get from your OC when you want to build a new rule looks incorrect for the scenario when you are using locally installed rule designer.

    Did you set the designerURL property in datainfo.properties file of your OC instance?:

    designerURL=http://xx.xx.x.x:8080/Designer/

    And you should also modify Designer resources.properties:
    /var/lib/tomcat7/webapps/Designer/WEB-INF/classes/resources.properties

    in this configuration file the "allowHosts" property should include your OC instance hostname (something like: yourOCHostName:8080)

    + don't forget to restart the tomcat

    Tomas
  • KavitaRegeKavitaRege Posts: 27
    edited February 2016
    Hi Tomas,

    Sorry for late reply, was on other project for sometime.

    Is this setting correct? or am I missing something?
    <oauth:resource accessTokenUri="http://xx.x.x.xx:8080/OpenClinica/" clientId="designer" id="ocInstance" type="authorization_code" userAuthorizationUri="http://xx.x.x.xx:8080/OpenClinica/"/>
    2. When I place the mouse on the icon of Rule Designer in Build Study page it points to
    https://designer13.openclinica.com/access?host=http://localhost:8080&app=OpenClinica&study_oid=S_PID_TEST&provider_user=root&path=pages/studymodule

    allowHosts=xx.xx.x.xx:8080,svn.akazaresearch.com:8444,...........

    designerURL=http://xx.xx.x.xx:8080/Designer-1.2/
  • olivercrsolivercrs Posts: 5
    Hello,

    I have been having the same problem; I am now getting to the rule designer but it is giving me an error.

    I have examined the logs and found the following errors that come up following a tomcat restart:

    AUTHPRIV DEBUG o.a.o.d.c.CoreResources:388 - Portal URL NOT Defined in datainfo
    AUTHPRIV DEBUG o.a.o.d.c.CoreResources:395 - Module Manager URL NOT Defined in datainfo

    There is no where in datainfo to configure these that I can see and the Sysurl is sysURL=opc-clinics.org${WEBAPP}/MainMenu.

    The URL that Open Clinica is trying to link to is:
    https://designer13.openclinica.com/access?host=opc-clinics.org&app=OpenClinica&study_oid=S_DEFAULTS1&provider_user=root&path=pages/studymodule

    Which appears correct to me but I get:

    Resource Not Found

    Sorry, we did not find the resource you were looking for.


    Does anyone have any ideas?
  • GerbenRienkGerbenRienk Posts: 745 ✭✭✭
    Hi Oliver,
    Try putting http or https in front of the URL:
    sysURL=https://opc-clinics.org/${WEBAPP}/MainMenu
    Kind regards,
    Gerben Rienk
Sign In or Register to comment.