Please join your peers on either March 26 (8pm GMT) or March 28 (8am GMT) to watch as user extraordinaire and forum legend @"lindsay.stevens" demonstrates OpenClinica Insight.

See preview and register at

Insight makes it easy to ask questions of ALL of your clinical and operational data and visualize answers via interactive reports and dashboards. The idea is simple, but the results are powerful: ask your questions, choose your visualizations, then return often for updated, interactive results that link you to all of the underlying data.

Deploying OpenClinica

I am running Ubuntu 16.04 LTS
Apache Tomcat/7.0.68
PostgreSQL 9.5.3

I am trying to deploy OpenClinica 3.11 within Tomcat

I have set up the folders and as instructed.
I have also successfully deployed a sample "Hello World" applet through Tomcat.

However, trying to access localhost:8080/OpenClinica results in

"HTTP Status 404 - /OpenClinica

type Status report

message /OpenClinica

description The requested resource is not available."

I have tried to deploy the OpenClinica.war file in the webapps folder in /usr/share/tomcat7

I would appreciate a little bit of guidance on this issue, things to check etc. The fact that Tomcat successfully deploys a sample applet but not OC makes me think that there may be compatibility issues, or additional requirements for OC to work.


  • jguptajgupta Posts: 27
    Hope you made all the necessary configuration changes in properties file, else it will not work.
  • yura.grabovskayura.grabovska Posts: 6
    edited June 2016

  • jguptajgupta Posts: 27
    Stop your tomcat.
    Make sure the changes you made changes to both places/tomcat/webapps/openclinica/WEB-INF/classes/
    and one in tomcat/openclinica.config/
    Start tomcat again
  • yura.grabovskayura.grabovska Posts: 6
    Both identical and still 404
  • kristiakkristiak Posts: 1,278 ✭✭✭
    I have noted that rebooting sometimes helps! Have you tried that?
  • ebsebs Posts: 118 ✭✭
    filePath should point to your folder. It may be that the folder must be named

    I'm also cautious not to use hyphens in the paths. This caused an issue in my deployment with Rules Designer previously.
  • yura.grabovskayura.grabovska Posts: 6
    via Email
    This is an excellent tip. I will check this today.
Sign In or Register to comment.