Cannot create Dataset

Hi,

I have a problem with creating dataset: After defining fields and scope and setting name and description I proceed to "Confirm and Save" -everything seems to be ok, but after confirm I'm landing back on the page with Name and Description. The system writes, that "Name and Description fields are required", pretending I haven't defined it yet. No error page, only always returning to name definition.

I've tried almost everything (different scopes, different Items, names..), but it doesn't work.
I have no special symbols, CRF's have null-values.

Could anyone please give a hint, what is going on here? Maybe there is a problem with general settings?

Unfortunately I'm not IT-administrator and I haven't done the installation, but maybe you can give a hint where to search for the problem?

Kind regards,
Maria Ostanina
UKSH Lübeck
Germany

Answers

  • GerbenRienkGerbenRienk Posts: 712 ✭✭✭
    Hi Maria,
    Is this the first time you try to create a dataset, or were you successful earlier? And did you look in the logs? They are a bit hard to read because of the abundance of details, but it helps if you:
    - stop tomcat
    - delete all logs
    - start tomcat
    - try to create a dataset
    Could you do that and report back what you find?
    Many thanks,
    Gerben Rienk
  • haenselhaensel Posts: 530 ✭✭
    edited October 2016
    Hi Maria

    Neither can I reproduce this issue nor did I have ever seen this issue before. Nonetheless it's very likely that this issue is related to your browsers localization settings and/or the language of the operating system the OC server runs on.
    You can check your browsers local settings using the w3.org checker (link [1]). If there is neither "en" nor "en_US" in the "Accept-Language" field try if changing this field helps (set "en" at the first position). Detailed information on how to change the language settings for different browser are described at link [2]. Please don't forget to reset the configuration after you finished your tests.
    If this helps please refer your administrator to link [3]. Although this is not the same problem the solution might help although.

    If nothing of the before mentioned helps please tell us which OC version you use.

    Regards,
    Christian Hänsel


    [1] http://validator.w3.org/i18n-checker/
    [2] https://www.w3.org/International/questions/qa-lang-priorities#changing
    [3] https://en.wikibooks.org/wiki/OpenClinica_User_Manual/PopupCalendar

    ------------------------------------------------------------------------

    Dipl.-Inf. Christian Hänsel

    IT / Software Developer

    Tel.: +49-(0)89-5526189-16
    Fax : +49-(0)89-5526189-55
    E-Mail: c.haensel@reliatec.de

    ReliaTec GmbH
    Schleissheimer Str. 37
    85748 Garching Germany
    HRB 150060 / AG München
    Gf Thomas Herbig
    http://www.reliatec.de

    =========================================================================
  • mostaninamostanina Posts: 2
    Hi,

    thank you for your answers, I finally got time to try this out, but unlikely it didn't work.
    - That's the first time I'm trying to create a dataset, so it has never been succesful before.
    - Deleting logs as you described didn't help.
    - Internationalization is ok, so it doesn't depend on this.
    - I'm using 3.11 version

    I have attached the log file. Here is a quote from the log file, that I found strange:

    10/14 09:48:51 [] AUTHPRIV WARN username o.a.o.d.e.DatasetDAO:508 - found no object: SELECT * FROM DATASET WHERE
    name = ? and study_id=? dfg
    10/14 09:48:53 [] FTP INFO username o.a.o.c.e.CreateDatasetServlet:455 - reached confirm all


    I would be very grateful if you can help me further or have any idea what can be wrong?

    Kind regards,
    Maria Ostanina
  • haenselhaensel Posts: 530 ✭✭
    mostanina said:


    - Internationalization is ok, so it doesn't depend on this.

    Hi Maria

    Did you checked the browser configuration and did your admin checked the Tomcat configuration? I'm sorry that this didn't helped.
    We do use OC-3.11 but hadn't any problem creating a dataset so far. The create dataset function is in OC for a long time and there where no major changes to it. So it should work straight away.

    Regards,
    Christian
  • haenselhaensel Posts: 530 ✭✭
    edited October 2016
    Hi Maria

    I just inspected the attached log file. The line you found in the logs
    mostanina said:


    10/14 09:48:53 [] FTP INFO username o.a.o.c.e.CreateDatasetServlet:455 - reached confirm all

    is immediate before the line where the localization problem occurs.

    If you can describe what you did to check if the "internationalization is ok" I can say if we both talk about the same thing.

    Regards,
    Christian
  • GerbenRienkGerbenRienk Posts: 712 ✭✭✭
    Hi Maria,
    Sorry to be returning to this mail after such a long time, but: did you solve it? If not, could you confirm that user tomcat has access to /usr/local/tomcat/openclinica.data and all children?
    Kind regards,
    Gerben Rienk
Sign In or Register to comment.