Please join your peers on either March 26 (8pm GMT) or March 28 (8am GMT) to watch as user extraordinaire and forum legend @"lindsay.stevens" demonstrates OpenClinica Insight.

See preview and register at https://openclinica.com/insight-webinar

Insight makes it easy to ask questions of ALL of your clinical and operational data and visualize answers via interactive reports and dashboards. The idea is simple, but the results are powerful: ask your questions, choose your visualizations, then return often for updated, interactive results that link you to all of the underlying data.

Schedule csv notes extraction

13

Comments

  • GerbenRienkGerbenRienk Posts: 763 ✭✭✭
    Hi Romain,
    In an earlier you post you mentioned that you re-installed OpenClinica and octest. Did you undeploy the apps, or did you remove them from webapps? If so, try to stop tomcat, remove the contents of /usr/local/tomcat/work and then start tomcat again.
    Kind regards,
    Gerben Rienk
  • RCHENURCHENU Posts: 195
    Thanks both of you for your help. I tried a lot of things and I did what you are suggesting but I can try again, maybe I'm missing something or not doing it in the right order.
    To be sure, you want me to:
    1. rm -rf OpenClinica and rm -rf octest from webapps
    2. unzip OpenClinica.war -d OpenClinica and unzip octest.war -d octest
    3. cp -rf OpenClinica* /usr/local/tomcat/webapps and cp -rf octest* /usr/local/tomcat/webapps
    4. rm -rf ./work

    Am I correct ?

    Thanks again,
    Romain.
  • GerbenRienkGerbenRienk Posts: 763 ✭✭✭
    edited March 2017
    Hi Romain,
    No, what I meant was:
    stop tomcat
    rm -rf /usr/local/tomcat/work/*
    start tomcat
    When you access your apps for the first time tomcat will "re-compile" them, so you have a fresh start. It will take a bit more time to start, though, but after the first run it should be the same as before.
    Hope this helps,
    Gerben Rienk
  • haenselhaensel Posts: 570 ✭✭
    I'm curious about it.

    Good luck
  • RCHENURCHENU Posts: 195
    I did did that a lot and it didn't change a thing. I will try it again but if you have any other solution...
    The fact that it is only the discrepancy servlet can't help you?
    Romain
  • haenselhaensel Posts: 570 ✭✭
    I tried to reproduce your issue but I had no luck with it. Can you provide further information about your runtime environment?

    Regards,
    Christian
  • RCHENURCHENU Posts: 195
    Yes it's a vm with centos 7, postgres 8.4, tomcat 7 and java 1.7 (I think there is also 1.6 and 1.8 on it) and OC 3.12
  • haenselhaensel Posts: 570 ✭✭
    Hi Romain

    There is no obvious reason that it isn't working with your setup.
    It seems as if it isn't possible to solve your issue remote.

    Regards,
    Christian
  • RCHENURCHENU Posts: 195
    Well, I hope we'll find a solution because I can't do without the note extraction.
    Gerben told me to reindex the database. I'll try that and keep you inform. Meanwhile, if you think about something, do not hesitate :-)
  • haenselhaensel Posts: 570 ✭✭
    The reason it fails has to do with the resource bundle system that is responsible for all the translations etc. It is worth a try to check Gerben's suggestion but can you think of a way to make your vm accessible for download?

    Regards,
    Christian
Sign In or Register to comment.