Job Extraction

Hello,

I created an export data job and I noticed that my files are stored on the server in a new directory called "datasetsdatasets" instead of the directory "datasets" where the other datasets are stored.

Could you confirm that it is a normal behaviour and not a bug that job extractions are in a directory and the other extractions are in another directory ?

Thank you,

Romain.

Comments

  • mvirtosumvirtosu Posts: 275
    Romain,

    This is a five-year old bug. Scheduled exports are created in "datasetsdatasets" folder, while manually-run exports are created in "datasets". Here is a JIRA ticket for this, and even though its status is "done", it is not:

    https://jira.openclinica.com/browse/OC-2093

    Hope this helps,

    Mihai
  • RCHENURCHENU Posts: 179
    Thank you for your quick reply.
    As long as it works and stays like this, it's ok for me.
    I'm writing scripts to run some tasks automatically and I want to be sure which directory to use.
    I'm also not sure if the naming of the files works properly, I have to check because I ran an extract job today and in the naming it was yesterday's date...

    Romain.
  • mvirtosumvirtosu Posts: 275
    Romain,

    The folder is consistent, I also have automatic scripts and never had a problem.

    The date in the file will be the date when you originally scheduled the extract job. I configure OpenClinica to overwrite and not zip export files, that way there will always be only one export file at all times and that makes it easy to know which file you need to read in.

    Hope this helps,

    Mihai
  • RCHENURCHENU Posts: 179
    Ok, that is an important point !!! That means that my script will not work for the moment... what parameters do you update to be sure to have only one file in this folder ? That will do the trick !

    Romain.
  • mvirtosumvirtosu Posts: 275
    edited January 3
    In extract.properties, I have the following settings for all export formats:

    extract.N.zip=false
    extract.N.deleteOld=true

    I think you need to edit or re-create your export job after you change those settings, otherwise they won't take effect.

    Mihai
  • RCHENURCHENU Posts: 179
    Ok ! Thanks for the tip. I'm going to try that and see if it works.

    Thanks a lot !

    Romain.
  • mvirtosumvirtosu Posts: 275
    You are welcome!

    Mihai
  • RCHENURCHENU Posts: 179
    In extract.properties, (for the SPSS extraction), deleteOld is commented. I've just run 2 job extractions and I only have one file at a time in the folder so I guess that by default, old extraction are deleted...
  • RCHENURCHENU Posts: 179
    Everything seems to work now.
    Thanks @mvirtosu !
Sign In or Register to comment.