FAIL - Application at context path /OpenClinica could not be started

13»

Comments

  • kristiakkristiak Posts: 1,197 ✭✭✭
    If this does not do the trick I see no other way around it but reinstalling. What version of OC are you working with? Normally an fresh OC installation takes about 20 minutes.
  • sebastianvsebastianv Posts: 16
    Reinstalled Postgresql 9.6 and Openclinica 3.12. Installed Tomcat 7 instead of 8.5. However, the problem reappears.

    I have attached the catalina and localhost log. Would anybody be able to resolve this?

    Thanks
  • kristiakkristiak Posts: 1,197 ✭✭✭
    Then you must have missed something during the installation process and to try to find the error is more time consuming than to reinstall, carefully following every step!
    By the way, what does POSTGRE look like using the manager.
    I would try POSTGRE 8.5 instead of 9.6.
  • sebastianvsebastianv Posts: 16
    Right, so got it working. It seems to have to do with the versions of the various applications. The configuration that works for me on Windows 10 Home:

    Openclinica 3.12.2
    JDK 1.8.0.121
    PostgreSQL 9.5.5
    Tomcat 7.0.73

    It only started working after downgrading PostgreSQL, so it may be possible that Openclinica could work under a higher version of Tomcat, but I won't be testing this (don't want to risk messing up my currently working version)

    Hope this will be useful to others. It may be a good idea for the OpenClinica team to keep OpenClinica working on the latest versions of all the supporting software as to ensure maximum security with minimum bugs. I do however understand that this requires a fair bit of work.
  • kristiakkristiak Posts: 1,197 ✭✭✭
    Great you got it to work. Yes it is correct, the OC team has never said it could work with PG above 9.5 and Tomcat 7. I'm not sure why. There are some other issues with PG 9.5 but merely looks, when you import an export file from another version it gibes you ab error message mut it does not mean anything.
  • haenselhaensel Posts: 530 ✭✭
    Hi personally have little experience with running OpenClinica under windows.

    All required softwares are of the latest versions.

    This might be an issue. Unfortunately OpenClinica isn't compatible to latest version. I highly recommend to use the versions linked in the installation description but maybe you'll be lucky with this configuration .

    Can you check the file
    org/akaza/openclinica/applicationContext-core-db.xml

    and check the configuration for

    <bean id="dataSource" ...>

    The interesting part is

    <property name="username" value="s[username]"/> <property name="password" value="s[password]"/>

    If this is the same on your installation try to replace the values with the username and password from your datainfo.properties (just for debugging purpose). Restart Tomcat and have a look at the localhost.*.log again.

    Regards,
    Christian
  • haenselhaensel Posts: 530 ✭✭
    Ok that was to late.

    Happy testing
  • GerbenRienkGerbenRienk Posts: 720 ✭✭✭
    Hi Sebastian,
    It looks like you're using tomcat 8.5 and OpenClinica only runs on tomcat 7.
    Kind regards,
    Gerben Rienk
  • GerbenRienkGerbenRienk Posts: 720 ✭✭✭
    And I was too late as well :-)
    Looks like some posts were queued and took some time to make it to the forum.
Sign In or Register to comment.