Cannot get the MainMenu (Default Main Page) of OpenClinica working on Ubuntu 16.04

indu.srinivasacharindu.srinivasachar Posts: 9
edited February 8 in Installation & Setup
Hi:
I have installed following version of software:
apache0 tomcat 9.0.0.M15
java-9-oracle
postgresql- 8.4
Openclinica 3.12.2
OS: Ununtu 16.04
I have verified the tomcat is working fine. I have verified that postgresql also is cofigured properly. I have followed all the steps as per the installation instruction of Openclinica but when I open up http://localhost:8080/OpenClinica/ I get the following message "requested resource not available". (as in the screenshot below. )


I have attached all the log files. for your reference. I do not see any obvious issue in the setup. Pls help me in getting the page working.
Regards,
Indu


«1

Comments

  • ebsebs Posts: 107
    Java 9!

    OC isn't even on 8 yet.
  • I had java 7 also installed and I reverted back to use Java 7 , shutdown and restarted tomcat but still the error is same.
  • kristiakkristiak Posts: 1,243 ✭✭✭
    Have you edited c:/oc/tomcat/openclinica.config/datainfo,properties ??
  • haenselhaensel Posts: 550 ✭✭
    Hi Indu

    The installation procedure might differ for tomcat 9 as the locations might differ.
    I can't see any hint in the catalina*.log that tomcat tries to start OpenClinica so my first gues is that OpenClinica isn't installed properly or not at the right location. But localhost_access_log*.log states that accessing 127.0.0.1/OpenClinica was successful. Can you see the login page?

    Where did you installed OpenClinica to? Is it in /opt/tomcat/webapps/OpenClinica or somewhere else?

    Using different software versions then recommended is often a problem but maybe we can work it out if you provide some more details about your setup (installation locations etc.).

    Regards,
    Christian
  • Christian:
    I have reinstalled ubuntu to 15.10 and following as per recomedation.
    OS:Ubuntu 15.10
    Java: 1.7.0.80
    Apache-Tomcat:Apache Tomcat/7.0.52
    Postgres : 8.4 ( available in OpenClinica community open-source edition).'
    OpenClinica :3.12.2
    Tomcat is working fine and opens up the tomcat page when I load localhost:8080.
    But the Openclinica still doesn't open up the main page and when I try to access localhost:8080/OpenClinica
    I get the below screenshot.

    Seems like database was getting migrated to Oracale for some reason and got into error inbetween. Attached are the logs Please help me to resolve this issue. The remaining.logs are empty so did not attach them.
    Regards,
    Indu
  • haenselhaensel Posts: 550 ✭✭
    Hi Indu

    Your
    localhost.2017-02-10.log
    contains the following error message.

    Caused by: org.postgresql.util.PSQLException: FATAL: password authentication failed for user "clinica"


    Did you modified datainfo.properties (probably in /opt/tomcat/openclinica.config) and set the database user and password correct?

    You can check your username and password on the console using the following command
    psql -h 127.0.0.1 -U clinica -W openclinica


    Regards,
    Christian
  • haenselhaensel Posts: 550 ✭✭
    I've overseen that the migration scripts had run allready so the database connection must have been successful at some point.
  • haenselhaensel Posts: 550 ✭✭
    Hi Indu

    Hmm, it looks good as far as I understand the log files. The first startup takes a bit and maybe you've been to fast to try to access the login page.
    If it still doesn't open, please shutdown tomcat, delete all the logs (they are easier to read then) and restart tomcat again.
    If you're familiar with the tomcat manager you might open it and have a look at the shown status.
    At least OpenClinca has been started and you're closer to the solution then before.

    Regards,
    Christian
  • indu.srinivasacharindu.srinivasachar Posts: 9
    via Email
    Thanks a lot for the prompt reply. But the last info in the log looks like memory leak as the server ran out of memory. Now the page just hangs I restarted the tomcat server but the page doesn't come up. Even local host didn't now open the default tomcat page and app memory seems to be full. Is there any config changes for memory and if so where should I  do it. Regards, Indu

    Sent from Yahoo Mail on Android

    On Fri, Feb 10, 2017 at 3:55 PM, haensel wrote: OpenClinica https://forums.openclinica.com/
    haensel commented on Cannot get the MainMenu (Default Main Page) of OpenClinica working on Ubuntu 16.04

    Hi Indu

    Hmm, it looks good as far as I understand the log files. The first startup takes a bit and maybe you've been to fast to try to access the login page.
    If it still doesn't open, please shutdown tomcat, delete all the logs (they are easier to read then) and restart tomcat again.
    If you're familiar with the tomcat manager you might open it and have a look at the shown status.
    At least OpenClinca has been started and you're closer to the solution then before.

    Regards,
    Christian
  • haenselhaensel Posts: 550 ✭✭
    Hi Indu

    You can change the memory settings in
    /etc/default/tomcat7

    Regards,
    Christian
Sign In or Register to comment.