HTML characters in GROUP_HEADER displayed as source in administrative editing mode

ebsebs Posts: 82
Hi,

We have a CRF where HTML has been used in the GROUP_HEADER definition to apply bold formatting etc. This works fine in all cases except when editing a CRF which has been marked as complete. In that case the source is being displayed rather than the HTML formatting.

Has anyone seen this before and have a resolution?

OC is v3.4.1

Thanks
Eric

Comments

  • haenselhaensel Posts: 530 ✭✭
    edited March 9
    Hi Eric

    Unfortunally i have no resolution for you. I never used OC 3.4.x myself. But my best tip is to avoid the html formating since it appears at places where it isn't supposed to be (e.g. print view).

    Regards,
    Christian
    Post edited by haensel on
  • GerbenRienkGerbenRienk Posts: 731 ✭✭✭
    Hi Eric,
    This is the same problem as https://jira.openclinica.com/browse/OC-7664
    In the jsp-page the attibute escapeXml="false" for the header of the repeating-item-group is not set, where in initial-data-entry it is.
    I submitted a pull request for this at December 28 2016, https://github.com/OpenClinica/OpenClinica/pull/716
    Let's hope it will be included in the next release.
    Gerben Rienk
  • ebsebs Posts: 82
    Thanks Gerben.

    I've voted for it ;-)

    Cheers
    Eric

  • ccollinsccollins Posts: 361 admin
    via Email
    Thanks Gerben. Will take a look and get it into the next release.
    Best,
    Cal
Sign In or Register to comment.