We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Bug on upload images?

Dear all,

in a CRF it's necessary to upload images files (about 1MB), but OC gives a generic error (*), while TOMCAT reports this error:
[/usr/local/tomcat/webapps/OpenClinica/] FTP INFO o.a.o.s.BulkEmailSenderService:42 - Executing now...0 taskScheduler-12 0

[/usr/local/tomcat/webapps/OpenClinica/] FTP INFO o.a.o.s.BulkEmailSenderService:46 - Nothing left to do getting out...

[/usr/local/tomcat/webapps/OpenClinica/] USER ERROR root o.a.o.c.s.UploadFileServlet:607 - java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key file_upload_error_occured
at java.util.ResourceBundle.getObject(ResourceBundle.java:395)
at java.util.ResourceBundle.getString(ResourceBundle.java:355)


No errors if the I try to upload files of few kB (up 10 Kilo Bytes).

Does anyone knows what to do to fix it? I'm using OC 3.
Thanks you
davide
«1

Comments

  • kristiakkristiak Posts: 1,334 ✭✭✭
  • DavideDavide Posts: 11
    via Email
    Thank you Kristiak for your answer.

    I have a problem that is completely different :-(

    An OpenClinica BUG (probably) during CRF filling doesn't allow the USER to
    upload any kind of FILE more than 10 KB :-(

    That's it.

    2017-07-24 13:01 GMT+02:00 kristiak
    :

    > OpenClinica https://forums.openclinica.com/
    > kristiak commented on Bug on upload images?
    >
    > Hve you read this page? http://www.trialdatasolutions.
    > com/tds/howto/crfwithimage.jsp
    >
    > --
    > To manage your email notifications, please visit:
    > https://www.openclinica.com/forums#/profile/preferences
    >
    > Reply to this email directly or follow the link below to check it out:
    > https://forums.openclinica.com/discussion/comment/19155#Comment_19155
    >
    > Check it out: https://forums.openclinica.com/discussion/comment/19155#
    > Comment_19155
    >



    --
    "*Il Signore ti benedica e ti custodisca.*
    *Mostri a te la Sua faccia e abbia di te Misericordia.*
    *Volga a te il Suo sguardo e ti dia Pace.*
    *Il Signore ti Benedica.*"
  • DavideDavide Posts: 11
    Thank you Kristiak for your answer.

    I have a problem that is completely different :(

    An OpenClinica BUG (probably) during CRF filling doesn't allow the USER to upload any kind of FILE more than 10 KB :s :s :s :s :s :s :s

    That's it.
  • GerbenRienkGerbenRienk Posts: 810 ✭✭✭
    Hi Davide,
    The error message you posted was just to say that an error occurred and that the message to be displayed should be found under "file_upload_error_occured" which was not in the properties file. So we need more info of your log files, but first could you try to:
    - stop tomcat
    - delete all files and folders in the work-folder (something like /usr/local/tomcat/work)
    - delete all files in the log-folder (something like /usr/local/tomcat/logs)
    - start tomcat again

    Then try to upload a file greater than 10kb and if the problem persists, then zip all log-files and post them to the forum.
    Many thanks,

    Gerben Rienk
  • DavideDavide Posts: 11
    Hi Gerben,
    I followed the steps you suggested. I attach tomcat logs.
    Many thanks,
    Davide
  • haenselhaensel Posts: 602 ✭✭✭
    Hi Davide

    It looks like it is a problem with your language settings.
    java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key file_upload_error_occured


    Change the language settings for tomcat to use English as the default locale.
    On Debian based systems (e.g. Ubuntu) you can add
    JAVA_OPTS="${JAVA_OPTS} -Duser.language=en -Duser.country=US"
    to /etc/default/tomcat7 and restart tomcat.

    This will save you from other errors with dates or numbers but has the drawback that the user has to enter the data in the US format (e.g. 2.5 for 2,5).

    Regards,
    Christian
  • haenselhaensel Posts: 602 ✭✭✭
    Hi Davide

    Looking at it a second time shows me that this isn't the initial error but the error that occurs creating the error message.
    Since there is no other error message regarding the file upload you can send us the log files again after you did the proposed changes.

    Regards,
    Christian
  • haenselhaensel Posts: 602 ✭✭✭
    Hi Davide

    If you want to get rid of the error
    ERROR in ch.qos.logback.classic.net.SyslogAppender[SYSLOG-USAGESTATS] - Could not create SyslogWriter java.net.UnknownHostException: usage.openclinica.com
    in your log files set
    collectStats=false in datainfo.properties.

    Regards,
    Christian

    P.S. Which OS do you use?
  • DavideDavide Posts: 11
    Hi Christian,

    the OS is: CentOS Linux release 7.3.1611 (Core)

    $ uname -a
    Linux xxxxx 3.10.0-514.16.1.el7.x86_64 #1 SMP Wed Apr 12 15:04:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

    $ env | grep LANG
    LANG=it_IT.UTF-8

    Can I put the JAVA_OPTS var inside /usr/local/tomcat/bin/catalina.sh? The /etc/default/tomcat7 doesn't exist.

    Many thanks,
    Davide
  • haenselhaensel Posts: 602 ✭✭✭
    Hi Davide

    For CentOS it should be
    /usr/share/tomcat/conf/tomcat.conf

    Regards,
    Christian
Sign In or Register to comment.