We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Bug on upload images?

2»

Comments

  • haenselhaensel Posts: 602 ✭✭✭
    edited August 2017
    I do not use CentOS so it might be another place as well.

    e.g.
    /etc/systemd/system/tomcat.service

    Normally editing catalina.sh shouldn't be necessary to set the environment variables although it will likely work. There should be a setenv.sh as well.
    So maybe someone else has some experience with CentOS.
  • DavideDavide Posts: 11
    Hi Christian,
    I've implemented the suggested configurations, but the upload error remains. I was able to upload only a file of 5,1 kB... but with files of greater size, the upload fail...
    In the attachment all the tomcat logs.
    Thanks,
    Davide
  • GerbenRienkGerbenRienk Posts: 810 ✭✭✭
    Hi Davide,
    How did you setup tomcat: in /usr/local/apache-tomcat-7.0.52 with /usr/local/tomcat as a softlink? And did you let tomcat:tomcat be the owner of /usr/local/tomcat ? In the start of catalina.out is states "GRAVE: Cannot find specified temporary folder at /usr/local/tomcat/temp" and that's strange.
    Can you check that?
    Many thanks,
    Gerben Rienk
  • haenselhaensel Posts: 602 ✭✭✭
    Hi Davide
    Davide said:

    Hi Christian,
    I've implemented the suggested configurations,

    It looks like the configuration did not work. The log file still says 'INFORMAZIONI' instead of 'INFORMATION'.

    And did you let tomcat:tomcat be the owner of /usr/local/tomcat?

    Following Gerbens suggestion will probably solve the upload problem but I highly recommend to also change the language settings.

    Regards,
    Christian
  • DavideDavide Posts: 11
    Hi Gerbens, Christian,
    now it work, many thanks for your support! I've uploaded a 2.1MB file.

    Christian:
    $ env | grep LANG
    LANG=it_IT.UTF-8

    maybe is this the problem? In the /etc/rc.d/init.d/tomcat I've modified as:

    ...
    # DM20170830 https://forums.openclinica.com/discussion/comment/19240#Comment_19240
    export JAVA_OPTS="$JAVA_OPTS -Duser.language=en -Duser.country=US -Xmx1280m -XX:+UseParallelGC -XX:ParallelGCThreads=1 -XX:MaxPermSize=180m -XX:+CMSClassUnloadingEnabled"
    ...

    Thanks again,
    Davide
Sign In or Register to comment.