Cannot Preview/Upload CRF

Hi,
I am using OpenClinica v. 3.14 and generated a new CRF using templates v3.3 and v3.9.
Recently I was successful uploading CRF using template v3.3.
Today, I tried uploading a new CRF using template v3.3 and received the following message from OpenClinica upon hitting "Preview CRF" button:
"oops, an error occured".

The database is running and so is tomcat, and I can elsewise navigate through the study.

Any help would be greatly appreciated.

Thank you so much,

Silke.

Comments

  • kristiakkristiak Posts: 1,313 ✭✭✭
    Hi Silke,

    Usually this problem may occur when there are many errors in the template. Try to go through it again and identify the problems. Alternatively you can can divide the template in sections e.g. only loading the first 20 lines. If that works, continue with the next 10 etc.

    Regards

    Krister
  • sroeddersroedder Posts: 20
    Hi Krister,
    Thank you very much for the good tip. In this case, it was due to Tomcat/Java not processing fully. Do you have any experience with that? I talked to our IT department and they recommended moving the database to a network server. Will that improve the processing?

    Thanks again,

    Silke.
  • haenselhaensel Posts: 577 ✭✭
    edited September 26
    sroedder said:

    Hi Krister,
    I talked to our IT department and they recommended moving the database to a network server. Will that improve the processing?

    Hi Silke

    So I assume that you run your OC instance on your local machine. As long as your local machine isn't very old it should not be very stressed by your OpenClinica installation.
    Moving the database to a different machine will improve the processing only if the data is transferred through the network faster then it is processed locally.

    Maybe the wikibook page The OpenClinica generic error page: An error has occurred helps to find the source of the error in the OpenClinica logs.


    Regards,
    Christian
  • sroeddersroedder Posts: 20
    via Email
    Dear Christian,

    Thank you so much for the help.

    IT is setting up a new machine as we speak, and we talked about moving the database to a network server.
    I may reach out again for additional help re the network server.

    Thank you again,

    Kind regards,

    Silke.
  • kristiakkristiak Posts: 1,313 ✭✭✭
    I agree with Christian. Please look into the Tomcat library. There should be two subdirectories OPENCLINICA.CONFIG and OPENCLINICA.DATA. In the first one you have to make sure that "DATAINFO.PROPERTIES" is correctly configured according to the attached example. You will find a few places where you have to put in your correct e-mail address.

    Regards

    Krister
Sign In or Register to comment.