We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

about audit log and time

Hi,everyone.
I have two problems about date and time:
1. I installed the postgres of the language in China,Hongkong.and the date of month is displayed correctly exception of the page of subject audit log dates.they appeared as ?? in the file attached here. I don't know how to solve this? thanks.
2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.

Regard,

Jim

audit log.jpg
Attachments:
audit log.jpg 57.9 KB

Comments

  • jeffjeff Posts: 36
    Hi,everyone.
    I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.and the date of month is displayed correctly exception of the page of subject audit log dates.they appeared as ?? in the file attached here. I don't know how to solve this? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.

    Regard,

    Jim

    audit log.jpg
    Attachments:
    audit log.jpg 57.9 KB
  • are you foreign guy? I have give you the solution.You cant read chinese email?
    From: [email protected]
    To: [email protected]
    Date: Fri, 27 Aug 2010 09:00:34 +0800
    CC: [email protected]
    Subject: [Developers] about audit log and time
    Hi,everyone.
    I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.and the date of month is displayed correctly exception of the page of subject audit log dates.they appeared as ?? in the file attached here. I don't know how to solve this? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.

    Regard,

    Jim
  • jeffjeff Posts: 36
    Hi,everyone.
    I installed the openclinica3.03 and now I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.the subject audit log dates appeared as ?? in the file attached here. I don't know how to solve this? can the format of date solve the problem? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.
    Regard,
    Jim



    audit log.jpg
    Attachments:
    audit log.jpg 57.9 KB
  • jeffjeff Posts: 36
    Hi,everyone.
    I installed the openclinica3.03 and now I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.the subject audit log dates appeared as ?? in the file attached here. I don't know how to solve this? can the format of date solve the problem? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.
    Regard,
    Jim



    audit log.jpg
    Attachments:
    audit log.jpg 57.9 KB
  • Hi Jim,
    A few questions regarding your first problem - does this happen in both Firefox and IE? Do you have the Chinese language set as default on your browser? When you installed the database, did you make sure its default encoding was UTF?
    Thanks in advance, Tom
    Tom Hickerson - [email protected]
    Senior Developer
    Akaza Research, LLC
    -----Original Message-----
    Sent: Fri 9/3/2010 3:22
    To: users
    Cc: developers
    Subject: [Developers] about audit log and time

    Hi,everyone.
    I installed the openclinica3.03 and now I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.the subject audit log dates appeared as ?? in the file attached here. I don't know how to solve this? can the format of date solve the problem? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.
    Regard,
    Jim



    Attachments:
    winmail.dat 3.1 KB
  • jeffjeff Posts: 36
    thanks for your reply.TOM.
    ---A few questions regarding your first problem - does this happen in both Firefox and IE?
    it happened only in the IE brower.but there is also a Chinese charcater display problem in Firefox.
    ---Do you have the Chinese language set as default on your browser?
    yes ,the default language on my browser is Chinese.
    --- When you installed the database, did you make sure its default encoding was UTF?
    yes,my default encoding was UTF8.
    could you please tell me how I can set the date format and time in the OpenClinca?
    how can I reset the postgres configuration server:postgresql.conf?
    thanks again.
    Jim



    ------------------ Original ------------------
    From: "Tom Hickerson"
    Date: Fri, Sep 3, 2010 02:54 PM
    To: "developers";
    Subject: RE: [Developers] about audit log and time
    Hi Jim,
    A few questions regarding your first problem - does this happen in both Firefox and IE? Do you have the Chinese language set as default on your browser? When you installed the database, did you make sure its default encoding was UTF?
    Thanks in advance, Tom
    Tom Hickerson - [email protected]
    Senior Developer
    Akaza Research, LLC
    -----Original Message-----
    Sent: Fri 9/3/2010 3:22
    To: users
    Cc: developers
    Subject: [Developers] about audit log and time

    Hi,everyone.
    I installed the openclinica3.03 and now I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.the subject audit log dates appeared as ?? in the file attached here. I don't know how to solve this? can the format of date solve the problem? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.
    Regard,
    Jim
  • About the Audit log problem:
    Please replace the file "Your_path_to\webapps\OpenClinica\WEB-INF\jsp\managestudy\viewStudySubjectAudit.jsp" with the attched file.
    Best,
    Kenneth
    On Fri, Sep 3, 2010 at 4:09 PM, jim wrote:
    thanks for your reply.TOM.
    ---A few questions regarding your first problem - does this happen in both Firefox and IE?
    it happened only in the IE brower.but there is also a Chinese charcater display problem in Firefox.
    ---Do you have the Chinese language set as default on your browser?
    yes ,the default language on my browser is Chinese.
    --- When you installed the database, did you make sure its default encoding was UTF?
    yes,my default encoding was UTF8.
    could you please tell me how I can set the date format and time in the OpenClinca?
    how can I reset the postgres configuration server:postgresql.conf?
    thanks again.
    Jim



    ------------------ Original ------------------
    From: "Tom Hickerson"
    Date: Fri, Sep 3, 2010 02:54 PM
    To: "developers";
    Subject: RE: [Developers] about audit log and time
    Hi Jim,
    A few questions regarding your first problem - does this happen in both Firefox and IE? Do you have the Chinese language set as default on your browser? When you installed the database, did you make sure its default encoding was UTF?
    Thanks in advance, Tom
    Tom Hickerson - [email protected]
    Senior Developer
    Akaza Research, LLC
    -----Original Message-----
    Sent: Fri 9/3/2010 3:22
    To: users
    Cc: developers
    Subject: [Developers] about audit log and time

    Hi,everyone.
    I installed the openclinica3.03 and now I have two problems about date and time:
    1. I installed the postgres of the language in China,Hongkong.the subject audit log dates appeared as ?? in the file attached here. I don't know how to solve this? can the format of date solve the problem? thanks.
    2. I found the time displayed in the Openclinica( such as the login time or the time of the CRF created) is not the time retrieved from my system time. the difference is about 8 hours. i don't know how to set them same!? thanks.
    Regard,
    Jim
This discussion has been closed.