We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Using OC 3.1.3 with most recent components version (within same major version)?

Hi everyone,

Refer to new OC 3.1.3 which is just released, when I checked at installation manual and founded it has been tested with the following components:

*ref: https://docs.openclinica.com/3.1/installation/installing-openclinica-windows

- Java 6 Standard Edition Development Kit 6.0 update 24 (Note: Java frequently changes its naming conventions.)
- Tomcat 6.0.32
- PostgreSQL 8.4.7.2 or Oracle 10g or higher

However refer to quote below:

The software dependencies OpenClinica uses are open source, and frequently updated with minor versions and revisions. Sometimes only a matter of weeks separates the release of two adjacent versions. At the time of this OpenClinica release, the latest stable version of Java, Tomcat, and PostgreSQL were used in integrated testing (and are referenced in this document). In some cases, the revision number used is no longer available. In general, you should be able to use more recent minor versions and revisions of the software dependencies. For example, if the installation instructions refer to PostgreSQL 8.4.7.2, then PostgreSQL 8.4.8 should work successfully too (but not PostgreSQL 9).



I did checked for the most recently version of individual component and found the latest of version (within same major version) are:

- Java 6 Standard Edition Development Kit 6.0 update 37
- Tomcat 6.0.36
- PostgreSQL 8.4.14

Ideally the most recently version includes a lot of bug, security fixes, performance improvements, etc ... So I wonder if OC 3.1.3 can use with them without any issue.

Have anyone using OC 3.1.3 with the most recent version of related components listed above?

Any comment, feedback are welcome!

Note: Our OC production server using Windows 2008 R2 (x64) Data Center as OS.

Best regards,
Montri

Comments

  • zwets-kcrizwets-kcri Posts: 50
    Montri,
    On 30 Nov 2012, at 10:29, Montri Ridjaibun wrote:
    > I did checked for the most recently version of individual component and found the latest of version (within same major version) are:
    > - Java 6 Standard Edition Development Kit 6.0 update 37
    > - Tomcat 6.0.36
    > - PostgreSQL 8.4.14
    >
    > Ideally the most recently version includes a lot of bug, security fixes, performance improvements, etc ... So I wonder if OC 3.1.3 can use with them without any issue.
    As a long time Java/EE & Tomcat developer I would claim that the likelihood of OC breaking on the latest point-releases of Java or Tomcat is less than that of your server crashing due to a stray cosmic ray. So go with the Oracle / Apache advisories and stay current on these, in particular if your server faces the public internet. Point-releases on the stable branches of Java and Tomcat are almost exclusively security-related. The risks you expose yourself to by not upgrading outweigh the tiny chance of breakage.
    I cannot speak for PostgreSQL. For DBMS upgrades my policy is to always 'go with the distro'. Install the package provided by your Linux distribution, and you'll get the upgrades pushed which are stable and important. Keep in mind that the distribution's package maintainers are active followers of upstream changes and very keen on keeping 'their' package both stable, secure and up-to-date. (Otherwise, *they* get the bug reports ...) And since they must make sure the package fits in with the rest of the distribution, they are in a much better position to decide about upgrades than you are.
    On a related note, when installing the JDBC drivers for PostgreSQL in Tomcat's lib (according to instructions which once were at https://docs.openclinica.com/3.1/installation/installation-linux#content-title-5460 but seem to have disappeared), I picked the latest 9.x driver as advised by PostgreSQL at http://jdbc.postgresql.org/, instead of the old 8.x driver that OC still ships with. This has always worked fine. (@OCDevelopers maybe upgrade as well? See the PS.)
    Best regards,
    Marco
    PS: just so to be very sure, all of the above relates to point-upgrades, not major or minor upgrades. That is: Java 6.0.x, Tomcat 6.0.x and PostgreSQL 8.4.x. Don't just bump your PostgreSQL to 9.x :-). As for the 9.x JDBC-driver: it is the PostgreSQL developers themselves who advise against using the 8.x drivers because of the flakier Java inside and their consequent lack of maintenance. They explicitly develop and test the 9.2+ line to support every PSQL since 7.2.
    --
    Marco van Zwetselaar
    KCRI - Kilimanjaro Clinical Research Institute
    Moshi
    Tanzania
    e [email protected]
    m +255 782 334124
  • SyntaxSyntax Posts: 34
    Hi Marco,

    Thanks for your info and comment, I still intend to maintain same major version indicates by OC installation document (for Java, Tomcat, PostgreSQL) but just do upgrade to the most recent minor one (point-upgrades) as I previously listed them.

    In summary there are more than 300 fixes/changes in all security fixes, memory handle fixes/improvements, performance improvements and etc ... However, my role is mainly on system/database administrator (not the developer), so I am not sure will it affect OC functionality or not. That’s why I design to write to ask people in community.

    PS: Seems PostgreSQL 9.x indicates some performance improvements over 8.x, unfortunately OC still not support it yet (may be in the next major version).

    Best regards,
    Montri
    Sent: 03 December, 2012 3:13 PM
    To: [email protected]
    Subject: Re: [Developers] Using OC 3.1.3 with most recent components version (within same major version)?

    Montri,

    On 30 Nov 2012, at 10:29, Montri Ridjaibun wrote:
    I did checked for the most recently version of individual component and found the latest of version (within same major version) are:
    - Java 6 Standard Edition Development Kit 6.0 update 37
    - Tomcat 6.0.36
    - PostgreSQL 8.4.14

    Ideally the most recently version includes a lot of bug, security fixes, performance improvements, etc ... So I wonder if OC 3.1.3 can use with them without any issue.

    As a long time Java/EE & Tomcat developer I would claim that the likelihood of OC breaking on the latest point-releases of Java or Tomcat is less than that of your server crashing due to a stray cosmic ray. So go with the Oracle / Apache advisories and stay current on these, in particular if your server faces the public internet. Point-releases on the stable branches of Java and Tomcat are almost exclusively security-related. The risks you expose yourself to by not upgrading outweigh the tiny chance of breakage.

    I cannot speak for PostgreSQL. For DBMS upgrades my policy is to always 'go with the distro'. Install the package provided by your Linux distribution, and you'll get the upgrades pushed which are stable and important. Keep in mind that the distribution's package maintainers are active followers of upstream changes and very keen on keeping 'their' package both stable, secure and up-to-date. (Otherwise, *they* get the bug reports ...) And since they must make sure the package fits in with the rest of the distribution, they are in a much better position to decide about upgrades than you are.

    On a related note, when installing the JDBC drivers for PostgreSQL in Tomcat's lib (according to instructions which once were at https://docs.openclinica.com/3.1/installation/installation-linux#content-title-5460 but seem to have disappeared), I picked the latest 9.x driver as advised by PostgreSQL at http://jdbc.postgresql.org/, instead of the old 8.x driver that OC still ships with. This has always worked fine. (@OCDevelopers maybe upgrade as well? See the PS.)

    Best regards,
    Marco

    PS: just so to be very sure, all of the above relates to point-upgrades, not major or minor upgrades. That is: Java 6.0.x, Tomcat 6.0.x and PostgreSQL 8.4.x. Don't just bump your PostgreSQL to 9.x :-). As for the 9.x JDBC-driver: it is the PostgreSQL developers themselves who advise against using the 8.x drivers because of the flakier Java inside and their consequent lack of maintenance. They explicitly develop and test the 9.2+ line to support every PSQL since 7.2.

    --
    Marco van Zwetselaar
    KCRI - Kilimanjaro Clinical Research Institute
    Moshi
    Tanzania
    e [email protected]
    m +255 782 334124
This discussion has been closed.