Blank page after login

Hello,

Recently, some users got a blank page after they installed OpenClinica
and tried to login. We are diagnosing this issue. Right now, we know
that it happened to those users who tried to update from version 1.x to
version 2.0 or who used sql scripts in database\PostgreSQL\1.1.

The following is one possible fix for this issue:

After setting up openclinica database, please check if you have tables
STUDY_PARAMETER and STUDY_PARAMETER_VALUE in your database? If you miss
these two tables, you could do:

1. check if there are values in your SUBJECT_EVENT_STATUS table
2. if the answer to 1 is "no", execute the sql script
..\OpenClinica\database\PostgreSQL\2.0\upgrade\schema_patch_1.1_to_2.0.s
ql
3. if the answer to 1 is "yes", get rid of the few lines at the end
of schema_patch_1.1_to_2.0.sql and execute the script. The lines should
be removed are:

--do the following inserts if your DB for 1.1 doesn't have any data in
subject_event_status
--otherwise, you may need to update the data manually, not insert,
because the DB for 1.0 has 9 statuses
--in subject_event_status table, but the data is missing by mistake in
1.1
insert into subject_event_status values(1, 'scheduled', '');
insert into subject_event_status values(2, 'not scheduled', '');
insert into subject_event_status values(3, 'data entry started', '');
insert into subject_event_status values(4, 'completed', '');
insert into subject_event_status values(5, 'stopped', '');
insert into subject_event_status values(6, 'skipped', '');
insert into subject_event_status values(7, 'locked', '');
If the problem still exists, please send us your Tomcat log files so we
could help.

Thank you for using OpenClinica.


Yufang Wang

Attachments:
winmail.dat 6.7 KB

Comments

  • Thanks to all of you who responded to yhis email. OpenCLinica is working
    now. If it is not too much to ask; could anyone send me some tips on how to
    put OpenClinica online in our website? We rent a space and a domain name
    with a local provider...

    Thanks again for all the help!

    Andrew

    _____
    On Behalf Of Yufang Wang
    Sent: Thursday, January 11, 2007 13:54
    To: users@openclinica.org
    Subject: [Users] Blank page after login

    Hello,

    Recently, some users got a blank page after they installed OpenClinica and
    tried to login. We are diagnosing this issue. Right now, we know that it
    happened to those users who tried to update from version 1.x to version 2.0
    or who used sql scripts in database\PostgreSQL\1.1.

    The following is one possible fix for this issue:

    After setting up openclinica database, please check if you have tables
    STUDY_PARAMETER and STUDY_PARAMETER_VALUE in your database? If you miss
    these two tables, you could do:

    1. check if there are values in your SUBJECT_EVENT_STATUS table
    2. if the answer to 1 is "no", execute the sql script
    .\OpenClinica\database\PostgreSQL\2.0\upgrade\schema_patch_1.1_to_2.0.sql
    3. if the answer to 1 is "yes", get rid of the few lines at the end of
    schema_patch_1.1_to_2.0.sql and execute the script. The lines should be
    removed are:

    --do the following inserts if your DB for 1.1 doesn't have any data in
    subject_event_status
    --otherwise, you may need to update the data manually, not insert, because
    the DB for 1.0 has 9 statuses
    --in subject_event_status table, but the data is missing by mistake in 1.1
    insert into subject_event_status values(1, 'scheduled', '');
    insert into subject_event_status values(2, 'not scheduled', '');
    insert into subject_event_status values(3, 'data entry started', '');
    insert into subject_event_status values(4, 'completed', '');
    insert into subject_event_status values(5, 'stopped', '');
    insert into subject_event_status values(6, 'skipped', '');
    insert into subject_event_status values(7, 'locked', '');
    If the problem still exists, please send us your Tomcat log files so we
    could help.

    Thank you for using OpenClinica.


    Yufang Wang

    Attachments:
    winmail.dat 8.0 KB
  • JozefJozef Posts: 71
    You can't run OpenClinica on a normal webserver, you will need an application server.
    Please ask your provider whether they can provide an application server where you get root access.
    The difference is that a webserver shows web pages (sometimes you also get a database with it), whereas an application server EXECUTES code.
    I do not know where you are located, but renting an application server (located at the provider) should not cost more than Euro 50, $65 per month.
    I have myself rented such an application server (www.XML4PharmaServer.com) for Euro 40 per month, which has a number of demo CDISC applications running on it.
    With best regards,
    Jozef Aerts
    XML4Pharma
  • application server. Can anyone forward me some tips on how to actually
    install this? Would I be installing in the same way with the difference
    that now it will be installed on to a web server? Are there other things to
    consider?
    Thanks again to whomever may help me!
    Yours truly,
    Andrew Miranda
    -----Original Message-----
    On Behalf Of dr. Jozef Aerts
    Sent: Sunday, January 14, 2007 6:08 AM
    To: users@openclinica.org
    Subject: Re: [Users] Blank page after login
    You can't run OpenClinica on a normal webserver, you will need an
    application server.
    Please ask your provider whether they can provide an application server
    where you get root access.
    The difference is that a webserver shows web pages (sometimes you also get a
    database with it), whereas an application server EXECUTES code.
    I do not know where you are located, but renting an application server
    (located at the provider) should not cost more than Euro 50, $65 per month.
    I have myself rented such an application server (www.XML4PharmaServer.com)
    for Euro 40 per month, which has a number of demo CDISC applications running
    on it.
    With best regards,
    Jozef Aerts
    XML4Pharma
  • You can find an install guide for Linux and Windows here:
    http://www.openclinica.org/entities/entity_details.php?eid=302.
    If you don't prefer the do-it-yourself route, Akaza Research offers a
    number of commercial services for OpenClinica installation, hosting,
    training, etc. I'd be happy to help you in either scenario.
    - Ben
    -----Original Message-----
    [mailto:users-bounces@openclinica.org] On Behalf Of Andrew Miranda
    Sent: Monday, January 15, 2007 3:48 PM
    To: 'dr. Jozef Aerts'; users@openclinica.org
    Subject: RE: [Users] Blank page after login
    Thanks again! This email has been most helpful... Now we have an
    application server. Can anyone forward me some tips on how to actually
    install this? Would I be installing in the same way with the difference
    that now it will be installed on to a web server? Are there other
    things to consider?
    Thanks again to whomever may help me!
    Yours truly,
    Andrew Miranda
    -----Original Message-----
    [mailto:users-bounces@openclinica.org]
    On Behalf Of dr. Jozef Aerts
    Sent: Sunday, January 14, 2007 6:08 AM
    To: users@openclinica.org
    Subject: Re: [Users] Blank page after login
    You can't run OpenClinica on a normal webserver, you will need an
    application server.
    Please ask your provider whether they can provide an application server
    where you get root access.
    The difference is that a webserver shows web pages (sometimes you also
    get a
    database with it), whereas an application server EXECUTES code.
    I do not know where you are located, but renting an application server
    (located at the provider) should not cost more than Euro 50, $65 per
    month.
    I have myself rented such an application server
    (www.XML4PharmaServer.com) for Euro 40 per month, which has a number of
    demo CDISC applications running
    on it.
    With best regards,
    Jozef Aerts
    XML4Pharma
This discussion has been closed.