We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Installation woes.

I am trying to get OpenClinica running on a test machine.
The setup is
FC6
postgresql-8.1.9-1
apache-tomcat-5.5.20
jdk1.5.0_12
Everything seems to start fine.
Tomcat up and running normally, so is postgres.
No error messages in the postgres logs.
I get to the login page, enter the root user.
Click Login.
And I'm taken to a blank, stalled page.
And this shows up in the Tomcat logs:
Jul 17, 2007 11:46:16 AM
org.akaza.openclinica.control.core.SecureController process
WARNING:OpenClinicaException::org.akaza.openclinica.control.SecureController::null
I've run the installation process three times.
I've done it following the instructions AND the Video, but I always get
the same results.
Any ideas would be appreciated.
Thanks.
Pat.

Comments

  • geminxgeminx Posts: 3
    Subject:
    RE: [Users] Installation woes.
    From:
    "Patrick Lefebvre"
    Date:
    7/17/07, 3:30 PM
    CC:
    [email protected]
    tested.
    [[email protected] data]# psql -h localhost -U clinica -d openclinica -p 5432
    Password for user clinica:
    Welcome to psql 8.1.9, the PostgreSQL interactive terminal.
    Type: \copyright for distribution terms
    \h for help with SQL commands
    \? for help with psql commands
    \g or terminate with semicolon to execute query
    \q to quit
    openclinica=> \q
    All seems good there, and no denied messages in the Tomcat or pgsql
    logs.
    On Tue, 2007-07-17 at 15:23 -0400, Daniel Bromberg wrote:
    > > This seems like communication with the Postgres Database is a problem.
    > > Try the command line first to see if it’s up and running (even before
    > > that, check within the Task Manager ‘processes’ tab).
    > >
    > >
    > >
    > > C:\> C:\PostgreSQL\8.1\bin\psql -h localhost -U clinica -d openclinica
    > > -p 5432
    > >
    > > Password: clinica
    > >
    > >
    > >
    > > Welcome to psql 8.1.9, the PostgreSQL interactive terminal.
    > >
    > >
    > >
    > > Type: \copyright for distribution terms
    > >
    > > \h for help with SQL commands
    > >
    > > \? for help with psql commands
    > >
    > > \g or terminate with semicolon to execute query
    > >
    > > \q to quit
    > >
    > >
    > >
    > > Warning: Console code page (437) differs from Windows code page (1252)
    > >
    > > 8-bit characters may not work correctly. See psql reference
    > >
    > > page "Notes for Windows users" for details.
    > >
    > >
    > >
    > > openclinica=> \q
    > >
    > >
    > >
    > >
    > >
    > > If that works, I would verify that settings (‘connectionURL’,
    > > ‘connectionName’, ‘connectionPassword’, ‘username’, ‘password’, and
    > > ‘url’) in the file C:\tomcat\conf\Catalina\localhost\OpenClinica.xml
    > > correspond to the values in the command line above.
    > >
    > >
    > >
    > > -Daniel
    > >
    > >
    > >
    > >
    > >
    > > [email protected]
    > >
    > >
    > >
    > > Daniel Bromberg, owner BaseZen Consulting, Cambridge, MA
    > >
    > >
    > >
    > > 1-877-BASEZEN
    > >
    > >
    > >
    > >
    > >
    > > -----Original Message-----
    > >
    > > [mailto:[email protected]] On Behalf Of Patrick Lefebvre
    > > Sent: Tuesday, July 17, 2007 3:05 PM
    > > To: [email protected]
    > > Subject: [Users] Installation woes.
    > >
    > >
    > >
    > > I am trying to get OpenClinica running on a test machine.
    > >
    > > The setup is
    > >
    > > FC6
    > >
    > > postgresql-8.1.9-1
    > >
    > > apache-tomcat-5.5.20
    > >
    > > jdk1.5.0_12
    > >
    > >
    > >
    > > Everything seems to start fine.
    > >
    > > Tomcat up and running normally, so is postgres.
    > >
    > > No error messages in the postgres logs.
    > >
    > > I get to the login page, enter the root user.
    > >
    > > Click Login.
    > >
    > > And I'm taken to a blank, stalled page.
    > >
    > > And this shows up in the Tomcat logs:
    > >
    > > Jul 17, 2007 11:46:16 AM
    > >
    > > org.akaza.openclinica.control.core.SecureController process
    > >
    > > WARNING:OpenClinicaException::org.akaza.openclinica.control.SecureController::null
    > >
    > >
    > >
    > >
    > >
    > > I've run the installation process three times.
    > >
    > > I've done it following the instructions AND the Video, but I always
    > > get
    > >
    > > the same results.
    > >
    > >
    > >
    > > Any ideas would be appreciated.
    > >
    > > Thanks.
    > >
    > >
    > >
    > > Pat.
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > >
  • Check to make sure two specific tables are installed
    STUDY_PARAMETER
    STUDY_PARAMETER_VALUE
    If these two tables are missing, please follow these instructions.
    1. check if there are values in your SUBJECT_EVENT_STATUS table

    2. if the answer to 1 is �no�, execute the sql script ..\OpenClinica\database\PostgreSQL\2.0\upgrade\schema_patch_1.1_to_2.0.sql

    3. if the answer to 1 is �yes�, get rid of the few lines at the end of schema_patch_1.1_to_2.0.sql and execute the script. The lines should be removed are:


    --do the following inserts if your DB for 1.1 doesn't have any data in subject_event_status

    --otherwise, you may need to update the data manually, not insert, because the DB for 1.0 has 9 statuses

    --in subject_event_status table, but the data is missing by mistake in 1.1

    insert into subject_event_status values(1, 'scheduled', '');
    insert into subject_event_status values(2, 'not scheduled', '');
    insert into subject_event_status values(3, 'data entry started', '');
    insert into subject_event_status values(4, 'completed', '');
    insert into subject_event_status values(5, 'stopped', '');
    insert into subject_event_status values(6, 'skipped', '');
    insert into subject_event_status values(7, 'locked', '');


    If it doesn't work for you, please zip all your tomcat logs to us, since the provided tomcat log is only a warning message in Catalina.log.
    Yufang Wang
    -----Original Message-----
    Sent: Tuesday, July 17, 2007 3:05 PM
    To: [email protected]
    Subject: [Users] Installation woes.
    I am trying to get OpenClinica running on a test machine.
    The setup is
    FC6
    postgresql-8.1.9-1
    apache-tomcat-5.5.20
    jdk1.5.0_12
    Everything seems to start fine.
    Tomcat up and running normally, so is postgres.
    No error messages in the postgres logs.
    I get to the login page, enter the root user.
    Click Login.
    And I'm taken to a blank, stalled page.
    And this shows up in the Tomcat logs:
    Jul 17, 2007 11:46:16 AM
    org.akaza.openclinica.control.core.SecureController process
    WARNING:OpenClinicaException::org.akaza.openclinica.control.SecureController::null
    I've run the installation process three times.
    I've done it following the instructions AND the Video, but I always get
    the same results.
    Any ideas would be appreciated.
    Thanks.
    Pat.
This discussion has been closed.