We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

postgresql database table setup errors on first time OCinstallation

Hello Jay,

I believe the error that you are encountering is because you have installed Postgres version 8.3. OpenClinica version 2.2 supports Postgres 8.2.5. (Website: http://www.postgresql.org/ftp/binary/v8.2.5/win32/). I would try uninstalling and reinstalling with version 8.2.5 of Postgres and try executing the sql scripts again. The software dependencies for OpenClinica 2.2 are:

Jakarta Tomcat 5.5.26
Java 2 Standard Edition Development Kit 5.0 Update 14
Postgres 8.2.5
Postgres JDBC Driver Version 8.1-405 JDBC 3


Also, there are installation instructions included in the download package (located in the install docs folder) which will walk you through the steps and point you to the location of the required software. Please let me know if this works for you or if you are still encountering an issue.

Best Regards,

Alicia

. . . . . . . . . . . . . . . . . . . .

Alicia Goodwin
Client Services Representative
Akaza Research
400 One Kendall Square
Cambridge, MA 02139
tel: 617.621.8585 ext. 24
[email protected]
Sent: Tuesday, July 29, 2008 6:26 PM
To: [email protected]
Subject: [Users] postgresql database table setup errors on first time OCinstallation

Hello,
I'm installing OpenClinica 2.2.2 for the first time. Following along with the video tutorial.
Installed PostgreSQL 8.3
Installed Java JDK 1.6.0_07
Installed Apache Tomcat 5.5
Installed Openclinical 2.2.2
I created the appropriate Environmental Variables, etc.
During the configure databases step I got the following error when running the second database configuration script (create_database_2_2_2_with_data)
"ERROR: foreign key constraint "FK_STUDY_EV_FK-STUDY__STUDY" cannot be implemented"
Thank you for your assistance,
Jay
This discussion has been closed.