We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

e-mail not working (SOLVED)

So I dug around in the source code and figured out that something was
failing in javax.mail. I tried creating a small program that imported
javax.mail from the mail-1.4.jar that comes with OpenClinica and it also
failed. I then added the javamail.jar from my classpathx-mail package
to /var/lib/tomcat5/webapps/OpenClinica/WEB-INF/lib and now OpenClinica
will send e-mail without problems.
Again, my system:
Red Hat Enterprise Linux 5.2 with OpenClinica 2.2.2 and packages:
- tomcat5-5.5.23-0jpp.7.el5_2.1
- java-1.6.0-sun-1.6.0.7-1jpp.1.el5
- postgresql-8.1.11-1.el5_1.1
I am afraid I can't explain explicitly why this problem exists and why
this solution works. Perhaps at least helpful for others...
-Michael
Michael Boland wrote:
> > Sorry, I will clarify - localhost works just fine as an SMTP server
> > (other applications, cron can all send mail), as does our institutional
> > smtp server. It is OpenClinica that is somehow not playing well with
> > e-mail and I can't tell why it is failing from the logs produced
> > (below). Furthermore, nothing is added to the system logs
> > (/var/log/maillog, for instance) on localhost after I try to send an
> > e-mail in OpenClinica so it is not even getting that far.
> >
> > Thanks for the response.
> >
> > -Michael
> >
> >
> >
> > Shaun Martin wrote:
>> >> Hi Michael,
>> >>
>> >> The best way to troubleshoot an email problem is via telnet you can send
>> >> emails and it gives you more meaningful feedback. Also if you are using
>> >> another host to relay the emails usually you have to add the source servers
>> >> IP to the mail relay list so it will accept the mail. Here is a good link to
>> >> sending an email via telnet, if you could try this for the servers that are
>> >> giving you an issue and post the whole set of commands and what they return
>> >> that will help us troubleshoot your issue further.
>> >>
>> >> SMTP via telnet link
>> >> http://www.activexperts.com/activemail/telnet/
>> >>
>> >> Thanks,
>> >> Shaun
>> >>
>> >>
>> >>
>> >> On 9/16/08 2:51 PM, "Michael Boland" wrote:
>> >>
>>> >>> "localhost" is a valid SMTP server (see datainfo.properties, below). I
>>> >>> have also tried using the full domain name of the server and the full
>>> >>> name of our institutional smtp server. All three options produce the
>>> >>> same output.
>>> >>>
>>> >>> Is there a way to get more information about where it is failing (I
>>> >>> can't tell from the messages below)
>>> >>>
>>> >>> Thanks.
>>> >>>
>>> >>> -Michael
>>> >>>
>>> >>>
>>> >>>
>>> >>> Paul Galvin wrote:
>>>> >>>> Hi Michael,
>>>> >>>>
>>>> >>>> It looks like you do not have a valid SMTP host in your
>>>> >>>> datainfo.properties file which is why emails are not working. For
>>>> >>>> example, the SMTP host would be structured the following way:
>>>> >>>>
>>>> >>>> mail.example.com
>>>> >>>>
>>>> >>>> If you are running OpenClinica on a network that does not have a mail
>>>> >>>> server, you will not be able to use the email features of the
>>>> >>>> application.
>>>> >>>>
>>>> >>>> Thanks,
>>>> >>>>
>>>> >>>> Paul
>>>> >>>>
>>>> >>>> -----Original Message-----
>>>> >>>>
>>>> >>>> [mailto:[email protected]] On Behalf Of Michael Boland
>>>> >>>> Sent: Tuesday, September 16, 2008 1:02 PM
>>>> >>>> To: [email protected]
>>>> >>>> Subject: [Users] e-mail not working...
>>>> >>>>
>>>> >>>>
>>>> >>>> I have OpenClinica 2.2 working great under Red Hat EL5 (Tomcat 5.5.23)
>>>> >>>> except that I cannot get the system to send e-mail regarding passwords.
>>>> >>>> There is no clear error generated when sending the e-mail (see below)
>>>> >>>> but at the same time there is no evidence of a connection in the
>>>> >>>> maillog. I can send mail locally using mutt and cron sends reports
>>>> >>>> daily.
>>>> >>>>
>>>> >>>> Anyone with similar problems or thoughts on how to resolve this?
>>>> >>>>
>>>> >>>> Thanks in advance.
>>>> >>>>
>>>> >>>>
This discussion has been closed.