Can't change study information

Hello,
I have problems changing study information. It is the first study I set up in this installation of OC. After completing all 7 set-up screens I pressed "Confirm study", everything looked ok before I pressed "Submit Study". I did not receive any error messages. (During the setup I only had some messages when the text that I had pasted in some fileds turned out to be too long, but I corrected that before I moved on.)
When I viewed the study the next day I realized that some information was missing, even in mandatory files like "Sponsor"or "Study phase". I opened the study to edit it, but was unable to move bejond the first screen, even after re-entering all information. Pressing "Confirm" would always take me to the following screen with :
"OpenClinica: An error has occurred
An error has occurred in the application. This can be for a number of reasons, not all of them might have to do with the actual Web application. If there are any messages above this text, please cut and paste them into an email to Akaza Research ........"
There is no other message displayed above or to the left.
I can modify the default study without problems.
I can doublicate this study in my "practice" set-up of OC on a different server without problems.
What can cause this problem and what can I do to correct it?
Any help is greatly appreciated
Regards,
Claudia

Comments

  • Paul GalvinPaul Galvin Posts: 886
    Hi Claudia,
    Can you please recreate the issue and then zip up all the log files from
    today in CATALINA_HOME/logs/ and send them to this list? The log files
    will have messages about why you see the error page when you edit a
    study.
    Thanks,
    Paul
    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    Akaza Research
    617-621-8585 x25
    www.akazaresearch.com
    www.openclinica.org
    ~ OpenClinica Enterprise ~ Ask me about professional training, support,
    and services for OpenClinica
    -----Original Message-----
    [mailto:[email protected]] On Behalf Of Claudia Trepte
    Sent: Monday, June 22, 2009 6:01 AM
    To: [email protected]
    Subject: [Users] Can't change study information
    Hello,
    I have problems changing study information. It is the first study I set
    up in this installation of OC. After completing all 7 set-up screens I
    pressed "Confirm study", everything looked ok before I pressed "Submit
    Study". I did not receive any error messages. (During the setup I only
    had some messages when the text that I had pasted in some fileds turned
    out to be too long, but I corrected that before I moved on.)
    When I viewed the study the next day I realized that some information
    was missing, even in mandatory files like "Sponsor"or "Study phase". I
    opened the study to edit it, but was unable to move bejond the first
    screen, even after re-entering all information. Pressing "Confirm" would
    always take me to the following screen with :
    "OpenClinica: An error has occurred
    An error has occurred in the application. This can be for a number of
    reasons, not all of them might have to do with the actual Web
    application. If there are any messages above this text, please cut and
    paste them into an email to Akaza Research
    ........"
    There is no other message displayed above or to the left.
    I can modify the default study without problems.
    I can doublicate this study in my "practice" set-up of OC on a different
    server without problems.
    What can cause this problem and what can I do to correct it?
    Any help is greatly appreciated
    Regards,
    Claudia
  • bancovabancova Posts: 1
    Hi,
    I'm new to the software, trying to set it up. When I tried to run .sql to
    set up tables, I got the following error: Query result with 1 rows
    discarded.
    Query result with 1 rows discarded.
    ERROR: foreign key constraint "HAS FATHER" cannot be implemented
    DETAIL: Key columns "father_id" and "subject_id" are of incompatible types:
    numeric and integer.
    ********** Error **********
    ERROR: foreign key constraint "HAS FATHER" cannot be implemented
    SQL state: 42804
    Detail: Key columns "father_id" and "subject_id" are of incompatible types:
    numeric and integer.
    Could some one kindly tell me if there is an updated version of setup file
    for postgresql?
    Thanks.
    john
    -----Original Message-----
    On Behalf Of Paul Galvin
    Sent: Monday, June 22, 2009 9:53 AM
    To: [email protected]
    Subject: RE: [Users] Can't change study information
    Hi Claudia,
    Can you please recreate the issue and then zip up all the log files from
    today in CATALINA_HOME/logs/ and send them to this list? The log files
    will have messages about why you see the error page when you edit a
    study.
    Thanks,
    Paul
    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    Akaza Research
    617-621-8585 x25
    www.akazaresearch.com
    www.openclinica.org
    ~ OpenClinica Enterprise ~ Ask me about professional training, support,
    and services for OpenClinica
    -----Original Message-----
    [mailto:[email protected]] On Behalf Of Claudia Trepte
    Sent: Monday, June 22, 2009 6:01 AM
    To: [email protected]
    Subject: [Users] Can't change study information
    Hello,
    I have problems changing study information. It is the first study I set
    up in this installation of OC. After completing all 7 set-up screens I
    pressed "Confirm study", everything looked ok before I pressed "Submit
    Study". I did not receive any error messages. (During the setup I only
    had some messages when the text that I had pasted in some fileds turned
    out to be too long, but I corrected that before I moved on.)
    When I viewed the study the next day I realized that some information
    was missing, even in mandatory files like "Sponsor"or "Study phase". I
    opened the study to edit it, but was unable to move bejond the first
    screen, even after re-entering all information. Pressing "Confirm" would
    always take me to the following screen with :
    "OpenClinica: An error has occurred
    An error has occurred in the application. This can be for a number of
    reasons, not all of them might have to do with the actual Web
    application. If there are any messages above this text, please cut and
    paste them into an email to Akaza Research
    ........"
    There is no other message displayed above or to the left.
    I can modify the default study without problems.
    I can doublicate this study in my "practice" set-up of OC on a different
    server without problems.
    What can cause this problem and what can I do to correct it?
    Any help is greatly appreciated
    Regards,
    Claudia
  • ctreptectrepte Posts: 100
    Hi,
    as suggested by Paul, I went back and tryed to change the study information as I did before. Unsuccessfully but again without definit error meaassage.
    We could not find a directory CATALINA_HOME/logs/ but I did find some files with extension LOG and CATALINA as part of the file name. I ziped up all the log files in that directory. There aren't that many since the program was only set up last week. However, there are no log files from today.
    I hope these are the right files to diagnose the problem.
    Best regards
    Claudia
    -----Original Message-----
    Sent: Montag, 22. Juni 2009 16:15
    To: [email protected]
    Subject: RE: [Users] Can't change study information
    Hi Claudia,
    Can you please recreate the issue and then zip up all the log files from today in CATALINA_HOME/logs/ and send them to this list? The log files will have messages about why you see the error page when you edit a study.
    Thanks,
    Paul
    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    Akaza Research
    617-621-8585 x25
    www.akazaresearch.com
    www.openclinica.org
    ~ OpenClinica Enterprise ~ Ask me about professional training, support, and services for OpenClinica
    -----Original Message-----
    [mailto:[email protected]] On Behalf Of Claudia Trepte
    Sent: Monday, June 22, 2009 6:01 AM
    To: [email protected]
    Subject: [Users] Can't change study information
    Hello,
    I have problems changing study information. It is the first study I set up in this installation of OC. After completing all 7 set-up screens I pressed "Confirm study", everything looked ok before I pressed "Submit Study". I did not receive any error messages. (During the setup I only had some messages when the text that I had pasted in some fileds turned out to be too long, but I corrected that before I moved on.) When I viewed the study the next day I realized that some information was missing, even in mandatory files like "Sponsor"or "Study phase". I opened the study to edit it, but was unable to move bejond the first screen, even after re-entering all information. Pressing "Confirm" would
    always take me to the following screen with :
    "OpenClinica: An error has occurred
    An error has occurred in the application. This can be for a number of reasons, not all of them might have to do with the actual Web application. If there are any messages above this text, please cut and paste them into an email to Akaza Research ........"
    There is no other message displayed above or to the left.
    I can modify the default study without problems.
    I can doublicate this study in my "practice" set-up of OC on a different
    server without problems.
    What can cause this problem and what can I do to correct it?
    Any help is greatly appreciated
    Regards,
    Claudia
  • ctreptectrepte Posts: 100
    Hi,
    I am using OpenClinica 2.5.5. The date format was not changed form the standard at installation, it is still MM/DD/YYYY. The browser does show this format when entering data.
    However the date format on my computer is the European standard DD.MM.YYYY. Can this cause a problem sometimes? (I would like set OpenClinica to European standard as well to make data entry easier.Can this be done by simply changing MM/DD/YYYY to DD.MM.YYYY, MM/dd/yyyy to dd.MM.yyyy, and so on in the format_en.properties file? )
    I also set up another study. As far as I remembered with the same entries as before, only different title and ID. This time it all went fine. All the information was stored correctly and can be updated/changed as well.
    However I am still unable to update the "problem" study information. The fields that had been entered but were not stored for the "problem"study are: protocol details description, sponsor, study phase, protocol type, protocol verification/approval date, condition, keywords, eligibility, gender, min. age, healthy volunteers accepted, expected total enrollment, all study parameter configuration. On the other hand official title, principal investigator, brief title, start date, purpose, was stored correctly. I don't know if this helps to narrow down the problem.
    Has anyone ever had problems when they copied and pasted information form study protocols?
    I much appreciate any help
    Claudia Trepte
    Paul Galvin schrieb:
    > Hi Claudia,
    >
    > The error message in the logs seems to be pointing to a date format
    > issue. What date format do you have set for OpenClinica and what
    > version of OpenClinica are you using?
    >
    > Also, please try to create another study and see if you get any error
    > messages. While you are creating the study, check the info box in the
    > upper right and see if your user's role says Invalid.
    >
    > Thanks,
    >
    > Paul
    >
    > -----------------------------------------------------------------------
    >
    > Paul J. Galvin
    > Project Manager
    > Akaza Research
    >
    > www.akazaresearch.com
    > www.openclinica.org
    >
    > ~ OpenClinica Enterprise ~ Ask me about professional training, support,
    > and services for OpenClinica
    >
    > -----Original Message-----
    >
    > [mailto:[email protected]] On Behalf Of Claudia Trepte
    > Sent: Tuesday, June 23, 2009 3:09 PM
    > To: [email protected]
    > Subject: Fwd: FW: [Users] Can't change study information
    >
    > Hi,
    >
    > as suggested by Paul, I went back and tryed to change the study
    > information as I did before. Unsuccessfully but again without definit
    > error meaassage.
    > We could not find a directory CATALINA_HOME/logs/ but I did find some
    > files with extension LOG and CATALINA as part of the file name. I ziped
    > up all the log files in that directory. There aren't that many since the
    > program was only set up last week. However, there are no log files from
    > today.
    > I hope these are the right files to diagnose the problem.
    >
    > Best regards
    >
    > Claudia
    >
    > -----Original Message-----
    >
    > [mailto:[email protected]] On Behalf Of Paul Galvin
    > Sent: Montag, 22. Juni 2009 16:15
    > To: [email protected]
    > Subject: RE: [Users] Can't change study information
    >
    > Hi Claudia,
    >
    > Can you please recreate the issue and then zip up all the log files from
    > today in CATALINA_HOME/logs/ and send them to this list? The log files
    > will have messages about why you see the error page when you edit a
    > study.
    >
    > Thanks,
    >
    > Paul
    >
    > -----------------------------------------------------------------------
    >
    > Paul J. Galvin
    > Project Manager
    > Akaza Research
    > 617-621-8585 x25
    > www.akazaresearch.com
    > www.openclinica.org
    >
    > ~ OpenClinica Enterprise ~ Ask me about professional training, support,
    > and services for OpenClinica
    >
    > -----Original Message-----
    >
    > [mailto:[email protected]] On Behalf Of Claudia Trepte
    > Sent: Monday, June 22, 2009 6:01 AM
    > To: [email protected]
    > Subject: [Users] Can't change study information
    >
    > Hello,
    >
    > I have problems changing study information. It is the first study I set
    > up in this installation of OC. After completing all 7 set-up screens I
    > pressed "Confirm study", everything looked ok before I pressed "Submit
    > Study". I did not receive any error messages. (During the setup I only
    > had some messages when the text that I had pasted in some fileds turned
    > out to be too long, but I corrected that before I moved on.) When I
    > viewed the study the next day I realized that some information was
    > missing, even in mandatory files like "Sponsor"or "Study phase". I
    > opened the study to edit it, but was unable to move bejond the first
    > screen, even after re-entering all information. Pressing "Confirm" would
    >
    > always take me to the following screen with :
    > "OpenClinica: An error has occurred
    > An error has occurred in the application. This can be for a number of
    > reasons, not all of them might have to do with the actual Web
    > application. If there are any messages above this text, please cut and
    > paste them into an email to Akaza Research
    > ........"
    > There is no other message displayed above or to the left.
    > I can modify the default study without problems.
    > I can doublicate this study in my "practice" set-up of OC on a different
    >
    > server without problems.
    >
    > What can cause this problem and what can I do to correct it?
    >
    > Any help is greatly appreciated
    >
    > Regards,
    > Claudia
    >
  • Hi Claudia,
    To answer the first half of your question:
    The date formats will depend upon your language setting in your browser. Note that 2.5.5 has the UK formats set to DD/MM/YYYY, so if you change your language setting to 'English/Great Britain', you should see the changes take affect after logging back in to the application.
    You can change format_en.properties and format.properties yourself as well, keep in mind that the caps should remain the same (like you write below, dd.MM.yyyy) as the *_format strings are used by Java for date formatting purposes.
    Instructions as to how to change your browser's language setting can be found here:
    https://www.openclinica.org/dokuwiki/doku.php?id=developerwiki:i18n#how_to_debug_i18n_in_openclinica
    As to your second question: which one of the studies is the 'problem' study, the first one you created or the second one? Does the application give you any kind of error message when you try to change the values?
    Hope this helps, Tom
    -----Original Message-----
    Sent: Mon 7/6/2009 17:43
    To: User Forum OC
    Subject: Re: FW: [Users] Can't change study information

    Hi,
    I am using OpenClinica 2.5.5. The date format was not changed form the
    standard at installation, it is still MM/DD/YYYY. The browser does show
    this format when entering data.
    However the date format on my computer is the European standard
    DD.MM.YYYY. Can this cause a problem sometimes? (I would like set
    OpenClinica to European standard as well to make data entry easier.Can
    this be done by simply changing MM/DD/YYYY to DD.MM.YYYY, MM/dd/yyyy to
    dd.MM.yyyy, and so on in the format_en.properties file? )
    I also set up another study. As far as I remembered with the same
    entries as before, only different title and ID. This time it all went
    fine. All the information was stored correctly and can be
    updated/changed as well.
    However I am still unable to update the "problem" study information. The
    fields that had been entered but were not stored for the "problem"study
    are: protocol details description, sponsor, study phase, protocol type,
    protocol verification/approval date, condition, keywords, eligibility,
    gender, min. age, healthy volunteers accepted, expected total
    enrollment, all study parameter configuration. On the other hand
    official title, principal investigator, brief title, start date,
    purpose, was stored correctly. I don't know if this helps to narrow
    down the problem.
    Has anyone ever had problems when they copied and pasted information
    form study protocols?
    I much appreciate any help
    Claudia Trepte
    Paul Galvin schrieb:
    > > Hi Claudia,
    > >
    > > The error message in the logs seems to be pointing to a date format
    > > issue. What date format do you have set for OpenClinica and what
    > > version of OpenClinica are you using?
    > >
    > > Also, please try to create another study and see if you get any error
    > > messages. While you are creating the study, check the info box in the
    > > upper right and see if your user's role says Invalid.
    > >
    > > Thanks,
    > >
    > > Paul
    > >
    > > -----------------------------------------------------------------------
    > >
    > > Paul J. Galvin
    > > Project Manager
    > > Akaza Research
    > >
    > > www.akazaresearch.com
    > > www.openclinica.org
    > >
    > > ~ OpenClinica Enterprise ~ Ask me about professional training, support,
    > > and services for OpenClinica
    > >
    > > -----Original Message-----
    > >
    > > [mailto:[email protected]] On Behalf Of Claudia Trepte
    > > Sent: Tuesday, June 23, 2009 3:09 PM
    > > To: [email protected]
    > > Subject: Fwd: FW: [Users] Can't change study information
    > >
    > > Hi,
    > >
    > > as suggested by Paul, I went back and tryed to change the study
    > > information as I did before. Unsuccessfully but again without definit
    > > error meaassage.
    > > We could not find a directory CATALINA_HOME/logs/ but I did find some
    > > files with extension LOG and CATALINA as part of the file name. I ziped
    > > up all the log files in that directory. There aren't that many since the
    > > program was only set up last week. However, there are no log files from
    > > today.
    > > I hope these are the right files to diagnose the problem.
    > >
    > > Best regards
    > >
    > > Claudia
    > >
    > > -----Original Message-----
    > >
    > > [mailto:[email protected]] On Behalf Of Paul Galvin
    > > Sent: Montag, 22. Juni 2009 16:15
    > > To: [email protected]
    > > Subject: RE: [Users] Can't change study information
    > >
    > > Hi Claudia,
    > >
    > > Can you please recreate the issue and then zip up all the log files from
    > > today in CATALINA_HOME/logs/ and send them to this list? The log files
    > > will have messages about why you see the error page when you edit a
    > > study.
    > >
    > > Thanks,
    > >
    > > Paul
    > >
    > > -----------------------------------------------------------------------
    > >
    > > Paul J. Galvin
    > > Project Manager
    > > Akaza Research
    > > 617-621-8585 x25
    > >
    > > www.akazaresearch.com
    > > www.openclinica.org
    > >
    > > ~ OpenClinica Enterprise ~ Ask me about professional training, support,
    > > and services for OpenClinica
    > >
    > > -----Original Message-----
    > >
    > > [mailto:[email protected]] On Behalf Of Claudia Trepte
    > > Sent: Monday, June 22, 2009 6:01 AM
    > > To: [email protected]
    > > Subject: [Users] Can't change study information
    > >
    > > Hello,
    > >
    > > I have problems changing study information. It is the first study I set
    > > up in this installation of OC. After completing all 7 set-up screens I
    > > pressed "Confirm study", everything looked ok before I pressed "Submit
    > > Study". I did not receive any error messages. (During the setup I only
    > > had some messages when the text that I had pasted in some fileds turned
    > > out to be too long, but I corrected that before I moved on.) When I
    > > viewed the study the next day I realized that some information was
    > > missing, even in mandatory files like "Sponsor"or "Study phase". I
    > > opened the study to edit it, but was unable to move bejond the first
    > > screen, even after re-entering all information. Pressing "Confirm" would
    > >
    > > always take me to the following screen with :
    > > "OpenClinica: An error has occurred
    > > An error has occurred in the application. This can be for a number of
    > > reasons, not all of them might have to do with the actual Web
    > > application. If there are any messages above this text, please cut and
    > > paste them into an email to Akaza Research
    > > ........"
    > > There is no other message displayed above or to the left.
    > > I can modify the default study without problems.
    > > I can doublicate this study in my "practice" set-up of OC on a different
    > >
    > > server without problems.
    > >
    > > What can cause this problem and what can I do to correct it?
    > >
    > > Any help is greatly appreciated
    > >
    > > Regards,
    > > Claudia
    > >
This discussion has been closed.