Problem with SPSS-extracts

Dear community,

recently we've at CTMM-TraIT run into a problem when one of our studies tried to make a SPSS extract. A new version of a number of CRF's was make just prior to the export job, but without any subjects or data added to the new CRF's.

Before the exports took only approx 2 hours but this time the CPU went up to 100% continiously. We had to restart our production-server to solve this. Because the SPSS / XSLT-job ran on a separate thread our users did not notice any delay.

Has anybody in the community noticed this before with OpenClinica 3.3 ? And do you know if there are registered issues similar to this one?

thanks for your responses and regards,
Jacob

Comments

  • ccollinsccollins Posts: 377 admin
    via Email
    Hi Jacob,

    The particular problem doesn't sound familiar to me. Does it happen with
    other extract formats or other datasets in the study? If you remove the
    newly added versions from the study does it then work again?

    If you're able to replicate the problem it on a non-production server and
    none of the above provide any guidance, you could troubleshoot by:

    1. Running the extract in 'CDISC ODM XML 1.3 Full with OpenClinica
    extensions' format. If this completes normally, it indicates the problem is
    with the XSL transformation. If not, the problem is in the Java source code
    and/or something wrong with the metadata/clinical data; the tomcat logs
    might be the best place to look.

    2. Assuming the CDISC extract completes, the problem is likely in the SPSS
    XSLT postprocessor. Because there are two output files in the package,
    there are two stylesheets. They are configured in extract.properties:

    extract.9.odmType=clinical_data
    extract.9.file=odm_spss_sps.xsl,odm_spss_dat.xsl
    extract.9.fileDescription=SPSS data and syntax
    extract.9.linkText=Run Now
    extract.9.helpText=Generate SPSS style sheets
    extract.9.location=$exportFilePath/$datasetName/SPSS
    # If you customize the name of the .dat file, you will either have to:
    # 1. change the related XLST stylesheet (odm_spss_sps.xsl) to generate
    correct reference to .dat file name
    # -or-
    # 2. change it manually inside the .sps output file
    extract.9.exportname=SPSS_SPS.sps,SPSS_DAT.dat
    extract.9.zipName=SPSS_$datasetName_$dateTime.spss
    #extract.9.zip=true
    #extract.9.deleteOld=true
    extract.9.success=Your extract job completed successfully. The file is
    available for down load $linkURL.
    #extract.9.failure=The extract did not complete due to errors. Please
    contact your system administrator for details.

    3. You can isolate if the problem is with just one or the other of the
    stylesheets by reconfiguring the properties, eg:
    extract.9.file=odm_spss_sps.xsl
    extract.9.exportname=SPSS_SPS.sps

    then try the same with the .dat files (restart tomcat each time)

    4. If one of them errors, you can also try running the CDISC XML output
    through one of these stylesheets using a standalone processor on your
    workstation. This may give more informative error messages to help you
    correct the problem or share with the list to get help.

    Best,
    Cal
  • kristiakkristiak Posts: 1,313 ✭✭✭

    Hi Jacob,

    No, we have never run into this problem. How many subjects do you have in your study?  Have you configured Tomcat 7 as indicated in the installation manual? Have you checked the log file? Have you collected the data in 3.3 or converted from an earlier version? You mentioned that you had made new versions of the CRF's but not entered any new data. Have you converted all the patients to the new version of the CRF's?

    Regards

    Krister

  • sookeyosookeyo Posts: 75
    via Email
    Hi Jackob.
    I've had similar problems since i started running o.c 3.3. Tomcat 7 does not run more than one study. I've been asking the same here severally but no one responds to me. I don't know whether there is a problem with tomcat 7? Someone may help me understand. I've tried in several different machines with different configurations.
    Regards

    Sent from my Lumia Windows Phone
    ________________________________
    From: jacob.rousseau
    Sent:
  • kristiakkristiak Posts: 1,313 ✭✭✭

    We had some problems with the earlier versions of Tomcat 7. Now we are running Tomcat 7.0.55 without any problems.

This discussion has been closed.