We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

apostrophe in open clinica

Hi Janus,
I discovered that the problem was an apostrophe in the Section Label. The label had "can't", so I had to change it to "cannot". I don't know if there is a solution to this other than this workaround. I also face a similar problem whenever there are a set of values in which the response options contain a comma. When that's the case i have to use a semicolon instead. I don't know if there are solutions for those two issues.

Thanks
Wael


Date: Mon, 16 Jul 2012 10:57:02 +0200
From: Janus Engstr?m
To: [email protected]
Subject: Re: [Developers] Maximum number of fields in a crf
Message-ID:

Content-Type: text/plain; charset="utf-8"
Hi Wael,
A CRF of that size is probably created by a lot of copy/paste of large
chucks of lines. In my experience, it's quite easy to introduce empty
lines in the excel sheet when doing this. Please check for empty lines in
your .XLS file, as this could be the cause of your problem.
Best regards,

Comments

  • rkelley2rkelley2 Posts: 38
    Hi Wael,

    You might try replacing the apostrophe with the appropriate character code ('), and see if that gets you what you want.

    Also, you can have commas in your response options text by using the escape sequence (\,) like this:

    1. African,2. European,3. Indigenous or Native American (e.g.\, Native North and Central America\, Native South American\, Canadian First Peoples),4. Southwest Asian and Middle Eastern (e.g.\, Turkey\, Arabia\, Iran\, Syria\, Israel),5. South Asian (e.g.\, Pakistan and India),6. East and South East Asian (e.g.\, China\, Japan\, Korea\, Vietnam\, Malaysia),7. Pacific Islander (e.g.\, Native Hawaiian\, Samoan\, Maori\, Aboriginal Australian),8. Not reported/unknown


    Reggie

    Reggie Kelley
    Database Analyst

    CCS Associates
    1923 Landings Dr.
    Mountain View, CA 94043
    Voice: 650-963-8152
    Fax: 650-691-4410
    www.ccsainc.com
    ------------------------------------------------------------------------------------
    This message contains information that may be confidential and privileged. Unless you are the addressee (or authorized to receive for the addressee), you may not use, copy, or disclose to anyone the message or any information contained in the message. If you have received this message in error, please advise the sender by reply e-mail and delete the message.
    Sent: Thursday, July 19, 2012 12:02 PM
    To: [email protected]
    Subject: [Developers] apostrophe in open clinica

    Hi Janus,
    I discovered that the problem was an apostrophe in the Section Label. The label had "can't", so I had to change it to "cannot". I don't know if there is a solution to this other than this workaround. I also face a similar problem whenever there are a set of values in which the response options contain a comma. When that's the case i have to use a semicolon instead. I don't know if there are solutions for those two issues.

    Thanks
    Wael


    Date: Mon, 16 Jul 2012 10:57:02 +0200
    From: Janus Engstr?m
    To: [email protected]
    Subject: Re: [Developers] Maximum number of fields in a crf
    Message-ID:

    Content-Type: text/plain; charset="utf-8"
    Hi Wael,
    A CRF of that size is probably created by a lot of copy/paste of large
    chucks of lines. In my experience, it's quite easy to introduce empty
    lines in the excel sheet when doing this. Please check for empty lines in
    your .XLS file, as this could be the cause of your problem.
    Best regards,
  • sedky69sedky69 Posts: 26
    Hi Reggie,
    I have another small issue if you don't mind. I setup my first study, but when I try to add patients I get a screen asking for (among other things) enrollment date, sex, date of birth, study event and start date. I'd post a screenshot, but i am not sure if I am allowed.
    One concern is I've already defined in the system that my participants are only females, also the rest of this information is already available on the CRF. is there a way to disable this window so that all i need to enter is the site and subject?
    Also is there a way to batch load investigators?
    Thanks and sorry for all those newbie questions :)
    Wael
    Subject: Re: [Developers] apostrophe in open clinica
    Message-ID:


    Content-Type: text/plain; charset="us-ascii"
    Hi Wael,
    You might try replacing the apostrophe with the appropriate character code ('), and see if that gets you what you want.
    Also, you can have commas in your response options text by using the escape sequence (\,) like this:
    1. African,2. European,3. Indigenous or Native American (e.g.\, Native North and Central America\, Native South American\, Canadian First Peoples),4. Southwest Asian and Middle Eastern (e.g.\, Turkey\, Arabia\, Iran\, Syria\, Israel),5. South Asian (e.g.\, Pakistan and India),6. East and South East Asian (e.g.\, China\, Japan\, Korea\, Vietnam\, Malaysia),7. Pacific Islander (e.g.\, Native Hawaiian\, Samoan\, Maori\, Aboriginal Australian),8. Not reported/unknown
    Reggie
    Reggie Kelley
    Database Analyst
  • Dear Wael,

    You can turn off some of these parameters when setting up the study (Edit Study page). Sex can be made optional and Date of Birth can be marked as “Not Used”.

    I have reported the section quotation mark problem in the issuetracker:
    https://issuetracker.openclinica.com/view.php?id=13707

    And a reference for escaping commas in response options text:
    https://mailman.openclinica.com/pipermail/users/2009-March/001517.html
    If you would like to use a comma in your set of responses, the escape character is "\\"

    Strangely, the OC docs suggest escaping commas with a /:
    https://docs.openclinica.com/3.1/technical-documents/openclinica-ecrf-specifications/crf-template-elements
    If the options themselves contain commas (,) you must escape the commas with a /

    Yours,

    Michael
    Sent: 20 July 2012 01:54
    To: [email protected]
    Subject: Re: [Developers] apostrophe in open clinica

    Hi Reggie,

    I have another small issue if you don't mind. I setup my first study, but when I try to add patients I get a screen asking for (among other things) enrollment date, sex, date of birth, study event and start date. I'd post a screenshot, but i am not sure if I am allowed.

    One concern is I've already defined in the system that my participants are only females, also the rest of this information is already available on the CRF. is there a way to disable this window so that all i need to enter is the site and subject?

    Also is there a way to batch load investigators?

    Thanks and sorry for all those newbie questions :)

    Wael

    Subject: Re: [Developers] apostrophe in open clinica
    Message-ID:


    Content-Type: text/plain; charset="us-ascii"
    Hi Wael,
    You might try replacing the apostrophe with the appropriate character code ('), and see if that gets you what you want.
    Also, you can have commas in your response options text by using the escape sequence (\,) like this:
    1. African,2. European,3. Indigenous or Native American (e.g.\, Native North and Central America\, Native South American\, Canadian First Peoples),4. Southwest Asian and Middle Eastern (e.g.\, Turkey\, Arabia\, Iran\, Syria\, Israel),5. South Asian (e.g.\, Pakistan and India),6. East and South East Asian (e.g.\, China\, Japan\, Korea\, Vietnam\, Malaysia),7. Pacific Islander (e.g.\, Native Hawaiian\, Samoan\, Maori\, Aboriginal Australian),8. Not reported/unknown
    Reggie
    Reggie Kelley
    Database Analyst
    The University of Dundee is a registered Scottish Charity, No: SC015096
This discussion has been closed.