We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Upgrading from 3.0.x to 3.1 beta

Dear OC users,
Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
The first failed and the second seems OK. (But I need the first one )
Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
Any experiences on that will be appreciated.
Thanks, Cuneyt.
--
Cuneyt Parlayan
Datamanager
Department of Pathology
Room: ZH 0 E 50
VU University Medical Center
Amsterdam
phone: +31 20 4444025
«134

Comments

  • Paul GalvinPaul Galvin Posts: 886
    Hi Cuneyt,

    Do you see any liquibase errors in your openclinica.log file from the instance that can’t be upgraded?

    We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with the betas of 3.1, but we have not tried 3.0.1.

    One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then point 3.1 to it to see if it works successfully.

    Thanks,
    Paul

    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    OpenClinica
    781-547-8425
    Register for the 2011 OpenClinica Global Conference | May 8-9 | Boston
    www.openclinica.com
    Open Source Platform for Clinical Research
    Sent: Wednesday, March 09, 2011 9:28 AM
    To: [email protected]; [email protected]
    Subject: [Users] Upgrading from 3.0.x to 3.1 beta

    Dear OC users,
    Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
    The first failed and the second seems OK. (But I need the first one )
    Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
    Any experiences on that will be appreciated.
    Thanks, Cuneyt.
    --
    Cuneyt Parlayan
    Datamanager
    Department of Pathology
    Room: ZH 0 E 50
    VU University Medical Center
    Amsterdam
    phone: +31 20 4444025
  • Paul GalvinPaul Galvin Posts: 886
    Hi Cuneyt,

    Do you see any liquibase errors in your openclinica.log file from the instance that can’t be upgraded?

    We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with the betas of 3.1, but we have not tried 3.0.1.

    One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then point 3.1 to it to see if it works successfully.

    Thanks,
    Paul

    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    OpenClinica
    781-547-8425
    Register for the 2011 OpenClinica Global Conference | May 8-9 | Boston
    www.openclinica.com
    Open Source Platform for Clinical Research
    Sent: Wednesday, March 09, 2011 9:28 AM
    To: [email protected]; [email protected]
    Subject: [Users] Upgrading from 3.0.x to 3.1 beta

    Dear OC users,
    Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
    The first failed and the second seems OK. (But I need the first one )
    Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
    Any experiences on that will be appreciated.
    Thanks, Cuneyt.
    --
    Cuneyt Parlayan
    Datamanager
    Department of Pathology
    Room: ZH 0 E 50
    VU University Medical Center
    Amsterdam
    phone: +31 20 4444025
  • parlayanparlayan Posts: 139
    HIi Paul,
    Thanks for your reply.

    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database section of the datainfo.properties file as follows:

    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect

    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is, like this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.

    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.

    Documentation bug? Or am I missing something?

    Thanks,
    Cuneyt.


    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin wrote:
    Hi Cuneyt,

    Do you see any liquibase errors in your openclinica.log file from the instance that can’t be upgraded?

    We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with the betas of 3.1, but we have not tried 3.0.1.

    One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then point 3.1 to it to see if it works successfully.

    Thanks,
    Paul

    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    OpenClinica
    781-547-8425
    Register for the 2011 OpenClinica Global Conference | May 8-9 | Boston
    www.openclinica.com
    Open Source Platform for Clinical Research
    Sent: Wednesday, March 09, 2011 9:28 AM
    To: [email protected]; [email protected]
    Subject: [Users] Upgrading from 3.0.x to 3.1 beta

    Dear OC users,
    Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
    The first failed and the second seems OK. (But I need the first one )
    Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
    Any experiences on that will be appreciated.
    Thanks, Cuneyt.
    --
    Cuneyt Parlayan
    Datamanager
    Department of Pathology
    Room: ZH 0 E 50
    VU University Medical Center
    Amsterdam
    phone: +31 20 4444025
  • Hi,
    This satyanarayana, can you tell me please how to run the source code of openclinica 3.0.
    I am new to this. i am using eclipse ide. I installed maven plugins and svn also. But the problem is project is build successufully but i cant add the server to project. if i create the war file and deploye in webapps tomcat home directory then project is working fine. but directly i can run the application. Please help me.

    Thanks & Regards
    Satyanarayana G.
  • Paul GalvinPaul Galvin Posts: 886
    Hi Cuneyt,
    It is a documentation bug. Thanks for bringing it to our attention, and we will be sure to change the instructions.
    Thanks,
    Paul
    -----Original Message-----
    Sent: Thu 3/10/2011 4:08 AM
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] Upgrading from 3.0.x to 3.1 beta

    HIi Paul,
    Thanks for your reply.
    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database
    section of the datainfo.properties file as follows:
    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect
    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is, like
    this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.
    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.
    Documentation bug? Or am I missing something?
    Thanks,
    Cuneyt.
    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin wrote:
    > > Hi Cuneyt,
    > >
    > >
    > >
    > > Do you see any liquibase errors in your openclinica.log file from the
    > > instance that can't be upgraded?
    > >
    > >
    > >
    > > We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with
    > > the betas of 3.1, but we have not tried 3.0.1.
    > >
    > >
    > >
    > > One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then
    > > point 3.1 to it to see if it works successfully.
    > >
    > >
    > >
    > > Thanks,
    > >
    > > Paul
    > >
    > >
    > >
    > > -----------------------------------------------------------------------
    > >
    > > Paul J. Galvin
    > > Project Manager
    > > OpenClinica
    > > 781-547-8425
    > >
    > > Register for the 2011 OpenClinica Global Conference| May 8-9 | Boston
    > >
    > > www.openclinica.com
    > > Open Source Platform for Clinical Research
    > > ------------------------------
    > >
    > > *From:* [email protected] [mailto:
    > > [email protected]] *On Behalf Of *Cuneyt Parlayan
    > > *Sent:* Wednesday, March 09, 2011 9:28 AM
    > > *To:* [email protected]; [email protected]
    > > *Subject:* [Users] Upgrading from 3.0.x to 3.1 beta
    > >
    > >
    > >
    > > Dear OC users,
    > >
    > > Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    > >
    > > I tried this on two virtual machines where one already has data on it, and
    > > one with only default study and root as user.
    > > The first failed and the second seems OK. (But I need the first one [?])
    > >
    > > Has anyone tried upgrading (not clean install, but upgrade from a previous
    > > version) to 3.1?
    > > Any experiences on that will be appreciated.
    > > Thanks, Cuneyt.
    > >
    > > --
    > > Cuneyt Parlayan
    > >
    > > Datamanager
    > > Department of Pathology
    > > Room: ZH 0 E 50
    > > VU University Medical Center
    > > Amsterdam
    > > phone: +31 20 4444025
    > >
    > >
  • Paul GalvinPaul Galvin Posts: 886
    RE: [Users] Upgrading from 3.0.x to 3.1 beta
    Hi Cuneyt,
    It is a documentation bug. Thanks for bringing it to our attention, and we will be sure to change the instructions.
    Thanks,
    Paul
    -----Original Message-----
    Sent: Thu 3/10/2011 4:08 AM
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] Upgrading from 3.0.x to 3.1 beta
    HIi Paul,
    Thanks for your reply.
    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database
    section of the datainfo.properties file as follows:
    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect
    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is, like
    this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.
    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.
    Documentation bug? Or am I missing something?
    Thanks,
    Cuneyt.
    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin wrote:
    > Hi Cuneyt,
    >
    >
    >
    > Do you see any liquibase errors in your openclinica.log file from the
    > instance that can't be upgraded?
    >
    >
    >
    > We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with
    > the betas of 3.1, but we have not tried 3.0.1.
    >
    >
    >
    > One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then
    > point 3.1 to it to see if it works successfully.
    >
    >
    >
    > Thanks,
    >
    > Paul
    >
    >
    >
    > -----------------------------------------------------------------------
    >
    > Paul J. Galvin
    > Project Manager
    > OpenClinica
    > 781-547-8425
    >
    > Register for the 2011 OpenClinica Global Conference| May 8-9 | Boston
    >
    > www.openclinica.com
    > Open Source Platform for Clinical Research
    > ------------------------------
    >
    > *From:* [email protected] [mailto:
    > [email protected]] *On Behalf Of *Cuneyt Parlayan
    > *Sent:* Wednesday, March 09, 2011 9:28 AM
    > *To:* [email protected]; [email protected]
    > *Subject:* [Users] Upgrading from 3.0.x to 3.1 beta
    >
    >
    >
    > Dear OC users,
    >
    > Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    >
    > I tried this on two virtual machines where one already has data on it, and
    > one with only default study and root as user.
    > The first failed and the second seems OK. (But I need the first one [?])
    >
    > Has anyone tried upgrading (not clean install, but upgrade from a previous
    > version) to 3.1?
    > Any experiences on that will be appreciated.
    > Thanks, Cuneyt.
    >
    > --
    > Cuneyt Parlayan
    >
    > Datamanager
    > Department of Pathology
    > Room: ZH 0 E 50
    > VU University Medical Center
    > Amsterdam
    > phone: +31 20 4444025
    >
    >
  • rcosanorcosano Posts: 2
    Hello
    I tried upgrade openclinica 3.0.4 to 3.1 beta and I could.
    But now I have a problem when I have Add New Subject, because in the
    screen I can see OpenClinica: an error has occurred.
    In the logs I can't see nothing
    Why can It be?
    Thanks,
    Raquel
    -----Mensaje original-----
    De: [email protected] [mailto:[email protected]]
    En nombre de Paul Galvin
    Enviado el: jueves, 10 de marzo de 2011 13:06
    Para: [email protected]; [email protected]
    CC: [email protected]
    Asunto: RE: [Users] Upgrading from 3.0.x to 3.1 beta
    Hi Cuneyt,
    It is a documentation bug. Thanks for bringing it to our attention, and
    we will be sure to change the instructions.
    Thanks,
    Paul
    -----Original Message-----
    Sent: Thu 3/10/2011 4:08 AM
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] Upgrading from 3.0.x to 3.1 beta

    HIi Paul,
    Thanks for your reply.
    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database
    section of the datainfo.properties file as follows:
    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect
    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is,
    like
    this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.
    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.
    Documentation bug? Or am I missing something?
    Thanks,
    Cuneyt.
    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin
    wrote:
    > > Hi Cuneyt,
    > >
    > >
    > >
    > > Do you see any liquibase errors in your openclinica.log file from the
    > > instance that can't be upgraded?
    > >
    > >
    > >
    > > We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1
    > > with the betas of 3.1, but we have not tried 3.0.1.
    > >
    > >
    > >
    > > One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and
    > > then point 3.1 to it to see if it works successfully.
    > >
    > >
    > >
    > > Thanks,
    > >
    > > Paul
    > >
    > >
    > >
    > > ----------------------------------------------------------------------
    > > -
    > >
    > > Paul J. Galvin
    > > Project Manager
    > > OpenClinica
    > > 781-547-8425
    > >
    > > Register for the 2011 OpenClinica Global
    > > Conference| May 8-9 | Boston
    > >
    > > www.openclinica.com
    > > Open Source Platform for Clinical Research
    > > ------------------------------
    > >
    > > *From:* [email protected] [mailto:
    > > [email protected]] *On Behalf Of *Cuneyt Parlayan
    > > *Sent:* Wednesday, March 09, 2011 9:28 AM
    > > *To:* [email protected]; [email protected]
    > > *Subject:* [Users] Upgrading from 3.0.x to 3.1 beta
    > >
    > >
    > >
    > > Dear OC users,
    > >
    > > Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    > >
    > > I tried this on two virtual machines where one already has data on it,
    > > and one with only default study and root as user.
    > > The first failed and the second seems OK. (But I need the first one
    > > [?])
    > >
    > > Has anyone tried upgrading (not clean install, but upgrade from a
    > > previous
    > > version) to 3.1?
    > > Any experiences on that will be appreciated.
    > > Thanks, Cuneyt.
    > >
    > > --
    > > Cuneyt Parlayan
    > >
    > > Datamanager
    > > Department of Pathology
    > > Room: ZH 0 E 50
    > > VU University Medical Center
    > > Amsterdam
    > > phone: +31 20 4444025
    > >
    > >
  • grzesaggrzesag Posts: 14
    Hi Paul and Cuneyt
    I agree with Cuneyt I had the same problems when trying to install OC 3.1. WIth the default settings OP 3.1 works if I change db username/db/password won't work.
    I did not report this as this is still beta release and I hope it will be solved. I hope that development team is aware about this issue allready.
    Regards
    G
    On 10 March 2011 09:08, Cuneyt Parlayan wrote:
    HIi Paul,
    Thanks for your reply.

    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database section of the datainfo.properties file as follows:

    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect

    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is, like this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.

    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.

    Documentation bug? Or am I missing something?

    Thanks,
    Cuneyt.


    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin wrote:
    Hi Cuneyt,

    Do you see any liquibase errors in your openclinica.log file from the instance that can’t be upgraded?

    We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with the betas of 3.1, but we have not tried 3.0.1.

    One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then point 3.1 to it to see if it works successfully.

    Thanks,
    Paul

    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    OpenClinica
    781-547-8425
    Register for the 2011 OpenClinica Global Conference | May 8-9 | Boston
    www.openclinica.com
    Open Source Platform for Clinical Research
    Sent: Wednesday, March 09, 2011 9:28 AM
    To: [email protected]; [email protected]
    Subject: [Users] Upgrading from 3.0.x to 3.1 beta

    Dear OC users,
    Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
    The first failed and the second seems OK. (But I need the first one )
    Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
    Any experiences on that will be appreciated.
    Thanks, Cuneyt.
    --
    Cuneyt Parlayan
    Datamanager
    Department of Pathology
    Room: ZH 0 E 50
    VU University Medical Center
    Amsterdam
    phone: +31 20 4444025
  • parlayanparlayan Posts: 139
    Hi documentation team van Open Clinica,
    Maybe it is also useful to include the following in the upgrade documentation.
    In the "backup" section, it is clearly stated that openclinica.data directory must be saved in order to keep the CRF data.
    But after completing the installation it is not mentioned that the contents of the saved openclinica.data should be copied in the newly created empty openclinica.data.
    This can be easily skipped if you are doing the upgrage on a friday afternoon.
    If the documentation contains an instruction to do so, the chance of skipping will be significantly lower.
    Thanks, Cuneyt.

    On Thu, Mar 10, 2011 at 10:48 PM, Grzegorz Agacinski wrote:
    Hi Paul and Cuneyt
    I agree with Cuneyt I had the same problems when trying to install OC 3.1. WIth the default settings OP 3.1 works if I change db username/db/password won't work.
    I did not report this as this is still beta release and I hope it will be solved. I hope that development team is aware about this issue allready.
    Regards
    G
    On 10 March 2011 09:08, Cuneyt Parlayan wrote:
    HIi Paul,
    Thanks for your reply.

    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database section of the datainfo.properties file as follows:

    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect

    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is, like this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.

    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.

    Documentation bug? Or am I missing something?

    Thanks,
    Cuneyt.


    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin wrote:
    Hi Cuneyt,

    Do you see any liquibase errors in your openclinica.log file from the instance that can’t be upgraded?

    We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with the betas of 3.1, but we have not tried 3.0.1.

    One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then point 3.1 to it to see if it works successfully.

    Thanks,
    Paul

    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    OpenClinica
    781-547-8425
    Register for the 2011 OpenClinica Global Conference | May 8-9 | Boston
    www.openclinica.com
    Open Source Platform for Clinical Research
    Sent: Wednesday, March 09, 2011 9:28 AM
    To: [email protected]; [email protected]
    Subject: [Users] Upgrading from 3.0.x to 3.1 beta

    Dear OC users,
    Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
    The first failed and the second seems OK. (But I need the first one )
    Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
    Any experiences on that will be appreciated.
    Thanks, Cuneyt.
    --
    Cuneyt Parlayan
    Datamanager
    Department of Pathology
    Room: ZH 0 E 50
    VU University Medical Center
    Amsterdam
    phone: +31 20 4444025
  • parlayanparlayan Posts: 139
    Hi doc team, it' s me again.
    In addition to my wish of including the maintenance of "openclinica.data" directory as a post installation action in the upgrade documentation, I stongly recommend to underscore that this is now called "openclinica-web.data" and not "openclinica.data" anymore. People (like myself on a friday afternoon) can just copy the openclinica.data without even noticing that this has now a different name, which results with unhappy users being separated from their CRF' s.
    Thanks and a good weekend,
    Cuneyt.
    On Fri, Mar 11, 2011 at 8:28 PM, Cuneyt Parlayan wrote:
    Hi documentation team van Open Clinica,
    Maybe it is also useful to include the following in the upgrade documentation.
    In the "backup" section, it is clearly stated that openclinica.data directory must be saved in order to keep the CRF data.
    But after completing the installation it is not mentioned that the contents of the saved openclinica.data should be copied in the newly created empty openclinica.data.
    This can be easily skipped if you are doing the upgrage on a friday afternoon.
    If the documentation contains an instruction to do so, the chance of skipping will be significantly lower.
    Thanks, Cuneyt.

    On Thu, Mar 10, 2011 at 10:48 PM, Grzegorz Agacinski wrote:
    Hi Paul and Cuneyt
    I agree with Cuneyt I had the same problems when trying to install OC 3.1. WIth the default settings OP 3.1 works if I change db username/db/password won't work.
    I did not report this as this is still beta release and I hope it will be solved. I hope that development team is aware about this issue allready.
    Regards
    G
    On 10 March 2011 09:08, Cuneyt Parlayan wrote:
    HIi Paul,
    Thanks for your reply.

    This is what I have consantrated:
    In the upgrade document it is stated that you should edit the database section of the datainfo.properties file as follows:

    username=clinica
    password=clinica
    url=jdbc:postgresql://localhost:5432/openclinica
    dataBase=postgres
    driver=org.postgresql.Driver
    hibernate.dialect=org.hibernate.dialect.PostgreSQLDialect

    If you do that, OC doesn't start. You get a HTTP Error.
    Whereas if you dont't do anything in that section and leave it as is, like this:
    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost
    It works fine.

    We have W2008 server; PG 8.4.1.1 Tomcat 6.0.20 and jdk-6u16.

    Documentation bug? Or am I missing something?

    Thanks,
    Cuneyt.


    On Wed, Mar 9, 2011 at 11:40 PM, Paul Galvin wrote:
    Hi Cuneyt,

    Do you see any liquibase errors in your openclinica.log file from the instance that can’t be upgraded?

    We have upgraded instances successfully from 3.0.3, 3.0.4, and 3.0.4.1 with the betas of 3.1, but we have not tried 3.0.1.

    One thing you could do is point 3.0.4.1 to your 3.0.1 instance, and then point 3.1 to it to see if it works successfully.

    Thanks,
    Paul

    -----------------------------------------------------------------------
    Paul J. Galvin
    Project Manager
    OpenClinica
    781-547-8425
    Register for the 2011 OpenClinica Global Conference | May 8-9 | Boston
    www.openclinica.com
    Open Source Platform for Clinical Research
    Sent: Wednesday, March 09, 2011 9:28 AM
    To: [email protected]; [email protected]
    Subject: [Users] Upgrading from 3.0.x to 3.1 beta

    Dear OC users,
    Is it possible to upgrade from OC 3.0.1 to 3.1. beta?
    I tried this on two virtual machines where one already has data on it, and one with only default study and root as user.
    The first failed and the second seems OK. (But I need the first one )
    Has anyone tried upgrading (not clean install, but upgrade from a previous version) to 3.1?
    Any experiences on that will be appreciated.
    Thanks, Cuneyt.
    --
    Cuneyt Parlayan
    Datamanager
    Department of Pathology
    Room: ZH 0 E 50
    VU University Medical Center
    Amsterdam
    phone: +31 20 4444025
This discussion has been closed.