We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

missing data in openclinica export

2»

Comments

  • kristiakkristiak Posts: 1,338 ✭✭✭
    You have to know what you are doing as with any advanced product. In experienced hands it is a superior product, we have used it for several years now and have no problems. The problems occur when inexperienced users install it and use it in production environment without following the rigid validation rules. The worst case is scenario is when some people install the beta version and are surprised that there are problems messing up their data.
    You would see problems even with products like Oracle Clinical and other high priced products if left to untrained and inexperienced people. During my several decades in this business I have seen it all.
    /Krister
    -----Original Message-----
    Sent: den 17 mars 2011 19:48
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] missing data in openclinica export
    Don't waste your time with this. It's totally useless.
  • kristiakkristiak Posts: 1,338 ✭✭✭
    You have to know what you are doing as with any advanced product. In experienced hands it is a superior product, we have used it for several years now and have no problems. The problems occur when inexperienced users install it and use it in production environment without following the rigid validation rules. The worst case is scenario is when some people install the beta version and are surprised that there are problems messing up their data.
    You would see problems even with products like Oracle Clinical and other high priced products if left to untrained and inexperienced people. During my several decades in this business I have seen it all.
    /Krister
    -----Original Message-----
    Sent: den 17 mars 2011 19:48
    To: [email protected]
    Cc: [email protected]
    Subject: Re: [Users] missing data in openclinica export
    Don't waste your time with this. It's totally useless.
  • mtepasmtepas Posts: 6
    Hi Krister,

    We use version 3.0.4.1 (upgrade last november) on CentOS 5.4 (server OS) with PostgreSQL 8.4 (database) all in English.

    Hope you can help!

    Best,
    Mark


    ----
    Mark te Pas
    AMC-CPCD Foundation
    Pietersbergweg 17
    1105 BM Amsterdam
    The Netherlands
    T: +31 (0)20-5661589
    E: [email protected]
    Sent: Thursday, March 17, 2011 10:22 PM
    To: [email protected]; [email protected]
    Subject: Re: [Users] missing data in openclinica export

    Hi Mark,

    Which version of OC do you use? What is your server OS? What language version of the OS? I have tried to reproduce the events that you describe in OC 3.0.4.1 but have not been able to reproduce your problems.

    Regards

    Krister
    Sent: den 17 mars 2011 15:21
    To: us[email protected]
    Subject: [Users] missing data in openclinica export

    Dear OC users,

    First we have problems with correction of data after a CRF has been marked complete. Example: a CRF is marked complete but the data manager wants to make changes after monitoring. Some of the changes made are shown in the open clinica database but are not reflected when doing a data export to excel. The old, incorrect, data will show in the excel sheet. We discovered that when you change data in the database sometimes a exclamation mark shows that warns you that data have been changed and you must provide a reason. When you do this you can save the data and they changes will be reflected in the export. However, for some reasons, sometimes the exclamation mark does not appear. The system will tell you the data have been saved but the changes are not reflected in the export.

    Furthermore we have a particular patient with a completed form that does not appear in the excel export. The patient ID is in the export, the interviewer and interview date are there but all other fields are empty although these fields are completed in the database.

    We have a particular fields for which the content is exported for some patients but not for others (for example blood pressure; we have data in the database for 10 patients but in the excel export the field is empty for 5 of those patients)

    We have a form that has 2 version: in version 1 one field was missing. In version 2 this field was added. When we export the data to excel, both versions are exported but the added field is missing in the export. When we look at the definition of the export, there is not option to add this field to the export.

    Many thanks in advance for all help!

    Mark


    ----
    Mark te Pas
    AMC-CPCD Foundation
    Pietersbergweg 17
    1105 BM Amsterdam
    The Netherlands
    T: +31 (0)20-5661589
    E: [email protected]
  • kristiakkristiak Posts: 1,338 ✭✭✭
    Well, having two versions of a form always creates problems particularly if you have already entered data. What we always do is to run a prototype of the database and when everyone is happy with it and it has been properly validated including an official UAT, we setup a clean install on the production server and only now do we allow data entry to start. With this method we have so far no seen any problems in the export. Have you entered much data? Otherwise I would recommend rekeying the data in a clean database where all fields are present from the start.

    My other question. What Internet browser do you use. IE can sometimes cause data problems if running in compatibility mode.

    Hope this can help.

    Regards

    Krister
    Sent: den 21 mars 2011 10:10
    To: [email protected]
    Subject: Re: [Users] missing data in openclinica export

    Hi Krister,

    We use version 3.0.4.1 (upgrade last november) on CentOS 5.4 (server OS) with PostgreSQL 8.4 (database) all in English.

    Hope you can help!

    Best,
    Mark


    ----
    Mark te Pas
    AMC-CPCD Foundation
    Pietersbergweg 17
    1105 BM Amsterdam
    The Netherlands
    T: +31 (0)20-5661589
    E: [email protected]
    Sent: Thursday, March 17, 2011 10:22 PM
    To: [email protected]; [email protected]
    Subject: Re: [Users] missing data in openclinica export

    Hi Mark,

    Which version of OC do you use? What is your server OS? What language version of the OS? I have tried to reproduce the events that you describe in OC 3.0.4.1 but have not been able to reproduce your problems.

    Regards

    Krister
    Sent: den 17 mars 2011 15:21
    To: [email protected]
    Subject: [Users] missing data in openclinica export

    Dear OC users,

    First we have problems with correction of data after a CRF has been marked complete. Example: a CRF is marked complete but the data manager wants to make changes after monitoring. Some of the changes made are shown in the open clinica database but are not reflected when doing a data export to excel. The old, incorrect, data will show in the excel sheet. We discovered that when you change data in the database sometimes a exclamation mark shows that warns you that data have been changed and you must provide a reason. When you do this you can save the data and they changes will be reflected in the export. However, for some reasons, sometimes the exclamation mark does not appear. The system will tell you the data have been saved but the changes are not reflected in the export.

    Furthermore we have a particular patient with a completed form that does not appear in the excel export. The patient ID is in the export, the interviewer and interview date are there but all other fields are empty although these fields are completed in the database.

    We have a particular fields for which the content is exported for some patients but not for others (for example blood pressure; we have data in the database for 10 patients but in the excel export the field is empty for 5 of those patients)

    We have a form that has 2 version: in version 1 one field was missing. In version 2 this field was added. When we export the data to excel, both versions are exported but the added field is missing in the export. When we look at the definition of the export, there is not option to add this field to the export.

    Many thanks in advance for all help!

    Mark


    ----
    Mark te Pas
    AMC-CPCD Foundation
    Pietersbergweg 17
    1105 BM Amsterdam
    The Netherlands
    T: +31 (0)20-5661589
    E: [email protected]
  • ctreptectrepte Posts: 100
    Hi,
    we have problems similar to what Mark described. We are using OC 3.0.4, PostgreSQL 8.4 on a Windows XP server (all in English).
    We have two sets of data (same CRF, same version, two different events) they appear completely blank when exported (both in Excel and SPSS exports) although data has been entered and is visible in Data Entry and View modes. I just noticed that for another CRF where data have been changed the change is not exported, the exported values are the "old" ones.
    I must admit that this is a little troubling as we cannot do a 100% check on all data exports. The validation we did in the beginning was fine and we have not been able to reproduce this error, thousands of other data entered and/or changed export correctly.
    Best regards,
    Claudia
    -------
    Data Manager
    NovaShunt AG
    Am 3/21/2011 10:10 AM, schrieb Mark te Pas:
    >
    > Hi Krister,
    >
    >
    >
    > We use version 3.0.4.1 (upgrade last november) on CentOS 5.4 (server OS) with PostgreSQL 8.4 (database) all in English.
    >
    >
    >
    > Hope you can help!
    >
    >
    >
    > Best,
    >
    > Mark
    >
    >
    >
    >
    >
    > ----
    >
    > Mark te Pas
    >
    > AMC-CPCD Foundation
    >
    > Pietersbergweg 17
    >
    > 1105 BM Amsterdam
    >
    > The Netherlands
    >
    > T: +31 (0)20-5661589
    >
    > E: [email protected]
    >
    >
    >
    >
    > Sent: Thursday, March 17, 2011 10:22 PM
    > To: [email protected]; [email protected]
    > Subject: Re: [Users] missing data in openclinica export
    >
    >
    >
    > Hi Mark,
    >
    >
    >
    > Which version of OC do you use? What is your server OS? What language version of the OS? I have tried to reproduce the events that you describe in OC 3.0.4.1 but have not been able to reproduce your problems.
    >
    >
    >
    > Regards
    >
    >
    >
    > Krister
    >
    >
    >
    >
    > Sent: den 17 mars 2011 15:21
    > To: [email protected]
    > Subject: [Users] missing data in openclinica export
    >
    >
    >
    > Dear OC users,
    >
    >
    >
    > First we have problems with correction of data after a CRF has been marked complete. Example: a CRF is marked complete but the data manager wants to make changes after monitoring. Some of the changes made are shown in the open clinica database but are not reflected when doing a data export to excel. The old, incorrect, data will show in the excel sheet. We discovered that when you change data in the database sometimes a exclamation mark shows that warns you that data have been changed and you must provide a reason. When you do this you can save the data and they changes will be reflected in the export. However, for some reasons, sometimes the exclamation mark does not appear. The system will tell you the data have been saved but the changes are not reflected in the export.
    >
    >
    >
    > Furthermore we have a particular patient with a completed form that does not appear in the excel export. The patient ID is in the export, the interviewer and interview date are there but all other fields are empty although these fields are completed in the database.
    >
    >
    >
    > We have a particular fields for which the content is exported for some patients but not for others (for example blood pressure; we have data in the database for 10 patients but in the excel export the field is empty for 5 of those patients)
    >
    >
    >
    > We have a form that has 2 version: in version 1 one field was missing. In version 2 this field was added. When we export the data to excel, both versions are exported but the added field is missing in the export. When we look at the definition of the export, there is not option to add this field to the export.
    >
    >
    >
    > Many thanks in advance for all help!
    >
    >
    >
    > Mark
    >
    >
    >
    >
    >
    > ----
    >
    > Mark te Pas
    >
    > AMC-CPCD Foundation
    >
    > Pietersbergweg 17
    >
    > 1105 BM Amsterdam
    >
    > The Netherlands
    >
    > T: +31 (0)20-5661589
    >
    > E: [email protected]
    >
    >
    >
    >
  • kristiakkristiak Posts: 1,338 ✭✭✭
    I’m curious to know what Paul and Tom thinks of this.

    Since it seems to be rare thing I hardly think it is in the code. Must be some external factor!

    Regards

    Krister
    Sent: den 21 mars 2011 13:28
    To: [email protected]
    Subject: Re: [Users] missing data in openclinica export

    Hi,
    we have problems similar to what Mark described. We are using OC 3.0.4, PostgreSQL 8.4 on a Windows XP server (all in English).
    We have two sets of data (same CRF, same version, two different events) they appear completely blank when exported (both in Excel and SPSS exports) although data has been entered and is visible in Data Entry and View modes. I just noticed that for another CRF where data have been changed the change is not exported, the exported values are the "old" ones.
    I must admit that this is a little troubling as we cannot do a 100% check on all data exports. The validation we did in the beginning was fine and we have not been able to reproduce this error, thousands of other data entered and/or changed export correctly.
    Best regards,
    Claudia
    -------
    Data Manager
    NovaShunt AG
    Am 3/21/2011 10:10 AM, schrieb Mark te Pas:
    Hi Krister,

    We use version 3.0.4.1 (upgrade last november) on CentOS 5.4 (server OS) with PostgreSQL 8.4 (database) all in English.

    Hope you can help!

    Best,
    Mark


    ----
    Mark te Pas
    AMC-CPCD Foundation
    Pietersbergweg 17
    1105 BM Amsterdam
    The Netherlands
    T: +31 (0)20-5661589
    E: [email protected]
    Sent: Thursday, March 17, 2011 10:22 PM
    To: [email protected]; [email protected]
    Subject: Re: [Users] missing data in openclinica export

    Hi Mark,

    Which version of OC do you use? What is your server OS? What language version of the OS? I have tried to reproduce the events that you describe in OC 3.0.4.1 but have not been able to reproduce your problems.

    Regards

    Krister
    Sent: den 17 mars 2011 15:21
    To: [email protected]
    Subject: [Users] missing data in openclinica export

    Dear OC users,

    First we have problems with correction of data after a CRF has been marked complete. Example: a CRF is marked complete but the data manager wants to make changes after monitoring. Some of the changes made are shown in the open clinica database but are not reflected when doing a data export to excel. The old, incorrect, data will show in the excel sheet. We discovered that when you change data in the database sometimes a exclamation mark shows that warns you that data have been changed and you must provide a reason. When you do this you can save the data and they changes will be reflected in the export. However, for some reasons, sometimes the exclamation mark does not appear. The system will tell you the data have been saved but the changes are not reflected in the export.

    Furthermore we have a particular patient with a completed form that does not appear in the excel export. The patient ID is in the export, the interviewer and interview date are there but all other fields are empty although these fields are completed in the database.

    We have a particular fields for which the content is exported for some patients but not for others (for example blood pressure; we have data in the database for 10 patients but in the excel export the field is empty for 5 of those patients)

    We have a form that has 2 version: in version 1 one field was missing. In version 2 this field was added. When we export the data to excel, both versions are exported but the added field is missing in the export. When we look at the definition of the export, there is not option to add this field to the export.

    Many thanks in advance for all help!

    Mark


    ----
    Mark te Pas
    AMC-CPCD Foundation
    Pietersbergweg 17
    1105 BM Amsterdam
    The Netherlands
    T: +31 (0)20-5661589
    E: [email protected]
This discussion has been closed.