We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Soap Error - <faultcode>SOAP-ENV:Server</faultcode>

Hi,

I am trying to access the web services and receive the following response. Any idea what the issue is?

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <SOAP-ENV:Header/>
   <SOAP-ENV:Body>
      <SOAP-ENV:Fault>
         <faultcode>SOAP-ENV:Server</faultcode>
         <faultstring xml:lang="en">Could not access envelope: Unable to create envelope from given source: ; nested exception is com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to create envelope from given source:</faultstring>
      </SOAP-ENV:Fault>
   </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Thanks

Richard
Tagged:
«1

Comments

  • richard.brookesrichard.brookes Posts: 54
    I should add this is using 3.2
  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    via Email
    can you share the request? make sure you are using the right soap version
    (not 2) and have included the wsse security headers
    On Apr 22, 2014 1:18 PM, "richard.brookes"
  • richard.brookesrichard.brookes Posts: 54
    endpoint is: .../ws/studySubject/v1/studyWsdl.wsdl

    <soapenv:Header>
    <wsse:Security soapenv:mustUnderstand="1" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
    <wsse:UsernameToken wsu:Id="UsernameToken-27777511" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
    <wsse:Username>root</wsse:Username>
    </wsse:UsernameToken>
    </wsse:Security>
    </soapenv:Header>
       <soapenv:Body>
          <v1:listAllRequest>?</v1:listAllRequest>
       </soapenv:Body>
    </soapenv:Envelope>
  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    via Email
    seems alright. I assume you've allowed ws for the root account.

    what are you using to send the request? I posted an issue with soapui a few
    weeks ago, maybe it's the same deal.
    On Apr 22, 2014 1:38 PM, "richard.brookes"
  • richard.brookesrichard.brookes Posts: 54
    I am using SoapUI 5. (also tried with Gerben's Access example with same results)

    The only non-vanilla part is NGINX being used as a reverse proxy. 
    Do you think that could be an issue?

    Richard.




  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    via Email
    I had a closer look at your request. In the body, could you try replacing
    this:
    ?
    with this:
  • richard.brookesrichard.brookes Posts: 54
    I tried removing the "?" - Still the same response.

    I tried over http rather than https - Still the same response...

    I removed nginx, connected directly to tomcat and it works...

    Has anyone managed to get webservices running through nginx?



  • toskriptoskrip Posts: 279 ✭✭✭
    Hi Richard,

    I have it running with nginx as reverse proxy without any problem. Did you try accessing wsdl directly via browser using reverse proxy URL (just to check whether the rule in a proxy configuration works properly)

    Tomas
  • richard.brookesrichard.brookes Posts: 54
    Hi Tomas,

    I could access the wsdl in a browser just fine.

    This is my nginx config, does it look right?

    location /oc-ws{
                proxy_pass http://127.0.0.1:9290/oc-ws;
                proxy_set_header Host $host;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  • toskriptoskrip Posts: 279 ✭✭✭
    this looks fine. Also if you can use browser to access the wsdl the forwarding has to works properly. Maybe SOAP UI is messing up the request. Can you also check nginx log files? When the request is not valid nginx usually log an error and do not forward the request.
This discussion has been closed.