We are currently working on the forum. For the short-term, all forum content will be in read-only format. We apologize for the interruption and look forward to collaborating with you shortly. All the best in your research!

Rule Designer Now Open Source



  • mokadamokada Posts: 10
    Hi all, 

    I tried Rule Designer and found Japanese characters cannot be used in "Message" of E-mail action. Any Japanese character corrupts when I save the rule. 

    I checked source code, but cannot find the cause.
    I think the cause of this error may be some codes in org.openclinica.ns.rules.v31.EmailActionType class.  The source code of this class is not published in GitHub yet. If anyone has access to the source code of the class, please check the code whether some code assumes specific text encoding.

  • drakosdrakos Posts: 16
    toskrip said:

    I know that preparing the development environment could be quite a quest for non IT person. I created Designer deployable archive (using java 1.6 jdk) which you can download at

    Installation instruction under linux, in typical OC environment:
    1. chown -R tomcat Designer-1.2.war
    2. mv Designer-1.2.war /usr/local/tomcat/webapps (Tomcat automatically extract the archive)
    3. vi /usr/local/tomcat/webapps/Designer-1.2/WEB-INF/classes/META-INF/spring/applicationContext-security.xml
    4. in this XML file you should find "oauth" element and adapt the accessTokenUri and user AuthorizationUri attributres to point to your OpenClinica instance
    5. vi /usr/local/tomcat/webapps/Designer-1.2/WEB-INF/classes/resources.properties
    6. in this configuration file the "allowHosts" property should include your OC instance hostname (something like: yourOCHostName:8080)
    7. vi /usr/local/tomcat/webapps/OpenClinica/WEB-INF/classes/datainfo.properties
    8. in this configuration file find the "designerURL" property and provide the URL to currently deployed Designer app. (something like: http://yourOCHostName:8080/Designer-1.2/)
    9. /etc/init.d/tomcat restart (restart your Tomcat)

    Now everything should be up and running. Give it a try and if you run in some troubles feel free to ask.



    Hello toskrip,

    I just finished installing the Rule Designer using the war file (1.2) and following the instructions that you were kind enough to share with the OpenClinica community.

    Everything worked fine and I would like to thank you for all your help and support.

  • rcaldeirarcaldeira Posts: 5

    Im trying to do the download of Designer-1.2 at http://www.skripcak.net/Designer-1.2.war, but the link are dead.

    Can you provide a new link to download designer-1.1 ZIP file?

  • GerbenRienkGerbenRienk Posts: 838 ✭✭✭
    Hi Ricardo,
    You can find it under "previous releases": https://dev.openclinica.com/distros/
    Gerben Rienk
  • MARKTASK001MARKTASK001 Posts: 6
    Good Day all. I have installed the designer, seem to have it configured correctly on my localhost 8080. I can login to the designer, but when I try to run it from within openclinica, I receive a page not found error. This is the url it is trying to open:


    Its that first http that seems to be causing the problem. Would appreciated any help on this

    Thank you
  • yogiyogi Posts: 25
    [email protected],

    i worked with the community Edition 3.3 and the rule designer 1.2. Everything is ok and working correctly in this composition. Now, i installed a new instance on the same tomcat of OpenClinica 3.6 CE. Nothing is changed on the rule compiler, configuration in datainfo.properties is set to the link of the rule compiler which is working in 3.3.

    And now the compiler doesn´t work in 3.6. If i want to start the rule compiler from openclinica i got a blank site. URL doesn´t seem be correct. In the middl is a redirect: "designer&redirect_uri=http%3A%2F%2Fdesigner13.openclinica.com" whats happen in 3.6? any changes? are you having experiences with that?


  • gpinkhamgpinkham Posts: 37
    Tomas.. Curious.. I see the default branch in the Guthub repo hasn't been updated in 2 years.. I see a few more recent branches.. if someone wanted to start trying out a local instance of the rules designer.. which branch would you recommend? 1.1-2? oc-6905? something else? thanks!!
  • toskriptoskrip Posts: 279 ✭✭✭
    Hi, I am still using the old 1.2, you may try the newer 1.3 or 1.3.1... I don't think that there have been many changes there.

  • amir129amir129 Posts: 2
    hi ,

    I followed the instructions and but when i click on Rule Designer. I get the following error in OpenClinica Designer

    Uncaught Exception
    Sorry, we encountered an internal error.

    This is the Designer URL I have:


    can you let me know where to check please.

Sign In or Register to comment.