Dataset not created

Dear all,

I am running OC CE 3.1.4.1 on a TOmcat 6 for windows 7
Everything was OK until I tried to export a dataset. I could select the appropriate CRF and create a dataset.
I click on an export and run now but nothing shows in my dataset archive.
I attached my log files. 
In the stdout I have this:

Exception in thread "[email protected]" java.lang.NullPointerException
at ch.qos.logback.classic.Logger.filterAndLog_0_Or3Plus(Logger.java:407)
at ch.qos.logback.classic.Logger.debug(Logger.java:526)
at net.sf.ehcache.util.UpdateChecker.checkForUpdate(UpdateChecker.java:63)
at net.sf.ehcache.util.UpdateChecker.run(UpdateChecker.java:51)
at java.util.TimerThread.mainLoop(Unknown Source)
at java.util.TimerThread.run(Unknown Source)

Thank you for your help.

Best.

Aurélien

Comments

  • bbaumannbbaumann Posts: 105 admin
    Hi Aurélien,

    Are there special characters in your dataset name? This was a known issue in 3.1.4.1. See https://docs.openclinica.com/release-notes/release-notes-openclinica-3.1.4.1 (scroll 2/3rd of the way down the page)

    If not, you might try rebooting Tomcat. There were some memory issues with extracts in older versions of OpenClinica. The reboot should help flush your memory.

    - Ben
  • Hello Ben,

    I just checked the dataset name and description. There are no special characters in it...
    I also rebooted the Tomcat server but nothing changed.
    Do you have any other idea ?

    Best
  • kristiakkristiak Posts: 1,317 ✭✭✭

    I have noticed when  another language configuration other than English is used in the operating system, the export does not work.  

    Regards

    Krister

  • AurelienmazeraudAurelienmazeraud Posts: 5
    via Email
    I checked with my provider. The OS is CentOs in English.
    Thank you for your suggestion!
    Le 24 nov. 2014 19:44, "kristiak" a écrit :
  • AurelienmazeraudAurelienmazeraud Posts: 5
    via Email
    So the export still doesn't work. I have no idea where to look to fix
    this... I really need a solution, so any suggestion welcome
    Le 26 nov. 2014 20:48, "Aurélien Mazeraud" a
    écrit :
  • kristiakkristiak Posts: 1,317 ✭✭✭

    Try an upgrade to 3.4. If I remember right there were some issues with 3.1.4.1. Just export the pgSQL file by using pgAdmin III. Create a new database in OC 3.4 and restore your data by using pgAdmin III. This way you will be able to avoid many issues.

    Regards

    Krister

This discussion has been closed.