Created and exported datasets contain no data

I’m trying to fix a problem on behalf of my client.  I’m by no means a Java developer and only became familiar with this program yesterday.  That said, I tried my best to document the problem and attempt fixes suggested elsewhere.  These include making sure the java language and location options are correct (en, US).


The problem exhibits itself when creating datasets in preparation for export. The resulting exported files contain blank data where there should be actual data.  My best guess is that the problem is related to this particular error message in the logs:

AUTHPRIV WARN  root o.a.o.d.e.DatasetDAO:508 - found no object: SELECT * FROM DATASET WHERE name = ? and study_id=?


This error message occurs as soon as one click’s the “Continue” button on the “Create Dataset: Specify Dataset Properties” page.  After finalizing the dataset creation and attempting to export in any format, the resultant files contain all of the appropriate field names, etc., but all of the data cells are empty.  Likewise, a couple of Java exceptions are thrown at the end, but these seem related to serving up the files, which works fine.


If anyone has any ideas on what might be the culprit, please let me know.  I've truncated the log file to isolate the specific operation for clarity. The system is on version 3.1.4.1 and is running under Centos.


Thanks in advance!



Comments

  • TNTN Posts: 2
    I have exactly the same error. Did you find the solution yet?

    I'm worried my postgres version (9.2.7) is the reason, but everything else but dataset's works just fine, so I'm not so sure.


  • GerbenRienkGerbenRienk Posts: 793 ✭✭✭
    That could well be, as postgresql 9 is not yet supported and is known to cause problems when exporting, I'm afraid.
    Gerben Rienk
  • TNTN Posts: 2
    Got it finally ...

    The Problem was the Postgres driver for me.

    This was the solution: https://forums.openclinica.com/discussion/15443/oc-3-3-fails-to-start
This discussion has been closed.