We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Data Extract Job Intermittant Failure

Hi,

We run several nightly data extracts, which until recently have always worked successfully. Jobs have suddenly started to randomly fail. Some nights they run successfully, others they fail giving the below error in the openclinica-ws log file.

12/02 01:00:00 [] FTP INFO   o.a.o.j.XsltTransformJob:114 - Job XsltTriggersExportJobs.Nightly BioChem Export started.
 12/02 01:00:02 [] AUTHPRIV INFO   o.a.o.d.h.RuleSetRuleDao:62 - EntityRuleSet0
 12/02 01:00:02 [] AUTHPRIV INFO   o.a.o.d.h.RuleSetRuleDao:63 - null
 12/02 01:00:02 [] AUTHPRIV INFO   o.a.o.d.h.RuleSetRuleDao:64 - hit count0
 12/02 01:00:59 [] FTP INFO   o.a.o.j.XsltTransformJob:212 - Finished ODM generation of job XsltTriggersExportJobs.Nightly BioChem Export
 12/02 01:00:59 [] FTP INFO   o.a.o.j.XsltTransformJob:861 - sending an email to john.******@ac.uk from john.******@ac.uk
 12/02 01:00:59 [] FTP ERROR  o.a.o.j.XsltTransformJob:515 - Error executing extract
 java.lang.NullPointerException: null
    at org.akaza.openclinica.job.XsltTransformJob.executeInternal(XsltTransformJob.java:242)
    at org.akaza.openclinica.job.XsltStatefulJob.executeInternal(XsltStatefulJob.java:23)
    at org.springframework.scheduling.quartz.QuartzJobBean.execute(QuartzJobBean.java:86)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:223)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)
12/02 01:01:02 [] FTP INFO   o.a.o.j.XsltTransformJob:560 - Job XsltTriggersExportJobs.Nightly BioChem Export finished.

If the data extract is manually kicked off it always completes successfully. They appear to fail at the point of transforming the .xml file in to which ever export format has been selected (.txt in this case).

We were running OpenClinica 3.4 when this error began. I have since downgraded to 3.3, but the problem persists.

If anyone could shed any light on the above it would be of immense help.

Thanks,
John

Comments

  • liu09liu09 Posts: 51
    Just wonder if this has been answered?
  • jjaymjjaym Posts: 6
    No it hasn't been answered. We still experience the problem daily, running version 3.4.1. now.
  • liu09liu09 Posts: 51
    we have experience with one of the servers, which is unfortunately not under my control. This server has been running WS service and have auto import job running.
    But I run it on my local machine which did not have any WS service or auto imported job, then it seems fine, we run version 3.5 though.
    Will you be able to have a separate server to have a test run ? I guess it is something missing in the database cause the trouble. Really somebody from OC team can answer that.
  • jjaymjjaym Posts: 6
    We also run the web service's and have auto data imports on this server. Sounds likely the WS is causing the problems then. I have migrated the system from a Windows 2003 R2 to a Windows 2012 64bit and the problem followed across the servers. So it is not a machine fault such as Java cache for example.
    I would use a virtual machine to test out other setups.
  • liu09liu09 Posts: 51
    I agree with you, it is not a machine specific problem. Migrate the sever means migrate the postgresql db with it, it the problem came from the db record, then the problem will be there. I think it is a good idea to run a clean environment without the ws and auto import jobs, and see what happens. Good luck with that, please keep me updated with your progress.
  • jjaymjjaym Posts: 6
    We are still experiencing the above, on Version: 3.12.2 now.
    Happy to supply logs if anyone wanted to look into/fix the issue.
    BW,
    John
Sign In or Register to comment.