We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Not Used option for Sex

I'm setting up a study for an X-linked disease.  The population will be only male, and as part of study setup, I indicate that Sex is not required.  However, it still appears as an field on subject entry.  Normally I wouldn't be concerned with this, it would just be extraneous data, except that the nature of the study means that if a female is enrolled, that should raise some red flags and/or be reported as a deviation, none of which am I able to do within the system at subject creation.  Is there a reason that sex does not have an option for "Not used" on the study build page like DOB, Person ID, etc.?


  • ccollinsccollins Posts: 379 admin
    Hi Byron, there's no real good reason it's different than other the 'not used' option for the other fields was added after the original design based on specific user needs and this one has never been made a priority. Ticket number is https://jira.openclinica.com/browse/OC-1150

    If you're able to write a patch that fixes it we'd love to add it.

  • GerbenRienkGerbenRienk Posts: 810 ✭✭✭
    Hi Cal,
    That would be two requests which I write here, as I somehow can not pull a request anymore(?) on github:
    in addNewSubjectExpressNew.jsp change line 181 into
    <c:if test="${study.studyParameterConfig.genderRequired !='false'}">
    and in addNewSubject.jsp change line 232 into
    <c:if test="${study.studyParameterConfig.genderRequired !='false'}">
    Many thanks,
    Gerben Rienk
  • ccollinsccollins Posts: 379 admin
    via Email
    That's great, thanks!
  • liu09liu09 Posts: 51
    Hi Guys,

    After following all the steps, it seems working fine for a user with admin right.

    However when log in as a data entry person, if you clicked the add new subject under the subject matrix, the sex selection shows up again. If you click add subject under tasks tab, click add subject, the sex option shows up there as well. Don´t do anything, just go back and click the add new subject under the subject matrix, the sex selection disappeared.

    Very strange behaviour, it seems related with the user right as well, I didn´t try other user, it would be great to have a solution.


This discussion has been closed.