We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Fail to install OC 3.7 or OC 3.8 on Ubuntu 14.04

Hi,

I could install all versions of OC up to 3.6.1 without any problems on Ubuntu 14.04. But starting from 3.7 the installation fails. I get the Error message "Error listenerStart", prededed by java.lang.NullPointerException. I tested with exactly the same system configuration (VM snapshot) all version from 3.6 to 3.8. Until 3.6.1 it works, starting from 3.7 it fails.

System configuration: openjdk-7-jdk, tomcat7, postgresql-8.4

I also verified, that tomcat and postgres work.

Has someone any ideas what I could try next to find the error?

Peter

Comments

  • kkrumliankkrumlian Posts: 25
    via Email
    Can you please send the logs.

    Krikor
  • lindsay.stevenslindsay.stevens Posts: 404 ✭✭✭
    via Email
    Most of the time, my deployment failures are to do with the database
    connection failing.

    Double check that the tomcat/openclinica.config/datainfo.properties
    settings for your database are correct.

    Also, even though the install docs imply oracle Java, I've found openjdk to
    work too so its probably not due to that.
  • parzerparzer Posts: 5
    The problem is solved. I started with the default configuration as it worked with all older versions. But the default database configuration in datainfo.properties does not work anymore. I had to explicitly change the settings to:

    dbType=postgres
    dbUser=clinica
    dbPass=clinica
    db=openclinica
    dbPort=5432
    dbHost=localhost

    Thank you all for the help.
This discussion has been closed.