We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Tomcat does not start

Hi,
I already installed and tried Openclinica on several notebooks and operations systems (Window 10, Debian 8.5/64bit). Now I tried to install oc on a 32-bit dell-notebook/ Debian 8.6. Everything works fine: I have access to PostgresSQL, I could install Tomcat and oc (all localy). But I got problem with starting Tomcat. service tomcat status gives me the following:
************************************************************************************
>service tomcat status
tomcat.service - SYSV: Tomcat start script for OpenClinica.
Loaded: loaded (/etc/init.d/tomcat)
Active: active (exited) since Mit 2016-09-21 13:40:00 UTC; 9min ago
Process: 433 ExecStart=/etc/init.d/tomcat start (code=exited, status=0/SUCCESS)

Sep 21 13:39:58 localhost su[451]: + ??? root:tomcat
Sep 21 13:39:58 localhost su[451]: pam_unix(su:session): session opened for user tomcat by (uid=0)
Sep 21 13:39:59 localhost tomcat[433]: Using CATALINA_BASE: /usr/local/tomcat
Sep 21 13:39:59 localhost tomcat[433]: Using CATALINA_HOME: /usr/local/tomcat
Sep 21 13:39:59 localhost tomcat[433]: Using CATALINA_TMPDIR: /usr/local/tomcat/temp
Sep 21 13:39:59 localhost tomcat[433]: Using JRE_HOME: /usr/local/java
Sep 21 13:39:59 localhost tomcat[433]: Using CLASSPATH: /usr/local/tomcat/bin/bootstrap.jar:/usr/local/tomcat/bin/tomcat-juli.jar
Sep 21 13:40:00 localhost tomcat[433]: Tomcat started.
Sep 21 13:40:00 localhost tomcat[433]: Tomcat is not running
Sep 21 13:40:00 localhost systemd[1]: Started SYSV: Tomcat start script for OpenClinica..
************************************************************************************

The difference of this output to another installation is the following line which is missing in the new installation:
Sep 21 11:03:45 ihmaz-hp01 su[485]: Successful su for tomcat by root
(Comes before this line: Sep 21 11:03:45 ihmaz-hp01 su[485]: + ??? root:tomcat)

I don't know what this mean. Does anybody can help me how to cope with this problem?

Thanks for any hint.

Installation:oc 3.11, jdk 7, posgresql 8.4, apache tomcat 7
Tagged:

Comments

  • dvmurraydvmurray Posts: 14
    Hi Giordano

    I seem to remember having this issue when installing a previous version of OC, I think the problem was the permissions had not been updated accordingly on the tomcat folder.

    Hope this helps

    David



  • giordanogiordano Posts: 12
    Hi David,
    Strange, why does this happend? A former installation on a 64-bit Debian notebook didn't cause this problem. Anyway. What does this mean? Where is the permission defined? It would be very nice if you could give me some advice.
    Thanks for replay and help
    giordano
  • giordanogiordano Posts: 12
    The problem could be solved thanks to this site:
    https://en.wikibooks.org/wiki/OpenClinica_User_Manual/ChangeLogLock

    The entries in table databasechangeloglock of the Database has to be deleted:
    delete from databasechangeloglock;
    Keyword to this problem is:
    Waiting for changelog lock....
Sign In or Register to comment.