We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Edit CHECK to make sure that data exists only in one field

2

Comments

  • kristiakkristiak Posts: 1,339 ✭✭✭
    via Email
    No the issue is that only one field may have data all the other three fields must be empty? Sorry if I was not clear about that. I attach the logic (sorry about the Swedish) but I'm sure you get the idea, only one of the evaluations points 0-5 should be filled in.

    Best

    Krister
  • ebsebs Posts: 137 ✭✭
    In that case just have one rule per field checking that the others are empty.
  • kristiakkristiak Posts: 1,339 ✭✭✭
    I have modified the rule, I hope I have understood it correctly as per the attached file.
  • kristiakkristiak Posts: 1,339 ✭✭✭
    When I change the rule to fit the actual e-CRF I get the following error
    "Your XML is not well formed, and does not comply with the Rules schema. Check it and try again. It returned the message: Line : 13 - The element type "Target" must be terminated by the matching end-tag "".
    XML file attached
  • ebsebs Posts: 137 ✭✭
    edited July 2017
    Try changing to the attached.

    Editing XML files in Notepad++ is easier as you can see the colour coding for the XML tags.

    Cheers
    Eric
  • kristiakkristiak Posts: 1,339 ✭✭✭
    via Email
    I have edited the XML files as indicated but now I get a new error message

    "Your XML is not well formed, and does not comply with the Rules schema. Check it and try again. It returned the message: Line : -1 - cvc-complex-type.4: Attribute 'OID' must appear on element 'RuleRef'."

    Best regards

    Krister
  • ebsebs Posts: 137 ✭✭
    Post up your xml.
  • kristiakkristiak Posts: 1,339 ✭✭✭
    Found a spelling mistake in XML but the correction did not help. I attach the corrected XML Can you use "" instead of "" ?

    Best

    Krister
  • kristiakkristiak Posts: 1,339 ✭✭✭
    I meant instead of the quote quote that you mentioned in your XML file?;
  • kristiakkristiak Posts: 1,339 ✭✭✭
    This is another version. The error message was "Your XML is not well formed, and does not comply with the Rules schema. Check it and try again. It returned the message: Line : -1 - cvc-complex-type.4: Attribute 'OID' must appear on element 'RuleRef'.
Sign In or Register to comment.