We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Double Data Entry save and exit buttons not working

Hi,

I am currently running a study on Openclinica community edition, version 3.14, and am experiencing a problem with double data entry. The data entry person saves the first run of data without problems. After the obligatory 12hr wait, openclinica offers to start double data entry, but the "save" and "exit" buttons in the data entry page are unreponsive, so the double data entry can't be completed, and I have to use the browser back button to exit the page. I have tried completing the DDE as a Study Director, and experience the same problem.

Would appreciate any help!
«1

Answers

  • jowakejowake Posts: 14
    To provide an update: the data entry persons were able to continue with the data entry after I "stopped" and restarted the data entry for each participant. The end result looks like DDE.

    Also, the DDE problems are site wide -- it doesn't work for any other of the studies on our site, including a new study I created just to test.
  • daniel71daniel71 Posts: 5
    I have the same problem. Are there any solutions for this?
  • ebsebs Posts: 137 ✭✭
    edited January 16
    I've never really used the feature in anger but did you ensure that the initial data entry was marked complete before attempting the second entry?

    https://docs.openclinica.com/3.1/openclinica-user-guide/submit-data-module-overview/enter-data-event-completing-crfs#content-title-4845

    Also note that certain user roles can avoid the 12 hour wait which would help in your testing - details in link above.

    Cheers
    Eric
  • jowakejowake Posts: 14
    Hi, all the openclinica rules on how to complete DDE have been followed. It has worked previously for another study on our server, but now it has stopped working for all the studies.
  • ro_silva79ro_silva79 Posts: 1
    I have the same problem. Did you guys managed to find a solution?
  • jowakejowake Posts: 14
    No solution so far.
  • maxramirez84maxramirez84 Posts: 2
    Hi, I'm experiencing the same problem. Save and Exit buttons are not responding. Let's me provide some more info.

    First of all, Save and Exit buttons are HTML disabled when DDE and this is why they are not responding:
    <input type="submit" id="srl" disabled="" name="submittedResume" value="Save" class="button_medium" onclick="disableSubmit(); this.form.submit();">
    Moreover, the section tabs and selector (on the top of the form) are not working. Tabs are not displayed and the selector is not responding neither. It seems that there's some problem with JavaScript. When loading the DDE page, I'm getting the following JS error:
    Uncaught SyntaxError: Unexpected token ; at DoubleDataEntry?eventCRFId=17:694

    Which is the following line of code:
    686 function DisplaySectionTabs()
    687 {
    688     TabID=1;
    689 
    690     while (TabID<=TabsNumber)
    691 
    692     {
    693         sectionId = TabSectionId[TabID-1];
    694         url = "DoubleDataEntry?eventCRFId=" + 17 + "&sectionId=" + sectionId + "&tab=" + TabID + "&exitTo=" +;
    695         currTabID = 1;
    696 ...
    At the end of line 694, between + and ; it is missing something!
    When I select another section through the selector, I'm getting another JS error:
    Uncaught ReferenceError: gotoLink is not defined at HTMLSelectElement.onchange (DoubleDataEntry?eventCRFId=17:804)

    Which is the line of code:
    <div class="formfieldM_BG_noMargin"><select class="formfieldM" name="sectionName" size="1" onchange="gotoLink();">
    However, the JS funtion gotoLink() is loaded:
    732 function gotoLink() {
    733 
    734     var OptionIndex=document.crfForm.sectionName.selectedIndex;
    735     if (checkDataStatus()) {
    736         window.location = document.crfForm.sectionName.options[OptionIndex].value;
    737     }
    738 }
    Any ideas?


  • GerbenRienkGerbenRienk Posts: 808 ✭✭✭
    Hi,
    It looks like you're using the oc3.14 version dated April 2018. This is a faulty version, which should be replaced by the latest version, as described here:
    http://forums.openclinica.com/discussion/16549/reassign-crf-to-a-new-version#latest
    However this version has also a bug, namely that special characters are not displayed in the audit trail, when extracting into odm-xml format. This has been reported and hopefully a new sub-version will be available soon.
    Gerben Rienk
  • maxramirez84maxramirez84 Posts: 2
    Thanks @GerbenRienk. Already replaced, we are currently testing that everything is working well.

    I have another question then. Should we replace OpenClinica-ws.war which is Version: 3.14 - Changeset: 20d4fc43fa07 2018-04-26 13:53 +0000 too?
  • jowakejowake Posts: 14
    Thanks again @GerbenRienk , we changed the file like you describe, and testing results so far look very good!
Sign In or Register to comment.