We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

Error during compilation today but not yesterday

I'm compiling OC 3.14 (mvn clean install -Dmaven.test.skip=true) and everything was smooth yesterday, but suddenly I get authentication error. Any idea what could be wrong?

"[ERROR] Failed to execute goal on project OpenClinica-core: Could not resolve dependencies for project org.akaza.openclinica:OpenClinica-core:jar:3.14: Failed to collect dependencies at oracle.ojdbc14:ojdbc14:jar:10g: Failed to read artifact descriptor for oracle.ojdbc14:ojdbc14:jar:10g: Could not transfer artifact oracle.ojdbc14:ojdbc14:pom:10g from/to openclinica.jfrog.io-libs-release (https://openclinica.jfrog.io/openclinica/libs-release): Not authorized , ReasonPhrase:Unauthorized. -> [Help 1]"


  • haenselhaensel Posts: 602 ✭✭✭
    edited January 2019
    Hello @altean

    I don't know why it worked for you yesterday but stopped working today. I don't know when OpenClinica started to gate their repository but it is done a while ago. Probably your local cache prevented you from this error until today.

    The solution is that you need to install all the missing libraries to your local maven repository (if you solve the ojdbc dependency you will get errors for other libs).

    Do you compile OC on a different machine then yesterday? If so you can try to copy the maven repository from this machine to the other one.
    If not you can download the OpenClinica-3.14 and extract all the libs from OpenClinica.jar within the OpenClinica.war. This will be a lot of work but should work reliable.

  • alteanaltean Posts: 12
    I was doing it on same PC. I did some compiling months ago and again yesterday. Thanks for response, I will try your suggestion.
  • haenselhaensel Posts: 602 ✭✭✭
    Did you checked your local maven repository for the missing dependency? If it worked yesterday it should be there.
  • alteanaltean Posts: 12
    I checked and it is there, but somehow ignored.
  • haenselhaensel Posts: 602 ✭✭✭
    What output do you get if you run maven offline?

    mvn -o clean install -Dmaven.test.skip=true
  • alteanaltean Posts: 12
    You are awesome. It worked! OC compiled without errors. I am quite new to Maven so sorry I didn't try this by myself yet.
  • haenselhaensel Posts: 602 ✭✭✭
Sign In or Register to comment.