We hope you'll join us for our 4/23 webinar on using data tables to apply reference ranges and AE codes in OC4. For more information and to register, visit https://register.gotowebinar.com/register/2882170018956684555

CRF Upload Issue - New Version Upload - OpenClinica 3.3.1

Hello Everyone,

We have some issues with OC 3.3.1 with uploading new versions for an original CRF.

Technical details:

OpenClinica 3.3.1
GNU Linux CentOS 6.5 32bits
Apache Tomcat 7.0.54
Java JDK 1.7.60
PostgreSQL - 8.4

Here is a screenshot with the involved error:

What we did is create a new study, select the status "Design" assign the first version of the CRF - no issues whatsoever. Starting with the second and the 3rd version OC started to complain as you can see in the screenshot. There is no preview for the CRF and we can't select the continue command to save the new version in the DB.

Any ideas on what can cause this error? It can be a DB issue or a file permission issue (although the original CRF didn't have any issues)?

Thank you in advance for any suggestions on how to fix this,

Best regards,

Razvan

Comments

  • enescu.razvanenescu.razvan Posts: 6
    UPDATE - Issue Solved!

    Hello Everyone!

    We managed to find the issue. I thought I post back what we discovered.

    The problem was the file we were using for the CRF. We are using Linux and Libreoffice and it looks like the Calc file we were using (Excel extension used) got corrupted between the usage of 2 Clinical Studies. So we started with a fresh template and the error went away.

    So if you will receive the warning in the screenshot one you need to start with a fresh template.

    Brgds.

    Razvan
  • agoodwinagoodwin Posts: 131 admin
    via Email
    Hello,

    Glad you solved the issue!

    Just a couple of observations I had:
    1. I noticed in your previous screen shot that in the "download" column,
    you have "N/A" listed. Typically you would see a download icon so that you
    can start with an existing copy of the CRF rather than having to start from
    scratch.
    >> Possibly issue / resolution: It would seem that the openclinica.data
    directory is not set up correctly (or that the CRF sub directory is missing
    files - the CRF templates)

    2. OpenClinica is only officially tested / supported for use with MS Excel
    files .xls (not .xlsx). Although I have successfully used openoffice to
    write these files with a little tweaking. I have an ubuntu OS on my laptop
    and used open office by putting my insertion point at the 1st blank row
    (below the data fields) and highlighting everything below and to the right
    and deleting it. I did this on every worksheet and could load the templates
    into OpenClinica. I'm not sure about libre office, but might be worth a
    try.

    Best Regards,
    Alicia


    On Thu, Jul 31, 2014 at 12:08 AM, enescu.razvan <
This discussion has been closed.