We are currently working on the forum. For the short-term, all forum content will be in read-only format. We apologize for the interruption and look forward to collaborating with you shortly. All the best in your research!

Main menu page does not display/load correctly

I've recently installed OpenClinica 3.3 on a vm running CentOS 6.5, Java jdk1.7.0_67, PostgreSQL 9.1.4, Tomcat 7.0.55, using https. The login page displays perfectly, but the menu page after you log in looks like it lost the navigation styling. I was thinking maybe i needed to change the permissions of the openclinica folder in tomcat/webapps but would appreciate any advice or guidance if anyone else has run into this issue, thanks.


  • richard.brookesrichard.brookes Posts: 54
    via Email
    Are you loading the page from a bookmark that contains the old
    jsessionid=xxxx? If so try removing it.

  • csabahalmagyicsabahalmagyi Posts: 21
    edited October 2014
    Your stylesheet file hasn't loaded. Check the page source. There should be a line similar to this:

    <link rel="stylesheet" href="includes/styles.css" media="all" type="text/css">
    If you have an absolute url there with port (or localhost with port) but you use reverse proxy, that can cause this issue.
  • marcusrmarcusr Posts: 3
    The stylesheet URL is exactly the problem, specifically the port is set to 80, which relates to the issue I have when I log out in that the URL for the log out link also points to port 80.

    <link rel="stylesheet" href="https://domain.com:80/OpenClinica/includes/styles.css" type="text/css">

    Any idea where this is set or how to modify it to drop the port?
  • csabahalmagyicsabahalmagyi Posts: 21
    edited October 2014
    I am not sure if it helps, but give it a try:

    Check your datainfo.properties and check what is under the sysURL (8). If you change the file, you need to restart tomcat.
  • marcusrmarcusr Posts: 3
    I don't think it's in datainfo.properties I had specified the IP address and then just tried to modify it to use the domain name, but same result. I suspect it might be in one of the javascript files, but I'm not quite sure where. I appreciate the suggestion though.
  • marcusrmarcusr Posts: 3
    edited October 2014
    And here's the answer to my issue: https://community.openclinica.com/openclinica-frequently-asked-questions#ISAFAQ1

    Or at least it should be, I'll update if I can get it working.
This discussion has been closed.