We are currently working on the forum. For the short-term, all forum content will be in read-only format. We apologize for the interruption and look forward to collaborating with you shortly. All the best in your research!

Have anybody installed OC4?



  • ccollinsccollins Posts: 383 admin
    via Email
    Hi All,

    Great to see enthusiasm in this topic, especially realizing there’s not a
    lot of detailed documentation on the OC4 code (yet). For anyone who hasn’t
    seen it, the basics of the OC4 Architecture are described in this blog post


    If you’re able to make it to the OC18 conference
    (only two weeks away!)
    we’re going to have ‘Birds of a Feature’ lunch session on OC3, OC4, and the
    future of the OC Community (session description below). The idea is to have
    a very open ended discussion where all ideas, questions, and perspectives
    are welcome, and use that to formulate some action items. Please join us!
    If you can’t, share your thoughts on the forum. I’ll make sure to report
    back the highlights of the discussion here.


    Session Description:
    The Community Spirit: The Future of OC3 and Migrating to OC4
    OC4 represents a generational leap forward in how you capture, manage, and
    utilize your research data. What does this mean for OC3? OpenClinica LLC is
    committed to its large base of OC3 users. We are working on pathways that
    ease adoption/migration to OC4, and eager to engage about the future of the
    community and ways to more tightly integrate the two platforms. Come share
    your ideas, needs, and questions on these important topics.
  • rollmaster25rollmaster25 Posts: 3
    edited November 2018
    haensel said:

    I tried to install OC4 but did not succeeded.
    As far as I do remember one of the main show-stoppers is the 'FormManager'-Service. I do not know this form manager and didn't found any information about it so I assumed it is a closed source product for enterprise users only.

    Regarding Auth0: The Auth0 library is directly used in OC4, so there is no way to change it to a different OAuth service without modifiing OpenClinica.

    In my opinion it is not possible to install OC4 as community version.


    for me the showstopper was not form service but user service

    in the config file there's a property

    Tried it with localhost and it doesn't work (returns 404 HttpException) also I couldn't find any refferences to that endpoint inside the app. That looks like an external service to me.

    I even tried to bypass it just to get the app working but by doing that I also removed important functionality (example: user roles) and I don't think it can work without it.
Sign In or Register to comment.